[REQUEST] NVMe mod for ThinkCentre M81 (7517 IS6XM mb)

I am trying to update to version but its giving me an error of " Error 8193: Intel (R) ME Interface : Cannot locate ME device driver" and then aborts the update.
I don’t know where to get or install the ME device driver.

Also in my device manager the “Intel Management Engine Interface” is showing the orange triangle but when I try to update it , I get a message that its already up to date.

The Lenovo package notes, relies only on Windows 7 support for the operation.
The device driver he needs ( on windows device manager “Intel(R) Management Engine Interface” is installed because you need it for the previous operation with FPT and dumps, so it could be an issue from the Lenovo package.

Gonna be straight with you… we know when users lack the experience on advance operations and it can be a risk for them… theres other solutions for this, but by then theres a “Bible” written by me on this thread and a lot of time given… i cant and most users cant, sorry.
Any way all that is required was already linked and all it takes is user time to read, learn and take their own chances, all the best.


1 Like

I thought I would try this again with a fresh head today but I am getting the

Error 9470: Fail to load driver (PCI access for Windows)
Tool needs to run with an administrator privilege account.

I am confused as to why that is coming up again, please advise.

Sir… i dont want to be rude… but tell me, do you read whats in front of you or do you simple ignore it?
“Tool needs to run with an administrator privilege account.”

EDIT: Do you see the MEI loaded driver in Dev.Management? Is the ME_DIS as default or factory…

That’s the weird thing I thought that I was in cmd ADMIN.

sorry to sound dumb but whereabouts in Device Manager will I see this to check for it

Are you making fun of me? Its seems so… im about to leave it as it is…
What is the windows device manager? Where do you see the current state of an installed driver and hw devices of a system?
What is to you, that capture that i posted earlier?
This is an advanced forum with a minimum of user knowledge, at least… your out of your league sir

EDIT: Expand “System devices” → “Intel(R) Management Engine Interface”

If its loaded, and you had access to it when used FPT tool… dont know whats happening on your side, period.

1 Like

no I know where the device manager is and I am not making fun of you believe me .
After I have the device manager up I can’t seem to find the MEI driver so was wondering in which section of the device manager it was in …

Again I am sorry if I am not clear.

UPDATE … yes it seems that I have no Intel in my system devices.

UPDATE 2 … I managed to install it again but am having an orange/yellow triangle on it

… shutdown the system, put ME_DIS back to original position, CLR CMOS with jumper 5sec, take out CMOS battery, AC power unplugged 2m, restart, run FPT.exe -greset (It may not work now…no driver loaded), reboot. Did you flash anything?

You’re about to get a corrupted bios or its already corrupted…at least the ME FW image…
This is the issue with unexperienced users who dont know what their doing or paying attention to details…

1 Like

MeatWar , thanks for your help and bearing with me even though I am a Dumb**s.
I took a risk and used AMI AFUWin64 v3.05.04 with GAN support flasher which I used to make a backup, then used it again to reflash the modified bios.
I made my changes to the backup bios file using the UEFITool program.

When I go into bios, the Nvme adapter is recognized in the Boot Sequence as the letter H.
Is that normal ? I haven’t installed an OS on the nvme drive for me to test it out yet.

H… is that normal… damm its a letter and i dont know how many drives boot ready devices you have in your system… is it normal i dont know
Has the NVMe disk any data or boot partition on it… i dont know.
Final advice to you and this thread, follow Fernando’s guide and install a fresh windows.

All the best, over_n_out, good luck.

1 Like

Thanks will do that :+1: :grinning:.
I appreciate you bearing with me.
I have 2 old hd (for storage) and a sata ssd which has the main OS right now .

I plan to get rid of them once the nvme drive has settled down.
Nvme has nothing but an old game folder which I copied to see the speed of copying.
It was never a boot drive, just been purchased recently

@cn900 @MeatWar I have a lenovv is6xm mainboard ,bios version 9HKT58A.i got the bin file,but it display different

why?please help.thanks.

Different from what…if you mean not displaying as the update package in the UEFItool, yes its correct.

The IMAGE9H.ROM is a Lenovo update file and what you’re showing is your dumped system or a downloaded one from a web user.

Nothing changes regarding the previous instructions.

thank you.I can’t find this name **8D4AB7ED-99B0-4389-84D4-557C449610DC in my bin file,so where place should i insert the NvmExpressDxe_Small.ffs?thanks again!

I’m not familiar with that screen shot from this forum…

Follow the guide [HowTo] Get full NVMe Support for all Systems with an AMI UEFI BIOS - Special Topics / NVMe Support for old Systems - Win-Raid Forum (level1techs.com)

EDIT: Glad you made it, enjoy it.

Thanks!I use this guide on my lenovo is6xm maniboard,it worked!nvme HDD is so cool!,so fast! Thank you very much!

@MeatWar Hi.Excuse me for my English.I used this guide on my lenovo is6xm mainboard,it worked OK.Thank you.I have an another question,My pcie 4X to nvme can bootable,but pcie 1X to nvme cannot bootable,it can normal use in the windows10,11,it only can’t bootable,please help me.Thank you very much!

I hate the “Please help me”… always sounds a matter of life and death… and this is usually just cheap Chinese hardware pcbs adapters…
Why dont you ask the Chinese that small issue you found, you’re asking here why, probably, a cheap/lousy pcie adapter boots with a certain disk on a slot and not on another…
Lets see…maybe the adapter is “Pure” s****, maybe the adapter doesnt like the disk, maybe the adapter doesnt like the motherboard slot… maybe the disk doesnt like the adapter…
This is not NVMe DXE driver related or mod.
Clear picture for you now ???

EDIT: No need the “Sorry”, its just those kind of obvious issues that its just pure logic 0 or 1 and has nothing to do with the forum, the mod or the original content of you initial query, this is a user task to “debug” it… of course its hard when a user only have one motherboard to test it, one adapter and on disk…

Sorry.I try another PCI 1X adapters.