[Request] NVMe support for 2 old Gigabyte BIOSes

On my original Thread, i was dircted here…
[Guide] How to get full NVMe support for all Systems with an AMI UEFI BIOS (350)
I know it’s a very long starting thread but i tried to give all of the information i think has some relevance.
Got a really good recommendation on “Lost_N_BIOS” if you are reading this thread:-)

Hello and thanks with advanced to whom who can help.
Never before tried something like bios moding.

i have a
3 * Gigabyte - GA-Z68X-UD3H-B3 (rev. 1.3) using uefi firmware U1n (BIOS American Megatrends Inc. U1n, 11/07/2016)
1 * Gigabyte - GA-H97M-D3H (rev. 1.0) using uefi firmware F7 (BIOS American Megatrends Inc. F7, 03/08/2015)
(if you will read in bios section in this MOBO page, you will see that F5 bios says “Support NVMe device” does anyone know if it including as a BOOT Device?)

i would like to add NVMe drives (Samsung 970 EVO Plus NVMe) insted of the samsung 860 Evo 2.5" because of changes to our factory floor and I’m going to use a custom chassis for this PC’s (windows 10)

if some one can help creating the necessary bios files, it would be very appreciated!
& another 2 questions:

can i install 2 NVME drives in one pc? (one for OS, one backup drive)
Do i have a size limit? (for example, 2 Terabyte samsung 970 evo plus)

I’m aware i will not benefit the full preformance from it bcz i use PCIe gen2 slots , my problem is about actual space not preformance.

the adapter that i intend to use will be this one if what i’m asking is possible, unless some one think i should use other adapter… suggestions or better products to support compatibility are wellcome:-)

Update: after carfully reading in this forum and others, i didn’t understand something to the fullest.
If NVME Implantation is possible, i would like to use RAID 5 config (using 3 or 5 sata onboard ports) or RAID 10 (using 4 sata onboard ports) on one of the z68 pc as backup solution for all other stations from the left over 500GB samsung 860 2.5" drives.
So is there a problem with RAID config while using NVMe drives?

@it.omri :
Here are some answers/comments from my side:

  1. The F7 BIOS for the Gigabyte GA-H97M-D3H has already native NVMe support and is ready for the installation of Win10 onto an NVMe SSD in UEFI mode. Consequence: There is no need to modify this BIOS.
  2. The U1n BIOS for the Gigabyte GA-Z68X-UD3H-B3 is one of the very first AMI UEFI BIOSes, but within its “DXE Driver Volume” is nearly no space for the insertion of an additional NVMe module (not even for the “small” variant).
    My proposal to get more available space for the insertion of the NVMe module: If you don’t use the Wake-on-LAN feature, I recommend to remove 1-2 DXE modules, which support networking while booting.
  3. Yes, you can insert 2 NVMe SSDs (provided, that there are 2 appropriate PCIe slots available and the related PCIe lanes are not blocked by another device).
  4. I am not sure, whether your Z68 chipset mainboard will offer the option to manage simultaneously
    a) booting off an NVMe SSD (after the insertion of the required NVMe module into the BIOS) and
    b) working with an Intel SATA RAID array.
    You will have to test the RAID configuration once the OS has been properly installed onto the NVMe SSD. The OS installation should be done anyway after having removed/unplugged all other HDDs/SSDs except the NVMe one.

@Lost_N_BIOS :
Do you have another/better idea how to help it.omri?

  1. Thats great!
    2. I do not use wake on lan on those machines
    3. Based on the manual there is a diract path to the PCIe lanes as can be seen in the pic attached.
    4. So anyway to know is only after installing os on NVMe drive, based on what you say, i will be happy to be directed to the right place in order to know in advance if possible.


@it.omri - In addition to what Fernando mentioned above - you may also be able to remove or make 1px square black boot screen logo too

What CPU are you using on the Z68X? Have you already used this UEFI BIOS with that CPU, and have gotten used to and accepted all the limitations imposed by the hybrid UEFI BIOS?
I ask this, because if you have not used that BIOS already, you may want to try it for a while before wanting to get it modified, because those BIOS for UEFI Gigabyte before Z77 have issues (CPU multiplier locked to 31 max I think, and some other stuff I cannot remember now)
Anyway, they are really only suggested used with IVY CPU, and even then I still suggest to users they may want to stay on the older non-UEFI BIOS instead because there is not so many bugs (Even if you use IVY there too)

“I think” You can use RAID with NVME, the NVME will be ran using AHCI protocol same as other non-RAID member disks, nothing to worry about there
However, depending on the board layout and your PCIE slot usages, some SATA Ports may be disabled, you’d have to check manual of each to confirm if this will be an issue or not
I didn’t check, but I know sometimes this is case, but mainly usually only applies if you use onboard M.2 slot, but not always.

As for NVME Mod BIOS on Z68X, please wait, I will see if I can sort for you without module having to be removed

I’ve been using uefi bios on both since they realeased.
Right now im using i3 gen 2, but upgrading to i7 gen 3 on z68, and i7 4rd gen on the h97, all of the above will use 2*8GB DDR3 1600 {don’t know yet if enabling Intel XMP for stability} modules corsair vangace pro for dual channel.
Proudly can say the realse of U1n came after U1m had problem with usb3.0 that i had to fight gigabyte on this subject… Wish i still had the documentation of it.

See my edit above, about logo. Good to hear the UEFI BIOS has been working OK for you

I would like to keep the oem logo on startup, but if i must take it of for nvne to work… So be it i guess:-(

Well, sometimes the logo can be resized, or large black extra portion cut off, either way it looks exactly the same. However, I tried and still can’t build BIOS like that either
Also, there is 3-4 logo type images. One big award one, and one additional long black strip used if no hotkey strip info is shown, and one big Gigabyte one (The main thing you consider logo) << That last one is the one usually cut or resized.
I can remove the the long black non-hotkey one + replace edited main logo, and build this BIOS properly using small NVME Module, if that would be OK with you?

Here is the logo edit that is done, click to view full size


So, if that is OK with you, let me know, I will upload BIOS for you tonight when I get back (it’s done, but I have to run so can’t wait fore your reply or upload now)
This way no hardware modules need to be removed, in case you decide you need to use any of that kind of stuff later (wake on Lan/Boot to Lan ect)

Sounds great! The full award logo i think u can completely remove
Sounds like u know exactly what u do😊

@it.omri - It only worked safely if I remove the long thin black one that covers hotkey strip text if you choose to hide that (and I think that is a hidden from user setting anyway). This is OEM2 if you extract them with AMI ChangeLogo or UEFITool and look at the images.
Here is BIOS, flash via Qflash only, do not use FPT as this is stock edited BIOS - https://ufile.io/891qni3v
* New link - http://s000.tinyupload.com/index.php?fil…925327462683223

Change Log - * NVME Small Insert
1. OEM Logo2 Removed (GUID - 86EE84E2-3375-41A1-AFBA-847BD29663AA)
2. Main logo edited per included image (Seen above as well, cut off excess on bottom)

Flash via QFlash

If it turns out the other way around with the hotkey text images, ie you now see hotkey info at bottom of boot screen and you didn’t before, let me know I will remove the opposite one instead

Qflash? You mean the internal bios flashing tool?
Thanks! Really appreciate it
I’ll update u soon how it works.

@it.omri - You’re welcome! Yes, that is the only safe way to flash BIOS on these boards, unless you use the included DOS utilities with BIOS.
If you have not already flashed to this BIOS as stock, do that first using the DOS tools, especially if you are not already on the UEFI Beta BIOS type
Then use Qflash. Do not use @BIOS

@it.omri - All OK?

@Lost_N_BIOS , unfortunately we had a schedule change that is a very big time consumer, so i didn’t get to check it yet… But on the moment i will, i will give an update concerning the matter, promise:-)

@it.omri - OK, no big deal, I just had your tab open all this time, and wanted to close it, so just checking in to see if all was OK or not. Yes, please update when you have a chance, thanks

I still didn’t test it with NVMe drives, but have checked if the modded UEFI firmware have any problem with USB 3.0 ports on the back panel (as informed here: [Request] Bios MOD for GA-Z68X-UD3H-B3 (rev. 1.3) UEFI BIOS (USB 3.0 fix, OC setings missing & NVME Support) ), and it does stopped working even after using my own saved profile.
Only when reverted to my version U1n, the back panel USB 3.0 ports came back to life.
I suspect that the version i have is not the same U1n on the official gigabyte site, but one provided by them in email after a big fight with the support team regarding the USB problem a few years ago.
so… @Lost_N_BIOS , i’m adding links to my version of U1n Bios and Profile, think you can make the MOD i asked for on my original post on the version i provide?
https://drive.google.com/file/d/1jg8smng…ew?usp=drivesdk (BIOS, Preconfigured in a way that legecy support is completely disabled & some other stuff)
https://drive.google.com/file/d/1jgO1u_v…ew?usp=drivesdk (Profile i created before flashing the ROM, tried to use my configuration profile on your moded BIOS but alas it did not solve the USB 3.0 problem)
i believe that if you mod the version i have, USB 3.0 will stay function, and only then i will be able to test NVMe Drives in a week or so.

Thanks to all of you guys, never thought an unofficial forum for OEM products will be a greater help then the official support team!

P.S: i’m thinking about contacting Gigabyte about the version they have and send them mine so they could upload it as official… should i?

@it.omri - the Z68X-UD3H BIOS here already tested by another member, it’s OK Yes, seems you both ran into odd USB 3 issue, I mean odd you found way to make it work.
Or yes, maybe your version is not same one on Gigabyte site? I’d have to compare them via hex to see for sure. Please upload for me an untouched (not modfied) version of U1n they sent you, then I will compare it with the one on their site and or do the mods again if it’s not same one.
I don’t want to use the files you provided above because they have been edited, any edits you want to apply you can do after you test the edit I send you, that way we know if my edits are OK AND others can use that as a stock only modified BIOS too.

I do not have an untouched version… This is the only one i have.

@it.omri - Send me the one Gigabyte sent to you directly, without you editing it (That would be untouched, this is what I mean)
Then I can compare with online one and see if same/different

@Lost_N_BIOS I understood what you asked, the answer is still no…
I do not have the original they sent… Only the one with my settings

Why do you not have the one they sent??? Check your email, it would still be there too.
If you cannot find it, then there is no way I can compare with the one they have online now, so nothing we can do there.

I can carry on with your edit, but for other users, you’d have to show me what you changed, unless I can see it all obviously in AMIBCP (like if you changed access level), if you changed defaults in fail safe or optimal collumn you’d have to tell me exactly what you changed to what so I could set it back to default.
But, even with that, it could not be compared to what they have online now. Maybe we could tell from build date though, but that would be all we could compare and they may not have changed that in the BIOS info and or in the actual build date windows sees for the file (this can be kept same always too, no matter when it was actually edited)