[Request] NVMe Support for GA-EX58 UD3R

The author is unfortunately not interested. I wrote to see if anyone else can edit the bios. I’m running the original bios, no problem. but when i install modded bios the system won’t boot. thank you for taking the time.

Translating may translate some words differently, I’m sorry about this, what I mean may not be understood

@Burhan294 Welcome to the Win-RAID Forum!

Since your request has nothing to do with the topic of the thread where you posted it (your old mainboard doesn’t have an AMI UEFI BIOS), I have moved it into the better matching “BIOS Moddig Requests” section and started a new thread.
Although you had addressed your request (in turkish language) personally to me, I cannot help you due to missing own experience in your requested BIOS modification.
The easiest way to get full NVMe support with your LEGACY mode mainboard is to buy a Samsung 950 Pro. This specific NVMe SSD has a LEGACY mode NVMe Option ROM in the box, which will allow you to boot off it without the need of any BIOS modification.

Good luck!
Dieter (alias Fernando)

@MeatWar Just for your information

I have read the bios edit posts. but I still couldn’t. As far as I know, you are talented at this. I would really appreciate if you can help with this. Or someone who can. I can give you the necessary information, if you are interested, motherboard, nvme ssd information @Fernando

If you want help, you should have given all required information within your first post:

  1. The details about your mainboard (isn’t it a Gigabyte GA-EX58-UD3R Rev.1.0?)
  2. The manufacturer and model of your NVMe SSD
  3. The HardwareIDs (VEN_XXXX&DEV_XXXX) of the NVMe Controller, which is inside of the SSD

Motherboard -GA-EX58-UD3R rev1.0
NVMe SSD - WD Green WDS480G2G0C-


If you want to be able to boot with your old mainboard directly off the WD NVMe SSD, you have to insert a matching NVMe Option ROM into the latest BIOS, which is offered by Gigabyte for your specific mainboard. It seems to be the BIOS version F12Q, which has the Phoenix BIOS architecture and can be opened by a tool named CBROM.
Here is the content of the original BIOS:

This is what has to be done:

  1. Download the universally usable NVMe Option ROM. You can find the download link within the start post of >this< thread. It is recommended to read all posts of that thread!

  2. Unzip the package named NvmeOpRom and customize the HardwareIDs, which are within the Option ROM named NvmeOpRom.bin, by using the tool named OpRomCfg.exe. You can check your work by opening the original and the customized Option ROM with any Hex Editor (I prefer the tool named HxD).

  3. The next step is the insertion of the customized NVMe Option ROM into the original BIOS by using the appropriate Phoenix BIOS tool named CBROM.EXE. >Here< is a guide how to do it.
    The modded BIOS should look like this:

  4. The last and risky step is flashing the modded BIOS into the mainboard’s BIOS chip.

Good luck!

Unfortunately I can’t. I’ve been reading for 3 hours. I try everyhing. Would you do this for me? You’d be doing me a huge favor. You make me happy @Fernando

What did you try and where are the results? Into which problems did you run?

As you may have realized, I have written a lot of detailed and pictured Guides about how to modify a mainboard BIOS. My intention was to give interested users a basic help, but not to do the requested BIOS modification myself. In the latter case all days/weeks I have spent for my Guides would have been wasted time.

Tools (CBROM.EXE and other tools) are not working on my system. my computer is windows 8.1

Tools like CBROM are running fine with all Windows Operating Systems from XP up.
The only precondition is, that you have to run the Command Prompt with Admin rights (right-click onto the cmd.exe and choose the option “run as Admin”).

I’ve read all the manuals but I can’t, the tools give errors. can you do this for me :frowning: you are much more knowledgeable than me

Post a screenshot showing the error message.

This application cannot run on your computer

Contact the software publisher to find a suitable version for your computer

Is it possible, that you don’t have Admin rights for your Operating System?
Who is the licence holder/main user of the Windows OS?

Mine. (I’m running as administrator) I couldn’t do whatever I tried. That’s why I was insisting that you do it. for me

The tool CBROM32_198 is dated 08/27/2008 and works fine even with my 64bit OS Win11 x64. So it should be usable with your Win8.1 system as well.
Do the following:

  1. Create a new folder within the root of your system’s drive C: or Drive D: and name it “TEST” (without quotation marks).
  2. Download the tool named CBROM32_198 from >here< and unzip its content named CBROM.exe into the just created folder.
  3. Copy the “pure” original BIOS named EX58UD3R.12Q into the same folder as the CBROM.exe file.
  4. Run the Command Prompt as Admin, navigate into the just created folder named TEST and run the following command:
    CBROM EX58UD3R.12Q /D
  5. Post a screenshot about what you get (by pressing the Alt+Print keys and inserting it into the MS tool named Paint).

Meanwhile I have realized, that you just want to get my already finally modded BIOS, but I will not deliver it to you. As I have written very often, I generally do not offer a modded BIOS on request.
My advice: Cancel your project to get full NVMe support by a BIOS modification.
A user, who is not even able to open the BIOS file for his/her mainboard, should not try to flash a modded BIOS.

1 Like

I have a screenshot like this, did I succeed? I haven’t tried it yet.

The reason I failed is because the translator translates some words differently, so I’m having a hard time. Also, CBROM was giving errors all the time, so I made my system windows 10 and after that I didn’t get any errors.

EDIT: I downloaded, installed, no smooth shutdown and reset. but nvme ssd doesn’t show up in HDD list. where did i go wrong? I saved the installation mode as AHCI,RAID,IDE, still it did not appear.


  1. Did you flash your modded BIOS? If yes, please attach it.
  2. How/where is the NVMe SSD connected to your mainboard?
  3. Which devices are shown within the “Disks” and “Storage Controllers” sections of the Device Manager?

I flashed it without any problem.
NVMe ssd plugged into pci ex x16 slot
I see NVMe ssd and other sata ssd in device manager and I can use it. but I don’t see NVMe SSD in bios

The BIOS may not show the NVMe SSD, but it has detected it (otherwise the Device Manager wouldn’t show it).
Now you can try to get Win10/11 installed onto the NVMe SSD by booting off an USB stick with the OS Image on it (after having removed or disconnected all other disk drives).

1 Like