[Request] NVMe Support for GA-EX58 UD3R

Is it possible, that you don’t have Admin rights for your Operating System?
Who is the licence holder/main user of the Windows OS?

Mine. (I’m running as administrator) I couldn’t do whatever I tried. That’s why I was insisting that you do it. for me

The tool CBROM32_198 is dated 08/27/2008 and works fine even with my 64bit OS Win11 x64. So it should be usable with your Win8.1 system as well.
Do the following:

  1. Create a new folder within the root of your system’s drive C: or Drive D: and name it “TEST” (without quotation marks).
  2. Download the tool named CBROM32_198 from >here< and unzip its content named CBROM.exe into the just created folder.
  3. Copy the “pure” original BIOS named EX58UD3R.12Q into the same folder as the CBROM.exe file.
  4. Run the Command Prompt as Admin, navigate into the just created folder named TEST and run the following command:
    CBROM EX58UD3R.12Q /D
  5. Post a screenshot about what you get (by pressing the Alt+Print keys and inserting it into the MS tool named Paint).

Meanwhile I have realized, that you just want to get my already finally modded BIOS, but I will not deliver it to you. As I have written very often, I generally do not offer a modded BIOS on request.
My advice: Cancel your project to get full NVMe support by a BIOS modification.
A user, who is not even able to open the BIOS file for his/her mainboard, should not try to flash a modded BIOS.

1 Like

I have a screenshot like this, did I succeed? I haven’t tried it yet.

The reason I failed is because the translator translates some words differently, so I’m having a hard time. Also, CBROM was giving errors all the time, so I made my system windows 10 and after that I didn’t get any errors.

EDIT: I downloaded, installed, no smooth shutdown and reset. but nvme ssd doesn’t show up in HDD list. where did i go wrong? I saved the installation mode as AHCI,RAID,IDE, still it did not appear.


  1. Did you flash your modded BIOS? If yes, please attach it.
  2. How/where is the NVMe SSD connected to your mainboard?
  3. Which devices are shown within the “Disks” and “Storage Controllers” sections of the Device Manager?

I flashed it without any problem.
NVMe ssd plugged into pci ex x16 slot
I see NVMe ssd and other sata ssd in device manager and I can use it. but I don’t see NVMe SSD in bios

The BIOS may not show the NVMe SSD, but it has detected it (otherwise the Device Manager wouldn’t show it).
Now you can try to get Win10/11 installed onto the NVMe SSD by booting off an USB stick with the OS Image on it (after having removed or disconnected all other disk drives).

1 Like
  1. Unzip the package named NvmeOpRom and customize the HardwareIDs, which are within the Option ROM named NvmeOpRom.bin, by using the tool named OpRomCfg.exe. You can check your work by opening the original and the customized Option ROM with any Hex Editor (I prefer the tool named HxD).

Can you explain this explanation a little bit because I can’t open the NvmeOpRom.bin file (OpRomCfg.exe). I modded it without making any changes, maybe because the required module is loaded. Also, thank you for your time, by the way. the only problem is just adding modules to the nvmeoprom.bin file.

I knew it all along that he didnt changed the HW ID…

You need to use the OpRomCfg.exe and set the ID of the controller on the NmeOpRom.bin, in this case yours is VEN_15B7 DEV_5019 (from the WD Green WDS480G2G0C, you reported earlier), save it and this is now the correct file to insert in the bios.

1 Like

I understand bro. OpRomCfg (file name> (vendor id) <device id)

I’m overlooking this. Sorry for my first time dealing with bios stuff. I was looking to open the nvmeoprom.bin file with the (hxd) program to edit it, and where to write the device ID :slight_smile:

Option ROM modules like the file named NvmeOpRom.bin can only be opened by using an Hex Editor like HxD. You can download it from >here<.

If you fogot to customize the NVMe Option ROM to make it compatible with the NVMe Controller of your specific NVMe SSD, you should do it. Otherwhise you will not be able to boot off the NVMe SSD.
This is how the related content of the NvmeOpRom.bin looks after having successfully customized it (corrected by me on 05/18/2023):

The “Little Endian” Code you can see (B7 15 19 50) is misleading, but correct (look >here<).

Note: Since you obviously have inserted a wrong (not customized) NVMe Option ROM, you have to redo the integration of the module from scratch by using the original BIOS as source. To avoid a mix-up I recommend to delete the previously modded BIOS.

1 Like

I added a module to the NvmeOpRom.bin file. I didn’t delete anything from it. Then I added it to the original bios. I installed with usb flash. NVMe ssd didn’t show up in boot options. If I install windows 10, you say it will appear on boot. Did I get right?.

By the way, I was using clover boot usb with nvme ssd windows 10 installed for 2 days with original bios. so NVMe ssd has windows ready. Is it normal that the nvme ssd still doesn’t show up in the boot options?

Yes, it doesn’t boot, perform a CLEAN UEFI Win10 OS installation.
Clover is a BOOTLOADER

Due to the missing NVMe EFI module I doubt, that an installation in UEFI mode will work.

1 Like

EDIT: You are right Fernando… how can it be possible if its legacy bios only with the disk controller, ignore my foolish statement… :face_with_peeking_eye: :upside_down_face:

I prepared windows 10 usb flash to NVMe ssd in 3 different ways, I tried, but still can’t install windows 10.
I get the error (We couldn’t create a new partition or find an existing partition).

HDD, sata hdd, I tried to remove all other storage devices. Bios mode (AHCİ)

Where is the problem?

Although I don’t know the exact reason for your current problem to get Win10 installed onto your NVMe SSD, I suspect, that it has something to do with the content or with the connection of your NVMe SSD to your mainboard.
Provided, that the BIOS modification has been done correctly and the modded BIOS has been properly flashed, you may have to create the boot sector (“Master Boot Record”) on your NVMe SSD manually. >Here< is a Guide about how to do it.

Here Try this bios.
And reinstall windows (without Clower). Normal windows installation.
GA-EX58-UD3R rev1.0.rar (586.2 KB)

Probably you were wrong. Not (7B 15 19 50) but (B7 15 19 50).


You are absolutely right - it was my own typo while entering the OpRomCfg command, which has lead to the misleading HxD picture I had posted >here<. To avoid future problems I have replaced the picture by a corrected one. Fortunately I did not share my wrongly modded Option ROM and BIOS files.

Thanks for having had your heads up!!! :+1:

Thank you very much, I’ll try right away