[Request] P8Z77-V LK NVME Bios Mod

Rely ONLY on user own project/guidance… the forum cant be responsible for any user provided files and its own functionality/integrity.
It was your only choice to use a file provided by a user with several modifications, as your only request was NVMe mod.

A forum is a open-house for the well intended and others… users should read guides and similar user experiences, take their own conclusions and as in real life, there’s always some one that can take advantage of unexperienced users, for their own “testing” purposes, situations that sometimes “escapes” admins control or missed.

Always remember that a user forum is primary the sharing and exchange info on a user encountered issue and trying to get the best change to resolve it, that’s why the guides are a valid tool and the primary direction pointed to a user.

it was shown in the msg thar GPU didnt support UEFI boot.

what is your gpu?

R9 290 …it does not support UEFI …i’m trying to find a bios for the video card that has UEFI GOP support now .

Which R9 290 are yours? or maybe send a gpuz screenshot here?

Sapphire Radeon R9 290X 4GB GDDR5 PCI-Express Graphics Card Battle Field 4 Game Edition 21226-00-50G

here try this (make sure to backup vbios before doing so):
R9290XBF4.zip (100.4 KB)

Bios taken form TPU web here, updated the gop to 1.70

That got rid of the message saying VGA not supported …it also now does not auto change the CSM mode .

But now i get just this

Maybe try to read point 4 of this: [HowTo] Get full NVMe support for all Systems with an AMI UEFI BIOS

Problem is also happened here: [OFFER] Asus P8B75-M BIOS v1701 NVMe, EFI_ROM microcode update

GPU-Z confirms UEFI …installed Windows on SATA drive no problem

tried both bios.ROM you made …bios never sees NVME or PCIE drive , I have both to test .

Never get past this

Success verification (the NVMe SSD has to be connected!):

  • Enter the “BOOT” section of the BIOS and make sure, that “CSM” has been set to “Enabled”. Then look for the listed bootable Disk Drives.
    If you now can see a new disk drive named “PATA” or “PATA SS”, you can be sure,
    a) that you have correctly inserted the NVMe module into the BIOS and
    b) that the modded BIOS has been successfully flashed.
    Note: Don’t try to boot off the listed disk drive named “PATA” or “PATA SS”! You will not succeed, because the required Option ROM is usually missing within the NVMe SSD. Nobody (except the user of a Samsung 950 PRO) is able to boot off an NVMe SSD in LEGACY mode.

ah ha…I decided to downgrade Bios to 1301 …and then try loading bios you made this way i can confirm bios was updated …and it will not upgrade to the modified 1402.
Asus Ai trick method did not work on modified bios …it does show completed normally in windows but does not actually update bios. ha ha

i’ll try a different method and be right back

No luck flashing bios from 1301 to modded 1402 NVME.

1: EZflash method …its built into the bios …but won’t flash complains about file name CAP

2: USB Flashback my board does not have that feature …button removed

3: AFUWIN Tool this method appears to work …no errors . But it does not update Bios

4: Usage of the Flashrom this method backs up ROM no problem …but errors when writing to it.

5: Usage of the ASUS AI Suite this method give no errors but does not write modded bios .
Tried 2 versions of tool .

Finally got full UEFI support working !
Big thanks to [Koekieezz]

Both video card and motherboard need modding to enable this.

I did end up bricking my motherboard during this episode …but lucky for me i have raspberry Pi and could recover easily.

after recovery …I used this file from a different source that was already made
P8Z77-V-LK-ASUS-1402-NvME.cap.zip (4.2 MB)

and Usage of the ASUS AI Suite method to flash using windows

1 Like

what did you do to the gpu? glad your file worked

my vbios were made based on the lates vbios available, inserted nvmedxe_5 and samsung_m2_ahci using mmtool, the one u sent use nvmedxesmall. but hey it works XD

but since you do have a programmer you could test if my bios were actually working or not, since you did said it didnt update/flash on software way.

I bricked the motherboard when i tried using the Bios.ROM file you made. flashed it using AFUWIN Tool…flashing went well no errors . reboot gave brick

no issues with the GPU file you gave me …it worked great.

1 Like

My raspberry Pi …did not have the correct clip . I had to bend up one that sort of fit it…but it worked enough to flash the backup i made before bricking.

You gave me 2 files …are both modified… specifically the CAP ones ?

nice to know that! seems like the bios you sent were inserted using uefitool

maybe wanna try this @spiidertnt ?
NvME2.rar (3.9 MB)

here’s the thing i inserted:

and ME, all using UEFITOOL, based on the bios u gave me.

That file produces brick also !

1 Like

alright, it is a good idea to zip your bios file and upload it here, in case anyone need it :smiley:

Hello everyone,
I came across an ASUS P8Z77-V-LK and also have some old parts. I was thinking of throwing together a super budget build and maybe gifting it away on r/hardwareswap. I have an nvme ssd drive (32gb intel optane) laying around that I would like to use.

But of course I run into the problem that I cant load windows onto it. I read this entire page and came to the response from spiidertnt that says after repairing the brick he ended up using this file:

after recovery …I used this file from a different source that was already made
[P8Z77-V-LK-ASUS-1402-NvME.cap.zip](4.2 MB)

So I loaded windows 8.1 onto a sata SSD, downloaded AI Suite 2, I then updated to 1301 bios from asus website first because it was on something super old, then I loaded the file above (modded 1402) and used the asus update to flash the modded bios. It said successfull. But when I get back to bios it didn’t actually flash…

I then renamed it from P8Z77-V-LK-ASUS-1402-NvME.cap to P8Z77-V-LK-ASUS-1402.cap
(which is the exact naming convention of the 1402 bios on asus website) It still did not take. How can I get this bios to take? I dont understand what Spiider did differently and im trying to avoid the brick because I dont have a raspberry pi to save nor do I know how.

I have done the following for Bios settings :

  • sata config listed under AHCI (not sure if this matters since im using pcie to m.2 adapter, it is plugged into the bottom black slot pcie x16_3)

  • tried setting this pcie _3 slot to x2 and x4 made no difference, left it on x2)

  • secure boot shows enabled and as UEFI

  • CSM enabled and options listed as below: (most were on LegacyOpRom before)
    -Boot device Control: Uefi and LegacyOpRom
    -Boot from network devices : Uefi driver first
    -Boot from storage devices: Both, Uefi driver first
    -Boot from pcie/pci expansion: Uefi driver first

  • made sure the drive was converted from mbr to gpt (but tried both , no difference)

  • also tried both of the extra pcie slots didnt matter.

How to get the modded bios file to flash? I’m not savvy enough to create my own modded bios but spiider said that one worked for him.