[OFFER] Asus P8B75-M BIOS v1701 NVMe, EFI_ROM microcode update

As requested by @Guddu988

NVMe module insertion detect

Asus P8B75_M_v1701_module_detect.png



EFI_ROM updates:

Asus P8B75_M_v1701_EFI_ROM.png



microcode updates:

Asus P8B75_M_v1701_microcode_update.png



see your manual p2-5 to update bios.

As always back up your drives before you flash the BIOS!

P8B75.rar (3.13 MB)

How is the module inserted? "ASUS EZ Flash Utility 2" does not allow it, is there a way to bypass ASUS security and insert it like any CAP update?

@Alo613 - All stock modified BIOS for Asus must be flashed via USB Flashback, or if no USB Flashback, then one of these methods in the Asus section here - [Guide] How to flash a modded AMI UEFI BIOS
Otherwise a per user/system FPT dump of BIOS region needs done, after BIOS/SMI lock is disabled first, then BIOS would be edited and then flashed back, and that kind of edit can only be used by the person that dumped the BIOS region with FPT
Some rare models, or BIOS versions, may allow mod BIOS flash via EZ Flash, but it’s rare and I think only when they made mistake in the EZ Flash module.

@hancor - Update BIOS info/method above needs amended

I have tried to follow the steps in section "B" as the guide describes but it is impossible, I start AFUWINx64.exe but when I try to enter the second character it closes automatically, I disabled antivirus and Windows Defender but I cannot avoid closing, I have also copied the commands and paste them into the console and the same thing happens, it closes, could there be another cause for system security that makes it close? Any other suggestions regarding extracting CAP from Bios? or insert NVMe modules required to boot from NVMe devices. My current system is Windows 7 64 bits, in the SSd that the BIOS does not detect due to lack of NVMe modules I was able to install Windows 10 Pro 64 bits because the installer sees the disk and everything was done normally, Thanks

Updated the attached BIOS file but still not able to boot from NVMe? Anywhere to set in the BIOS to activate?
By the way, I have connected M.2 SSD to PCI-e x4 card.
Please help.

@Ted

In the boot tab section of your bios/uefi you need to set CSM (Compatibility Support Module) = DISABLED

Then reboot, reenter bios/uefi and you should see something like "Windows Boot Manager" in your boot section tab of the BIOS/UEFI.


Cheers

Hans

Hi @hancor
Feel great to see your reply. I tried to follow your guide - to disable CSM
After Save settings , reboot and reenter BIOS, I do not see "Windows Boot Manager" in the Boot Section tab.
Any clue?

screen capture from bios

1.JPG

2.JPG

3.JPG

@Ted

Hit the back button on JPG.3 and show me what your BOOT tab looks like…

Hello @hancor
Attached are the screenshots from the Boot Tab.

4.JPG

5.JPG

@Ted

What do you see in your BOOT CONFIGURATION tab?

In your manual at page 2-26

UEFI/Legacy Boot = Enabled both UEFI and Legacy (Default) should be set to [Disable Legacy]

PCI ROM Priority = Legacy ROM (Default) should be set to [EFI compatible ROM]

You may also have to toggle SECURE BOOT to Other OS etc.

Set the above two/three settings and then reboot; re-enter BIOS/UEFI

and find the BOOT OPTIONS PRIORITIES tab… also on page 2 - 26 of your manual.




Cheers

Hans

Hello @hancor
Secure boot set to Other OS > Done
I have downloaded tha manual and refer to the page 2-26
Unfortunately, the Bios screen seems different from what I have ( Can’t find the 2 options mentioned )
Please refer the PDF file for the screenshot from manual and my mainboard BIOS

From Manual 2.pdf (218 KB)

The BIOS/UEFI is specific to this board Asus P8B75-M only:

https://www.asus.com/supportonly/P8B75-M/helpdesk_Download/

That means the following boards need their own BIOS/UEFI and are all subtly differentiated from the above bios:


P8B75-M LE
P8B75-M LE PLUS
P8B75-M LX
P8B75-M LX PLUS
P8B75-M/CSM
P8B75-V
P8B75-M LX/TW

Please VERIFY the EXACT model of motherboard you have…

Hi @hancor
Yes, I am having the exact model P8B75-M
Attached is from BIOS and physical board
Hope you may able to assist.

6.jpg

7.jpg

@Ted

Okay, I see significant “dust bunnies” in there, when did you clean it last?

You want to select the “Advanced” version by hitting F7

Also did you, unplug computer, remove the motherboard battery for 60 seconds to let the capacitors drain and reinstall, then reboot, load setup defaults?

Further, which PCIe slot did you use to install adapter and NVMe drive?


Cheers

Hans

hmm… seems like never cleaned it

Hi @hancor
Let me try now

Hi @hancor
I’m using PCIE-4 to install the drive
Below is the model
https://24h.pchome.com.tw/prod/DCAX4G-A9007CFH8
and this is SSD i am using
https://24h.pchome.com.tw/prod/DRAHC0-A900B1OLP

Unfortunately still the same after take out battery to allow bios loads defaullts
Still can’t see the 2 options and not able to boot

What happens when you hook up a SATA hard drive or SATA SSD and/or USB drive…do they show up in the boot priorities tab?