[REQUEST] RSA Signed BIOS Unlock - HP Pavilion 14-v066br.

Hi! I have a HP Pavilion 14-v066br notebook and would be great to have the Advanced tab unlocked, mainly to change fan speeds and processor voltages.
As the title says, this bios is RSA signed/protected.
I own a CH341A programmer and successfully flashed stock bioses on this notebook but I lack the knowledge to crack the security.
I write this in hope there is someone who wants to take this challenge. All I can do is flash and test the modded bios.
Here is the latest bios from hp: ftp.hp.com/pub/softpaq/sp92501-93000/sp92961.exe (I don’t mind if there is a need to use an older version)
Board ID is 02280

Thank you!

Last time i checked…still the so called NEW (2016 up) RSA versions, hadn’t have any successful advances on bypass, and its not for lack of testers.

Oh… I didn’t realize that only some specific bioses with rsa check could be modded.
Apparently changing uefi varstores is also not possible. Just have to forget about it, unfortunately.

Anyway, thanks for answering!

Does anyone try to patch EC firmware for return success of rsa sure start reading? The firmware itself loads from spi rom on boot. So that’s possibly to bypass.

@Sweet_Kitten Sorry for citing you out of nowhere, but can you take a look at this bios?
I am willing to be a tester if it is of your interest.

Unlocked. Partially.

Unlocked Partially.

It boots!
After flashing the rom and turning on the notebook, a red colored text appears. Some warning that I couldn’t take a photo of. My bad. It only shows up in the first boot after flashing.
In sequence, the operating system loads as usual.
I can access the bios and it does have all the tabs unlocked. Changes get saved but they don’t take effect it seems.


Which? I know that they were locked by HP for purpose. Because some may not work properly or not work at all.
Have you tried turning overclocking feature on?

Looks like every setting that was unlocked doesn’t take effect.
Yes, I can turn it on and change some settings that, again, do not take effect. But there is one that if I change will result in a brick.
If I change the setting “Core Voltage Mode” from “Adaptive” to “Override” it won’t boot after saving and restarting. Only reflashing the rom fixes it.


I don’t know what it’s connected with. Additional locks!?
Even tho these settings in BIOS does not have an effect, maybe "Intel XTU" for Windows becomes active after switching OC feature on?

Good news! I found unlocked settings that takes effect.
I was able to reduce the usable processor cores to 1 and disable hyperthreading. Both settings are located in the “Power” tab.
Apparently nothing works in the “Advanced” tab.
I tried changing (in the advanced tab):
-fan speed.
-igpu memory size
-processor voltage
No dice. I can undervolt on Windows using XTU, but can’t using bios.

Nothing new shows up on XTU after enabling “Overclocking Feature” on bios.

As far as I understood, CPU control via XTU was already available for this laptop model.
So bad. This BIOS is useless.

Yes. Not only that, but also "Core Voltage Mode" remains greyed out in XTU despite being unlocked at bios.
Do you mean that this specific bios is bad and this fact has nothing to do with the protection?

I think yes.

Oh, well. If you discover anything and want to try, I’m up to test.

If this is the end of the line: Thank you very much for the work! =)