[Request] Sabertooth P67 BIOS with NVMe Support

Hi everyone! i’ve got a sabertooth p67 (rev b2 ?) motherboard currently at bios version 2302 i have tried to update to the bios provided in the thread by SKyRo "Modded BIOSes for all ASUS Z68+P67 MBs"
But i get an “integrity check failed” error while trying to update the bios through ez flash.
I have also tried updating the bios with .rom files directly from asus (2302, 3302 and 3602) the highest version one i can update to is version 2302,

is someone able to modify the 2302 rom with the needed drivers ? for nvme aswell as nvme boot support ?
Thank you in advance!

Heres the the highest version bios rom i dont get an “integrity check failed” error while updating to attached

Edit by Fernando: Thread title shortened and customized

SABERTOOTH-P67-ASUS-2302.zip (2.43 MB)


Dont play with bios up and down, and dont flash mod bios files versions different from the actual one in the system.
If now the system is on 2302, disconnect the AC power, clear CMOS (Battery OFF/Jumper 2-3), wait 10m and re-connect everything.
Start the system, go to bios and load defaults, go to EZ in bios and select the official 3302 from a USB drive, update the bios, repeat the process if the next and final update to 3602 fails again.
Only then when the system has the 3602, u can flash the provided mod 3602.

Then u can follow Fernando guidance, on point#4 OS installation on the NVMe: [HowTo] Get full NVMe support for all Systems with an AMI UEFI BIOS

@meatwar System is now on 2302 tried resetting the cmos several Times, and then trying to flash to 3302 without success i keep getting the "integrity check failed" error in ez flash bios Tool, tried with the roms on several different usbs in different ports etc, i really dont get what im doing wrong ? Thinking its an issue because the motherboard is b2 stepping?

From Asus website, updating bios 2302: "*Please update Bios twice when update from previous Bios version, then need CLRTC"

This is a note when u click the “SHOW MORE DESCRIPTION” in the bios update field description.

So redo the 2302 update again, leave the USB plugged, i have the same board for sale and i did the updates this summer, all over to 3602.

I have followed all the steps on the asus website, update twice then clrtc while updating to 2302, The ez flash utility gives me the “integrity check failed” error when trying to update to 3302 from 2302. No matter how many times i’ve updated to 2302 and clrtc, :frowning: ? must have done this step atleast 10 times ? is there some way to check if the update has succeded when doing it the second time ?

Do you have the updated motherboard with b3 stepping or b2 ?

Weird the EZ Flash2 giving that error on ORIGINAL Asus files…
Theres no B2 on the Sabertooth P67…at least to my knowledge, i always saw B3 as its mine.
U can try the DOS utility BUpdater 1.30 on the 3302 or 3602 bios file.
Thats my last suggestion, besides the use of a CH341A SPI flasher…

I believe that the 2nd update round on the 2302 its about new EC FW or ME Firmware…dont recall.
Doing the update with a SandyBridge or iVyBridge?

im doing the update with a sandy bridge i5-2500k, Currently on ME version and EC version MBECE-0018
Would buying an already updated bios chip be an easy way out ?


Nah… thats not good, indeed something is not right because the bios version 2302 contains the ME… that should been updated using the i5-2500k SandyBridge…
Im not fan of buying already programmed SPI, prefer empty ones… but it works, cant say the rate success in different motherboard models…
But i noticed that ur board states B2… now thats a death end for me now as i never had a B2.


Other option beside the BUpdater in DOS, first update the ME 7 1.5MB v7.1.80.1214 from here: Intel (Converged Security) Management Engine: Drivers, Firmware and Tools
and then try again the bios updates

Might be related to ME, 2103 and 2302 are both on same ME 7.0, 3302 is update om ME 8. One could try to clean ME now, but this is probably too much work.

Did you try to dump your old bios with fpt from this thread Intel (Converged Security) Management Engine: Drivers, Firmware and Tools
Use ME System Tools v7 r2 - For systems running ME v7, fpt(w(64)) -d spi.bin might give you an error if flash descriptor is locked.

If this is the case: Board has socketed chip, buy a CH341 programmer and some 32 Mbit SPIs, dump the chip, transfer board specific info to a stock bios, mod stock bios and flash it to a new chip, easiest way of trying new things…

║ ME Analyzer v1.254.0 r265 ║

║ SABERTOOTH-P67-ASUS-3602.ROM (4/4) ║
║ Family │ ME ║
║ Version │ ║

║ SABERTOOTH-P67-ASUS-3302.ROM (1/4) ║
║ Family │ ME ║
║ Version │ ║

║ SABERTOOTH-P67-ASUS-2302.ROM (2/4) ║
║ Family │ ME ║
║ Version │ ║

║ SABERTOOTH-P67-ASUS-2103.ROM (3/4) ║
║ Family │ ME ║
║ Version │ ║

As suspected @lfb6 the flash descriptor is locked! will check in when i’ve decided which route i will go thank you for the help and info so far!