(Request) ThinkCentre E93, M73/p, M83, M93/p, ThinkStation E32, P300 Microcode update/trobleshooting

I have a Lenovo M93 tiny pc model 10A4.
I purchased on eBay a i5-4790T 35w TDP CPU which by this list:Upgrade list should be working.

The PC came originally with a G3220T CPU. With i5-4590T the pc starts but stops booting for some reason, practically, doesn’t boot.
I suspect that has a missing microcode or the microcode in my bios is not loaded for some reason.

I have updated with the latest bios, so microcode should be the latest as well. Lenovo bios page

The symptoms are similar to described here: Thread
My bios dump:Bios

Can someone knowledgeable look into this?. Thank you in advance.

Maybe helpful:

The Haswell Refresh BIOS update consists from two parts: the bios update and intel ME microcode update.
The last one can only be installed from Windows using “BIOS updater for New 4th Gen Intel Core Processors”

I sent you info in PM how to check ME FW version, so I can tell you how we update

I’ve already made it working with the latest Intel Management Engine Firmware Update Tool from here: Lenovo website

My i5-4590T is up and running. Files needed: the latest bios and ME firmware. Both of them can be used inside windows. I

@gdfath3r - Thanks for update, I was waiting on a PM back from you to see what happened. So, latest stock BIOS was OK after you updated ME FW?
If yes, I thought maybe it would be from the get-go once we looked into the microcodes, but I didn’t think of the ME FW till later (Sorry!)

I had not thought of the ME FW was isolated from BIOS updating firmware!Thanks bro!
I had updated the latest ME FW by SPI programmer!

These days I was reading 24/7 forums how-to update the microcode because I was suspecting that or is missing the relevant info or is blocked by something.
Lost’n’Bios tried to help me, by editing the bios dump I sent him. It did not work. I realized then that is not the microcode is missing. Is missing something else.
Then I start digging on forums topics related to not working cpu’s. At least I learned how to flash modified bios…:slight_smile:

I have a working afudos flasher which bypasses security.

Do you mean you had a afudos flasher which bypasses security on ThinkCentre E93?
could you share with me ?thanks!!!

@gloobox Yupp, I do. There you go:

Make a bootable freedos thumbdrive with Rufus, then copy the files on drive with the bios.bin you with to flash.

I used the following command:

afudos bios.bin /gan

You have to replace bios.bin with your filename, or rename it to bios.bin. If you have .rom, then simply just rename it to .bin.

Hope it helped!

AFUDOS.rar (151 KB)

I met error when using the AFU you gave me in the machine of IS7XM which had the latest bios version(9SKT9CAUS,released in 12/11/18)


And I found your bios of IS8XM just released in 12/24/19,so I think it just is available for IS8XM?

But according to my experience,the error 46 would happen mainly because the bios is too new to support this AFU version.So you rather using the newer AFU or downgrading your bios version.

So do you mind flashing your dumped bios which is only adding the nvme support ?

Hi Gloobox,

I have the M93 tiny version, which doesn’t have PCIe sockets on board, so I can’t help you with that.

I remember that I’ve downgraded to an older version, then I’ve flashed the modified bios by Lost’n’Bios.
However, it didn’t work and flashed back the latest BIOS just to doublecheck that everything is ok. Then I read about that is not missing the microcode, it only needs the ME firmware to make it work.

End of the story, as you suspect, from older bios the flash might work, because when it worked for me I was flashing from older to a modified one.


There is no need you have PCIe sockets on board,you just text it whether it could flash the modded bios.

Yes, it should be able to flash since mine did.

I think it may only adapt for your machine

Well, you have to try downgrading your bios, then flash your modified bios.
It is not my flasher. I’ve got it from someone who is more experienced than me.

@gloobox - I have 3.06 one w/GAN if you want, let me know?

Also, I think this model has S3 sleep bug, so may be able to FPT after that, but I can’t remember what gdfath3r said about this when I had him check.