[Request] Unlock advanced menu on 2019 Acer Predator Helios 300 PH315-52

Hi @Lost_N_BIOS
There is new bios ver. 1.08 available, my current modified bios is 1.06 so for some reason they skipped 1.07
Changes stated are only “Supports new LCD panel” but I still would like to try, if I flash it normal way will I be able to restore my current modified 1.06 without programmer?
And second question, can you explain please how to unlock this new version?

ps it looks your bios in post #10 not available, is there a chance to reupload? coz I’m not sure that my saved one is the same

@Hyppo - maybe we could find in BIOS or EC, but it would probably be super hard to find, maybe not as bad in EC if it’s there, but not easy no matter how it’s done.

I Don’t know what TCV is, I thought you mentioned it first? Just ask Acer if they will tell you where the fan curve programming is, in what BIOS module or if it’s in EC FW
I answered you in PM about going back, if you can FPT BIOS region then yes, you can always go back. However, if BIOS must match EC FW then you’ll have a problem, and programmer will be required.
Also, if ME FW updates with new one, and you want it back to old, you’ll probably have to dump BIOS and downgrade me / program back too. Unless you already have unlocked FD from previously flashing in with programmer, then usually it would remain unlocked and you could FPT ME FW too.

Yes, I have all BIOS, but the one you mentioned #10, is before you sent me some new dumps which you said was from “New System” So are you sure you want the #10 BIOS?
It’s named Go1.bin inside that folder name you can see in the link.

On the unlock, I’d have to look at the BIOS, which I don’t have time to do right now, but I bet it’s same as previous edit which I showed you how to do.
Were you able to follow along and do the edits with the info/images etc I gave you before?

1) ok, I will try to ask acer where fan curve stored
2) I will check your routine and try to modify previous bios 1./06 myself and check if it matches with yours one
3) yes proper modified bios was in post #10, I think I saved it and here it is
can you check please? Also. if I will make dump using “fptw -d” must it match with those from post 10?

No, that is not the BIOS from post #10. That is BIOS from after you sent me "New System" dumps and I modified it and sent back.
BIOS in post #10 was named Go1.bin, and was made before the BIOS you sent link to above (by a hour or two)

No, any dump you make now will not match anything from before, checksums, times, dates, NVRAM changes all constantly change as a system is running.
The only time two dumps would match is if you made them with flash programmer with the system powered off the entire time and never restarted between dumps.

I can’t believe that I didn’t save it but I can’t find it in my folders, can you please share it again?

I think you want BIOS from #14, it’s best one

Well so I made the dump using “fptw -d” and then flashed new ver. 1.08, it was flashed successfully and worked fine but no fan issues fixed.
So I decided to revert bios but “fptw -f” failed with following

command “fptw -d” still works though

Is there any way to revert to the bios dump which I made before flashing using fptw tool?

Yes, I assumed you couldn’t flash back that way as I mentioned, you will have to unlock stuff like we did first time around. or stay on BIOS 1.08, it’s best thing to do anyway.
Which, I see was nothing, we didn’t unlock anything to bypass 167, you used programmer. So, program back in BIOS FVM2.BIN

@Lost_N_BIOS You mean to flash fmv2.bin using programmer? Or rather those saved “dump colibri fvM.BIN” which I shared today?

Or maybe it’s better to make new dump from 1.08 and unlock it?

Yes, FVM2.BIN is based on the colibri fvM.BIN but with cleaned updated ME FW, so best one to use of those two.
or yes, you can make new 1.08 dump and unlock it (I assume you mean unlock BIOS menu) If the only reason you want to go back to old BIOS is for menu unlock, then yes, stay on latest BIOS and unlock it’s menu instead, no point to go back to old BIOS

* edit, send me the dump if you can’t get it unlocked with info I gave you before. If I do this, do you want updated microcodes and ME FW too? I will unlock FD and remove FPRR/PRR * BIOS lock like before, so you can FPT flash BIOS region.

I’m still not sure why FVM2.BIN is better than colibri fvM.BIN?

colibri fvM.BIN was the first version with unlocked advanced menu while FVM2.bin was the same plus unlocked FPRR, right? But what is the benefit if in any case I need to use programmer when new version issued by Acer?

And speaking of new dump 1.08 you mean dump made by programmer or fptw tool?

As I explained a few times, that is same BIOS as colibri fvM.BIN but it also has updated cleaned ME FW (so latest ME FW)
Go1.bin was first BIOS I sent you with unlocked menus, but dump colibri fvM could also be this, very confusing here and that dead link doesn’t help. On my end, from what I can see and tell, Go1.bin is that first BIOS (folder name matches dead URL name.

No, all the locks etc was removed at BIOS post #10. Benefit of all the unlocks (aside from menu unlock) is that you can FPT flash BIOS with the locks removed, so you can dump, edit, reflash without using programmer.
Of course, any time you reflash stock BIOS or update BIOS version you will loose all those modifications (maybe not FD Unlock, but certainly FPRR/PRR lock will go back into place - error 167)

All I know for sure is best BIOS for you to use, of the old version is FVM2.bin. Use that, or dump new 1.08 BIOS and update it, unlock it + mod BIOS menus etc.
Dump it with programmer, leave system open or at least bottom not all the way screwed back on, so you can program back too.

First modified bios was “dump colibri fvM”, you didn’t send me go1, probably they are the same just renamed.
So the benefit of FPRR/PRR unlock is that in case if I already have modified bios then I can flash another modified bios using fptw tool. But if I flash new stock bios it’s all will be lost and I need again to disassemble whole laptop and use programmer again.

I will disassemble it soon and make the dump of 1.08 and then will try to make changes myself and will compare with your changes, is it ok? For me it’s better to have minimal changes i.e. only unlock the menu.

The problem with this laptop is that it’s difficult to have it half assembled, you need to mount motherboard in case anyway

I’m sure I did send you Go1.bin, it’s the dead link at post #10 “Pre-FPT” That’s first BIOS w/ unlocked BIOS menu I sent you, then you programmed that in, dumped and sent me colibri fv and I modified that to remove locks to allow you to FPT flash, that file was colibri fvM
Disabling BIOS Lock and FPRR/PRR lock allows you to flash with FPT, before that is done you cannot flash with FPT, which is why you ordered the programmer.
Yes, anytime you flash in stock BIOS using stock method, all changes will be lost, except FD edits may be left in place if the stock BIOS does not re-write the FD (usually it doesn’t flash this area, but can if it wants)

If you only want unlocked menus on your dumped 1.08, and you can’t get it, send me dump and I can do only that.
I don’t mind to limit changes to whatever, I just usually do the FD, BIOS Lock, FPRR/PRR lock disable stuff so it’s easier for users to choose what happens next with their BIOS instead of being locked into flashing stock BIOS only, or having a huge hassle to flash in mod BIOS like you did from the start of this thread.

I just meant leave the bottom unscrewed, but put it back on there, maybe put in 1-3 screws to hold it in place while you get things finished up

Hi @Lost_N_BIOS
here is new dump of stock bios ver. 1.08

From your how-to I only understood how to change two bytes on 9e0 and a22 rows from values 38 and 75 to 00 and eb accordingly, in the branch of guid from setup utlility.
So I did it, here is comparison before and after

and then made replace body and made my first bios mod
Here is my modified bios 1.08

But what do those 2 bytes do, only unlock advanced menu, do they unlock also overclock settings? Becoz other picture from how-to is not clear for me, can you please elaborate?


@Hyppo - is that the extracted PE32 body of Setup utility? If yes, then that is proper edit (looks correct), then reinsert as body at same place you extracted. Other images from how-to I sent you just show how to extract the file, and what you’re actually editing viewed in an assembly program (IDA)
Yes, those bytes unlock the Advanced and Power menu if I remember which menus it was correctly

The other edits to remove SMI/BIOS Lock and unlock Overclock Settings is totally different modifications, which I didn’t send you info about in how to do because it’s much more involved (edit of NVRAM variables)
If you just want Overclock enabled, test your mod BIOS and see if it works properly, menus unlocked etc, and then let me know, if all OK I will do the unlock for Overclock settings (and make you notes on how to this time, since that will only be one byte to edit, but it may be many times to edit it in any single module.)

Yes @Lost_N_BIOS it is PE32 body from Setup utility, before and after
And yes I 100% need the overclock menu otherwise unlocking bios has no benefit (for me)
I have an idea how to make laptop working without assembling but I need time to setup such bench, I will do it tomorrow then flash my mod bios 1.08 and let you know results, please stay tuned)

Ok, then test your mod BIOS, confirm menu mod is working, and then if it is I will use your mod BIOS as base and unlock the overclocking stuff.
Sorry, I assumed you just removed the bottom to access the flash chip to reprogram, if you have to remove the board and disconnect a bunch of stuff to get to it, then what I mentioned wouldn’t be a way to leave it sitting and be able to use it.

Yes this is a pain with this model, I need to completely remove motherboard as bios on opposite side
And the second issue, I need to attach laptop keyboard in order to start the system becoz power button is integrated in it but to attach it I need to remove it from top case)

I know how that is, hopefully you have other system you can use while this one is in pieces
Sounds like a real pain made worse by the keyboard/power button issue too