[Request] Unlocked Acer Aspire Switch 10E SW3-013 BIOS

I recently got an old notebook from a friend with windows 8.1 32bits, model : Acer Aspire Switch 10e | Sw3 Sw3-013
and I tried to format and the bios is totally locked with secure boot all options are locked.
I’ve already tried “F9” to restore to default and nothing happens
I tried to install the latest bios … but it already has it BIOS_V110
I tried every possible way to try to update the bios unlock it and etc… but without success…
I’m not an experienced guy in bios and I would like some help if possible … thanks to everyone in the forum and I’m sorry for my mistakes in english since a good morning good afternoon or good
night ! <3

Edit by Fernando: Thread title customized

If im not mistaken, in bios for changing those settings its requires a User password to be set. This is not required by bios mod, its Acer policy.

I already set the password… but I can’t set the superuser…

Dump firmware, empty NVRAM?

I would just like to reset the bios to put a new operating system or bring up secureboot in order to change the boot order


What can I do for you?


hello sorry to bother you again, i would like if someone could help me with a mod bios of the notebook/tablet Acer Aspire Switch Sw3-013 as I have tried everything in my power before I came for help… the bios is blocked not with " password" but yes the options I can’t set a password for the “administrator” only for the normal user to enter the bios… but I can’t change anything… as I understand I need to put a new bios to go back to the “default” as if it were a reset in the bios… I don’t know where the reset is on this notebook on his hardware I’ve never seen this model before as I said I got it from a friend
once again thank you all for your time =D

So you need an unlocked BIOS for more options?


yes that’s exactly it … so I could put another windows and remove this 8.1 32x and install the latest version 10 64x that the notebook accepts and has support I’m grateful for your attention and I leave the bios I use on the notebook

bios.zip (3.4 MB)

Ok. Unlocking consists of copying your current BIOS, editing it and writing back to the device. It means that we cannot install an unlocked BIOS as if it were that BIOS downloaded from support page. So it requires to run the BACKUP_Tools to obtain a backup of your BIOS (it’ll create results.rar archive on desktop). Also, I need a copy of your BIOS variables. (run "GET VARS.bat" from this archive and share with me the output file "vars.txt"). As soon as I receive these files, we will try to unlock the BIOS without using the SPI programmer.


here are the files you asked for and i’m sorry for the delay as i was working

Var+Results.zip (1.82 MB)

No problem. I can be a little busy too, so sometimes I can’t give a reply promptly.
DOWNLOAD: helviio.zip. Extract its contents to a separate folder. Next, run "SET VARS", reboot your device and then run 'FLASH". Lets see if it’ll work out.

gave error in flash.bat because the file is in 64bits and the system is 32bits of windows

Ah! Sure. You could change the name of the executable file in the script, or dowload my archive again. I have updated it.


I did the procedure you said and this error occurred

You have completed step one, rebooted and launched FLASH32, right?

exact, redid 3 times and the same error continues

This will not work. Although we even turning off bios lock in the first step, BIOS does not allow writing for some reason. I said that we would try, we were in for a failure. Im sorry, it seems that there is no other way than SPI flash memory programming.

I’m heartily grateful for your help brother! …
I read the bios from the manufacturer’s website and switched to version 1.10
for 2.00 i went into flash mode but gave this error