[Request] Unlocked Acer Nitro 5 AN517-51 BIOS Features

Acer Nitro 5 AN517-51 with unlocked bios but Overclocking Features is Greyed Out. If anyone is able to provide help thanks

Modded Dump with greyed out overclocking features: https://www.mediafire.com/file/jj74ugal2…am_mod.rar/file


This one worked for Raeo6987 :



Taro6987, have you unlocked the advanced UEFI settings?

I want to unlock fan control in my laptop. is that even possible? There is no limit to how far i will go to get this. I have already extracted my bios, searched "Fan" in the UEFI tool, extracted pe32 image driver sample and used ifr extractor to make sense of it. and I also believe my bios is write-protected.

Hi friend, use this tool run it as Admin and upload the result file here :


Let me know

apparently I can neither upload archives bigger than 6mb nor am i allowed to post links.

ok, i have no idea what im supposed to do, now. I got your results but idk ow to send it.

I read around and seems like I have to have at least 5 posts(?) before I can post links.

Weird rule if you ask me but this is gonna make it the 5th post so it’ll probably be it.

edit: there you go

Ok friend , your Eeprom is Write Protected so you have to unlock it setting the NVRAM Variables to 0x00 :

FPRR VarOffset - 0x6D1

BIOS Lock VarOffset - 0x17

Please download these tools and unpack them, then one for one try which one is working well for your pc, go into the folder for any one and run the Dump.bat by double click
on it , when you will get the vars.txt file, then upload it here to edit and write which H2OUVE version is working :


I will reply with the same file varsmod.txt and you will reflash back again by H2OUVE tool.
Let me know

I’m not sure if I was supposed to unlock the eeprom first but I don’t know how to unlock eeprom anyway so I got you the vars.txt first.
I used H2OUVE_200.00.01.00 for the vars.txt.

vars.txt (232 KB)


Here you go :

File attached below …

Put the varsmod.txt into the folder and run the Write.bat program by double click and then reboot the pc, after that you will use the FPT tool
to flash back the bios mod , run from the bios mod folder the Write.bat by double click again :


Let me know

varsmod.txt (232 KB)

I got this error

Screenshot (114).png


Have you rebooted the pc , have you the H2OUVE log to see ?

I did not reboot. On the first try it gave me this error.

Error log:

Error 167: Protected Range Registers are currently set by BIOS, preventing flash access.
Please contact the target system BIOS vendor for an option to disable
Protected Range Registers.

FPT Operation Failed.

If you have done well the rewriting varsmod.txt , then it means that the Eeprom is not unlockable …

Show info
@mesh17 - Great, so the vars edit does unlock FPRR, good to see, and you have tested recovering via programmer now too,
also great! So, put back in your original dumped BIOS with programmer, unless that is what you have now?
Then flash in the modified vars, and then send me new FPT BIOS region dump (or is this what is above)?

In this case only the SPI Programmer CH341a + the Pomona Clip can do the job.
I have got two of these laptops , both by CH341a modded … Taro6987_1.10 and widuo16_v.1.10 :frowning:

Reboot and try again …

I’m gonna try to do this without the use of the programmer but in case it becomes necessary I will buy it.
I’m having problems in post #16 ([REQUEST] Acer Nitro 5 (AN515-54)) where there’s varsM.txt and I think you were gonna send me an edited vars.txt as well but I’m not seeing it the zip file you sent me in the link. if it gets fixed without programmer it’ll be really great.

Edit: okay I think I messed up, please wait.

Yes friend, you can try to make it by RU shell or EFI shell too … don’t forget it !

ok so i got the varsmod.txt i put it in the H2OUVE_200.00.01.00 folder then ran write.bat after that I rebooted then i got into the Bios.Rog195_V1.33_EH50F_Mod folder that you sent me and ran the this command: FPTw.exe -bios -d biosregmod.bin. it worked without any errors, however when I was gonna boot in to the BIOS it asked me for password. i had password before and it was "1" and now it seems like it has changed. have you changed it?
by the way the picture is after I failed to enter the password 3 times in a row.

2021-09-19 22.10.58.jpeg