[Request] Unlocked Lenovo Ideapad Gaming 3 15IMH05

thank you very much, I no longer hoped that something would help besides the programmer, but you saved me from unnecessary expenses

Я только что увидел твой регион профиля, ты Русский?

As specified in my profile.

Обнаружилась проблема, с этим биос пропал сон, просто темный экран и не спит, можно это как-то вылечить?

On mod. BIOS version EGCN27WW?

Yes, the version is the same, but I broke my bios again and your recovery archive does not help

I can’t say anything about this. I did not touch the sleep state.

It means that BIOS has broken too much.

I can’t run the installation as described in the readme file from the archive, it just turns on, you don’t even need to press the power button as described in the file

I have a question, on the 7th point of the instructions, the laptop should not turn on itself when connecting the power cable?

It should not. But if it does, try without disconnecting and reconnecting the power cable. The instruction is pretty old.

I tried with the battery disconnected, with the power connected and without power, reformatted the flash drive probably 3-4 times. The laptop behaves in all cases the same as the first time, but this time it just refuses to flash.

But when I do everything according to the instructions and just don’t let go of the “fn + r” combination, then it just restarts

Hello! help me with a similar problem on my ideapad gaming 3 i5. I wanted to return the factory bios after unlocked, but after reboot, just a black screen, no backlight.
I tried to flash a dump that was posted by other people on the forum for repair specialists, but it even turned out byte to byte the same as my dump from an already broken laptop.
sorry for using the translator.

UPD.: We managed to solve the problem by searching for a BIOS dump and then flashing it.

@Sweet_Kitten @Lost_N_BIOS
An emergency call for help from a completely noob , I just joined this beautiful forum , I have IdeaPad Gaming 3 15IMH05 same as sergey … and I don’t know a thing about BIOS dump … but what I need is to unlock my BIOS (to change my S/N) … I have the results20.rar and vars.txt files because I tested it before …
So i will appreciate it if you guys helped me :heart:.

News :
I have unlocked my BIOS advanced menu … but when I test again it passes (Read Flash) but fails at (Write Flash) , it gives me Error 167 :

So any suggestions ?


EDIT: I linked the guide for reading and learning, not to take guidance from other users HW and bios protected values examples, as its not equal to all.

Lets say, that what a beginner user calls bios/rom, in these days its more called an SPI FIRMWARE system image, so your system as most of all, have protected areas on it that doesnt allow some operations to be done.
And as a beginner that you are…be very careful as this is not common tools/operations risk safe, advanced user experience is a must, and the risk of fail operations is always present.

Thanks for sharing …
What is the EEPROM and is there a relation between it and the SPI firmware ?
(I’m beginner)

In the thread you shared , He said : “Notice that BIOS/UEFI is not locked by the Flash Descriptor and thus OEMs are responsible for implementing BIOS-specific read/write restrictions such as Protected Range Registers and so on. That means that the Flash Descriptor is not responsible for any read/write restrictions set at the BIOS/UEFI region of the SPI chip, so the FD-related methods below will not be of any assistance in such cases.”

and my problem here is the Protected Range Registers and the Flash Descriptor has nothing to do with it as he said , right ?

Correct me if I’m wrong ^^ .

Edit :


Yeah , true …
I think I’ve to go to a technical support center to flash EEPROM (because I don’t have any programming chip + I can’t risk doing it myself).

But I wonder if there a way to change S/N in a low level (without flashing BIOS) where Windows can read it differently ?


I have the same laptop with same model , with the same BIOS version EGCN29WW.
the flash command always fails with Error 167 : Protected Range Registers …
So how does it work for you ? Did you flash the EEPROM ? or What did you do ?

Hello, I would like to unlock the advanced bios options of the Laptop Lenovo Gaming 3i 15IMH05, I am using the bios version EGCN39WW.
link bios: https://download.lenovo.com/consumer/mob…cn39ww.exe

Thanks for the help.