Requesting Dell Optiplex 7060 official bios bin files

corrupted bios during update. i managed to enter bios recovery menu but the system immediately restarts after i press the confirm button. i am going to try some luck with a ch341 programmer. could anyone upload an official bios bin file? thanks

it’s an dell optiplex 7060. i know it is an old model but i have a mac binding software running on this machine.

Dell doesn’t provide a complete firmware image and if they did flashing it would possibly delete machine specific data.
Dump your bricked firmware (at least 2 times getting a 100 % identical dumps) with a CH341 programmer, post the dump.

this is the bricked image. thank you (9.2 MB)

I flashed a random bios file after dumping this bricked image. everything seems working but the mac adress is changed…i think that could be one of the specific data you mentioned

Reverted updated parts of bios region back to old version. Didn’t empty NVRAM or clean ME region. Try… (9.1 MB)

not woking… machine won’t boot after flashing this bios. press the power button gets the amber light blink once(less than 0.1s) and immediately goes off.

The first part of the static parts of bios region is old while the last parts are updated, So there’s a quite clear error and I don’t see a reason why it shouldn’t start with the old onfiguration after fixing. You’re sure that you flashed correctly?

Did you read it back in a separate process and compared the fresh dump with the file intended to flash?

tried to flash it twice and got thte same result. but i didn’t read it back and compare the fresh dump. gonna do it

You might try this file, empty NVRAM and freshly re-configured ME: (8.7 MB)

save my az. thank you for your patience