i have a ROG STRIX Z690-A GAMING WIFI D4 stuck on broken XMP on bios
Version 2004 and i am not able update to flash it back to Version 1304 where it all worked fine
windows updated the bios to the current version I’ve gotten no help from ASUS over the matter
this is what the Bios says

“1. Improve system performance
2. Update ME version to
3. Many ME updates and optimizations for the next-gen CPU are included. This version does NOT allow rolling back to the previous versions, not even via USB BIOS FlashBack™, to ensure better compatibility”
IM vert new and sorry if i haven’t explained anything right but
can any one help me flash it back to 1304 or tell me a way to do it

Asus are being very unprofessional so after some looking around i was advised to come here so here i am

Many thanks

Why not latest 2103…
ASUS ROG Strix Z690-A Gaming WiFi D4 Thread | Page 46 |

Big risks to take if procede with any attempts and i do not recommended it…

You can try the Intel FPT tool from ME16 tools package
SPI programmer with connection to TPM header.
image image

Nothing is for sure if it works or not, your task and risk since we dont know how older bios image can deal with latest Asus ME16 FW updated inage or how the SPI will react to a full spi programming.
Also an incognito on mordern Asus motherboards, 2 SPIs…

2103 my XMP still doesn’t want to work for some reason the board will run perfectly on 1304

i have played with both latest and still have no luck even gone and got 6 set off ram new CPU and still the same im thinking maybe the MB is faulty in some way but its getting to ASUS to RMA I’ve asked 4 times now and they don’t want to give me the time or day so i dont really know what to do with it give up or try again and againa or sell the MB

Thanks for your replay


What is the version of the ME16 current on the motherboard? And processor model?