Router D-LINK DIR-822+ bios update failed

When doing a firmware update the router stopped working.
I have one mini usb programmer ch341A but I need one FULL DUMP file to download.
I already sent a firmware that I downloaded from the official page to the roter chip but it does not boot.
Can someone help me to change the .bin file so it can load?

First, have you verified your software is backing up and verifying the file 100% match before you wrote to the chip? Not all software versions work good with all chips, you sometimes need to try a few versions before you can read/backup and verify saved file/memory buffer matches what’s on the chip

Did you confirm you had working software version before you wrote to the chip? If not, then still may be OK to write stock rom in there, once you confirm the software version is working good for the chip you’re working with.

You might simply need to “Unzip” the .bin file, using 7zip, unzip to a folder and you will find a bunch of individual folders. Maybe those need programmed to the root of chip instead of the .bin file.

When you did write from the stock, did you extract the firmware or do anything to it first, before writing the file to chip? Is this the product and download page, I can only find DIR-822 no 822+ If it’s not, please give link to download the firmware so I can look at it, thanks

Please post an image of all stickers on the device too, I see here there are multiple revisions and build types

Here’s two guides that may help you make some progress, they are for oepnWRT firmware, but I think looking over the process you might find the answer on putting back stock image - I know this is not your model, only posted for further details to go along with above guide

Only exists in the site d-link China, you can use chrome to translate the site into English


What happened was that I tried to update the firmware for wireless, and this caused the update to fail, now the router does not boot nor can I access its configuration page to do a new update.

What I have at the moment is:

New Firmware V1.05 : page_openwrt-mtk-sysupgrade-86157-201709291917.bin
Firmware that is on the chip but does not boot, I can send you a copy of the two files to see if you can fix.

I think all you maybe need to do is get the bootloader wrote to the chip, then you can update via USB. Thanks, that’s why I couldn’t find 822+

So do you have a backup image of the chip, before you wrote anything to it? If yes, upload a copy of that, and your 1.05 new FW and I will see if I can figure anything out.

From your FW name, that is openWRT, so above linked recovery guide (generic.debrick) does apply directly.
Did you try unzipping with 7zip as I mentioned and write those files to chip as is into root?

Can you ssh into the router?

I’ll send the two files for you to verify.

SSH ?? how can I do this?

Download link:…71c03c3e0b90ZU/

ssh is similar to Telnet into router, you’d have to google around to find correct method for your brand. It’s not always possible by default though, sometimes you have to enable first before you can do it, so may not be possible now since you’re locked out and didn’t enable before.
Thanks for the files, I’ll see if I can do anything tonight and let you know.

I found this guide for another model, maybe already enabled in your model too…ecovery-Step-by

Similar but at D-Link site

Guide here, but for another model, might help (About splitting firmware in Linux)

And this might help too…327206ad11e03bd…2cf45e459d8a956

I see similar reports everywhere about clearing NVRAM fixed some, so be sure to try 30-30-30 resets too

I see OpenWrt Linux-3.10.14 already written to backup you provided, so looks like flash update went ahead at least somewhat

Is orange light blinking? Or nothing?

30-30-30 resets isn’t working.

is it not possible to change the .bin file so that the router boots to the recovery page and then make a new update?

I was reading about some of the older versions (Other models), and I read a lot about flashing in two steps, of course we’d be programming in two steps. They called this splitting the firmware.

First in was Kernel and then Ramdisk. So maybe we can try partial files, put in kernel first and try to boot, then telnet ramdisk on there?
I am not so sure it can be just programmed to the chip? The same version you uploaded is already inside the backup you uploaded too, what did the screen say when it failed, how were you flashing, ect what all happened?

Did you already try writing the factory D-link image on, instead of WRT? And have you tried anything similar to this yet, it’s built in recovery…-dlink-dir-868l

Sadly, I see here if the bootloader is gone you cannot recover with flash programmer. Can you ping the router from PC?

You never get to this page (emergency flashing)? If not, maybe bootloader is gone?

See also…mware_partition

If I have the network cable connected for example port 3, the router on start up flashes port 3 briefly, but then turns off and the power led is on and the 2.4G always on.

I can open the openwrt-ramips-mt76x8-tplink_tl-wr902ac-v3-squashfs-tftp-recovery.bin file with 7-zip but backup3.bin give error, Is it normal for this to happen?

I noticed the same with 7zip, I am not sure if that is normal? Did you try to write the stock FW instead, since the WRT already failed, I would be trying the D-Link version instead until you get recovered

I tried to use static IP but I can’t ping…

I’ve tried to push the reset button, but it has no effect.

The only thing I can try to do is send a firmware with the micro usb programer to try to have the ruter boot in recovery mode.

I only have the firmware that I took from the dlink page China, the original firmware on the router was destroyed by the update.
So if I send a firmware from another router model, but I do not know if it will work.

The downloads are all packed, and extracted (unzipped) into various places on the chip, we can’t just write to them to the chip from the downloaded files.
As you asked for, a dump would be a great starting place, then we’d have much better/easier time fixing, I could hex edit in proper stuff that way, but from the packed downloadable FW images that’s nothing like that gets written from those to the chip during the update process.

I think they will help you with a file you can program, once you get a hold of the main office. I see they gave you link to contact them on their forum, I bet they will have proper programmable image for you to use to recover!

hola amigo, pudiste solucionar el problema? yo presento el mismo problema y aun no puedo resolverlo.

he desoldado la memoria de la placa del router y la he leido con pun programador de memorias, pero no he logrado dar solución.


@Plus ^^
@abe1osky - This is English forum, please translate and post message in English, thank you

Não consegui, acho que a única solução que existe é alguém que tenha o ruter a funcionar que copie com um programador a bios diretamente do chip.

I couldn’t, I think the only solution that exists is someone who has the ruter working and who copies with a bios programmer directly from the chip.