RSA KEY - Dell 7590 Intel Core I9 SR40B - Can someone help with cleaning me region?


I cant clean region using all program, normally it’s not problem for me, but now i has RSA Signature and in FIT i dont has option “Platfrom Integrity”.
Maybe someone know what i shoud to do?

Please for help,


20200311_123085019_SVOD3.part1.rar (5 MB)

20200311_123085019_SVOD3.part2.rar (2.49 MB)

Skip that step, as noted in the guide, it does not apply to your BIOS since no "Platfrom Integrity" as you mentioned.

Hi, if i skip this step, then laptop dont turn on after SPI programing becouse RSA key is not inside ME region (i think like that) , me analyzer saying RSA signature = No, but shoud be = YES and that is why motherboard dont want start program, PCH dont start the program wich one have inside.

@robertd - Sounds like you are not doing something right possibly? Does this Dell BIOS have two BIOS chips? If yes, do you have flash programmer? If yes, dump BIOS from both chips, while system is running bootable BIOS, then send to me.
Upload to or, that way you don’t have to split file and attach here, it’s a mess to download files from here, especially if split.

As mentioned, your ME FW does not have this section, so it does not apply. You may be doing something wrong in the edit, or if system has two chips you need to dump both and append file, then do the edit, then split and put back into each chip
OEM Public key will remain, this has nothing to do with step #7 platform integrity. I checked a dump I have here from another user, it’s not in this BIOS either, so you skip step #7 as mentioned.

* edit - I just realized, there is no clean RGN here to use, other than older version. Are you OK with that?

* Edit 2 @robertd - here is clean ME FW/BIOS using your files in post #1 as base/source, ME FW version is downgraded due to what I mentioned above, but you can upgrade to latest with ME FW update tool within windows or DOS once up and running again…893301174699091

MEA RSA = Yes, skipped step #7 too, so something in your process was wrong maybe?
Don’t edit BIOS otherwise, Boot Guard is enabled, and probably burned into PCH FPF fuse too, so only certain areas of the BIOS can be touched (in case you are also applying other edits/changes etc)

I program using SVOD3.

Ok, i program your dump, and i has the same situation, when i plug, AC Adapter motherboard take 0.138mA, i has 3.3V, 5.0V, 1.0V, but motherboar dont start… I replaced PCH, after replace works fine just start 1 mintute… then i clear region using FIT, and after clear region i has problem like that… i using LBE, FIT, HXD, and nothing change…

On SPI i has 3.3V too… maybe i brake PCH with wrong cleaning?

Edit1: i see in me analyzer your dump is not configured but hXd saying region is diffrent like mine

Edit2: when i program old dump - i has the same problem 0.138mA …

I don’t know what SVOD3 is?? You replaced PCH?? You should have said that in your first sentence! Was this a BRAND NEW PCH, or do you not know?
If PCH has a key burned into FPF fuse, you cannot use it, it would never match this BIOS/ME FW key and you can’t see the key to enter it into ME FW either. Unless maybe from same exact machine, then it would possibly work.
You need clean PCH, never used, or at least confirmed by your own eyes to NOT have a key burned into PCH FPF fuses (check via MEINFOWin -verbose, look at end of report, if you see anything enabled at left/FPF side then you can’t use that PCH

So, you had it working fine, until you tried to clean ME FW? If yes, then program back in that original dump you made, before you tried to clean ME, then it should be fine. If not, at least it should boot again, then you can run MEINFOWin -verbose, and see if key burned into FPF

Ahh! Sorry, please wait, I did not see “initialized” until you mentioned in your edit, let me redo that and see if I can make it configured!

Yes, you may have PCH soldred on wrong or not fully, shorted etc, if programming in original dump does not work either!

Sorry for not saying.

SVOD3 - its deivce for program SPI, bios etc…

PCH - SR40B - was burrned, i replace for NEW ONE, after replace evrything work byt start to logo taking 1 minute for motherboard

When i clear region 1st. time the problem start - motherboard dont work anymore

When i program old dump - i veryfing this 2 times - i has still problem

So, maybe i destroy this PCH after first cleaning?

Thanks for your help.


Yes, you may have PCH soldred on wrong or not fully, shorted etc, if programming in original dump does not work either! --------- no cuz after replace PCH motherboard work, with new one pch, after programing 1st. time BIOS stop working

I think we have a translation or terminology issue, we aren’t talking same things, at least I think. To me, PCH is chipset, and I assume you meant you replace PCH (desoldered, and soldered in new/other one replacing old)
When I say burned, I mean a key is stored permanently into PCH chipset. You cannot have that, if you replace, unless you replace with PCH from exact same model, then maybe it would be OK

Sounds like, whatever you did, system was OK, running fine, yes? Then you didn’t like boot up time, taking too long, so you decide to clean ME FW? Yes? If yes, program back in the BIOS before you did that, if this fails, then something in your write process fails.
You can’t always rely/trust software verify the write. Write the chip, do not start or power machine, then dump it, then compare in hex what you dumped now with what you wrote, is it a match 100%?

Cleaning ME FW, or even messing it up on purpose or accident would not damage the PCH, only cause system and or ME FW to fail to start. No physical damage should be done, unless you incorrectly changed some voltage settings in ME FW, then maybe.
Original working dump from system that was running and you wanted to fix slow boot time, that should work if you program it back, if not then your write is failing.

Sorry, I cannot fix clean ME FW for you until Plutomaniac is back full time. He needs to update the ME FW guide for V12 at step #9 - to explain cover CSE Region and ME Sub Partition.
If you replace ME Sub Partition as the guide says, this fails to build, if you replace CSE Region with ME FW Stock RGN, build is OK, but initialized already, if you replace CSE and delete ME Sub Partition (assuming initialization coming from here), fails to build
So guide needs updated to discuss what’s going on here, how to replace ME Sub Partition and or CSE region and not have outimage initialized etc. He’s busy right now, so may not have chance to reply for a while, but I will try to have him look soon


Yes, its all like you write.

1. Client come with burrned chipset - 1.0V was shorted to the ground
2. I buy NEW one chipset and replace
3. Laptop work great after replacing but logo coming to soon - like 1 minute
4. I clear ME REGION using FIT in orginal bios file
5. I program clear file to the SPI (BIOS)
6. Motherboard is dead…
7. I program old dump - i veryfing it always 2 times
8. Motherboard is still dead
9. ME, You and others trying help me with modding this region
10. If we end and i repair this will be a great lesson for us :smiley:

EDIT: i has program LBE for working with bios files, i cleared more that 1000 files, i really know what i do, but with version 12 i has problem its something new for me and still learning that is why i love repairs electronic: D

See, to me “Burned Chipset” does not mean physical damage. I was talking about burned in key into PCH (Boot Guard) burned into PCH via software, locking key to PCH/System

2-3 sound good! To me that means it should be fixable by programming in last dump before you worked on ME FW then. Verify how I mentioned, write it, do not power on system, do not try to start etc.
Then dump and compare in hex editor what you wrote with what you dumped, software verify/compare from programming software can’t always be trusted, if doubt like now, compare in hex with source file and new dump after write
This way you confirm 100% your write is valid and OK, by dumping it and checking yourself in hex editor.

Yes, for me too, V12 is issue right now. Hopefully plutomaniac will update guide some, especially step #9.
I have issue with merging new PMC with stock ME region only too, sometimes, but I usually figure it out eventually

At least it doesn’t treat me as bad as ME FW on X79 system , I refuse to do that for anyone now, only show them how to update via ME FW Update tool.
If ME corrupted, then I tell them they must use programmer and stock BIOS/ME, then update ME via ME FW update tool after working state again

I don’t see any problem with the guide and no FIT crash or similar. It’s simple: load 20200311_085019_SVOD3.bin, save xml config, go to 20200311_085019_SVOD3 > Decomp, replace ME Sub Partition.bin with renamed as “ME Sub Partition.bin”, load back the xml config and build.

hi, thanks for your time.

So maybe you can clean this BIOS file and make configured ME region? becouse we cant;/ and if you do it and this will work i will pay for you for sure;)

Hi @robertd , Excuse me if am writing some nonsense. Swapping PCH chip as you mentioned is interesting stuff for me, so silly question - if I will swap PCH 6 series to 7 series chip, will this be all working? I am already runnig ME 8 due to @plutomaniac kindness on 6 series, so ME would not be problem there. Just for sure, do you think is here technical possibility to do is? I am just thinking from overclocking perspective, but if PCH chip included ME region only than no way to mess with for me.
Thanks Dan

Hi :slight_smile: @DaCou write for me motherboard version.

For sure, i know you can change SJTNV PCH to SLJ8E PCH, then you can use procesor like i3,i5,i7 :smiley:

ME region is the same but cleaning it is easy like hell :slight_smile:

EDIT: @DaCou you must give me right model of PCH not series, i dont know what series it is

Thanks for reply. It wont be simply find some documentation on PCH model, it is AIO Lenovo hybrid (H61)wchich I am using for my experiments and it is not about cpu, because the board came with Pentium G 630 and now I am using I7 3 Gen due ME7 swap to ME8. But I am struggling with some MSR, which were set by Lenovo or it is PCH settings (?), it is not documented properly of course. Lets say cpu is supporting plus 400 Mhz, but MSR saying NOT :slight_smile: I will search for exact PCH and let you know. What ME cleaning you mentioned is concerned, I dont know much about, and also struggling with modify ME for BCLK OC by my self, but from last Pluto response I got, you actually cant cleaning anything just apply RNG and build the setting.

plutomaniac - Wow, really? EVERY Time I edit ANY BIOS w/ V12 I have similar issues at step 9, always a hassle no matter what, often due to which file to swap/replace.
I have not noticed until this one if all v12 I edited in past said “initialized” afterwards or not, so that problem may only be specific here. But all, I have to do 2-3 times before I figure out how/which file to replace during the swap/UPD and it’s often not the one this step says to replace in the guide.
So, from what I see every time with V12, some kind of clarifications or updates need added there. It would also be great, if you could add how to merge ME+PMC, when time permits, whichever is easiest method (ME FW directly + PMC or BIOS as a whole + PMC etc)

So, following your exact instructions, which I did before and this fails, same file today too. And replacing CSE image with ME FW instead works, but I assume this is wrong, and what causes the “initialized” outimage
Anyway, here is error following instructions above/guide step 9 same/same. Except I am using, because it was only RGN in package I had at the time (r15 repo, will download latest now)
Maybe it’s due to that? Or, due to I have nor merged any updated PMC (mainly due to this is also a hassle, I’ve figure out once, but only by accident) I’m using r20 tools package, I see there is new one, so maybe this is the problem?


I’m at the point now with V12, soon I will be treating it like X79 ME FW, and refuse to do this for users, it’s too much hassle, always a problem with this or that, huge pain in my rear

* Edit - Disregard! And my apologies for not updating stuff first! It must have been something either with the R20 package version?
Or do I need to delete those cse_image_FWU images each time after I run program (for other BIOS, to keep FITc folder clean)? Maybe those from some previous BIOS being in there causing issue?
I only thought of this because I see they were not in tools package originally, but appear after using FITc, so maybe old ones in there from previous other BIOS edit cause all the problems I had with V12? I’ve always left them I think, assuming they were meant to be there.
If this doesn’t matter, then some bug with v20 FITc I guess?

@robertd - Please wait if you see this post now, I will retry with version plutomaniac mentioned once I download it, but I assume same/same will happen because it always does for me with V12 ME

Edit @robertd - here you go, updated clean ME and updated PMC (not “initialized” either, but “Configured” as it should be)


The guide expects that the user has the latest tools, repositories and a clean working directory. Everything works, I have never had any issue with CSME 12 and the guide is as clear as it can be IMO.

plutomaniac Thanks, I usually always delete all old folders, ini and log files, but I must have thought those cse_image_FWU images were part of the required files to be left in place, so I had been leaving those and I guess that’s maybe what caused all the issues.
Unless issue with older version in r20 package which I had been using for a little while. Anyway, thanks for checking it out for me!