Safely remove DXE Modules without breaking (not enough space) (root volume can't be grown)

Hello,
I want to use my M.2 as a bootable device on my P8P67 motherboard, but I always have the problem that I don’t have enough space. (NVMe Support for old Systems)


Now I’d like to erase something, but I’m afraid to break something.
PXE or Raid, I do not use at all, but where do I find this.
Is there a table somewhere where I can look up what all this abbreviations means?

Or could someone post here what i could delete without worries.

Information: Asus P8P67 Rev 3.1 BIOS Build 3602
MMTool .txt extraction: https://pastebin.com/VdyMhGPC
ROM Link: https://www.asus.com/Motherboards/P8P67_REV_31/HelpDesk_BIOS/

thx th0mak, from germany

EDIT by Fernando: Typos corrected within the thread title

@th0mak :
Welcome to the Win-RAID Forum!

Which SSD model with which protocol (AHCI/NMe) do you want to use as bootable system drive?
Very important: If there is not enough space within the DXE Driver Volume, you have to remove 1-2 other modules, which are located within the same Volume.
If you don’t use RAID, you can remove the Intel EFI RAID module named RaidDriver or SataDriver without running into any problem.
If you dont use the “Wake-on-LAN” option, you can remove all LAN EFI modules. >Here< is the related tip given by CodeRush.

Regards
Dieter (alias Fernando)

Samsung NVMe SSD 960 EVO
Yes it is in the same Volume.
I can’t find any RaidDriver or even Raid. When i’m searching for it, it jump somewhere thats called “Setup”.
“DpcDxe” and “Udp6Dxe” it does not find.

http://www.bilder-upload.eu/show.php?fil…-1521408878.png

Full List (paint skills, sry) http://www.bilder-upload.eu/show.php?fil…-1521409245.png

@th0mak :
I cannot help you regarding the choice of a removable DXE Driver.
Hopefully you will get an advice from someone, who knows more about this topic.

First of all I would like to thank this forum and its active members, who make it possible for normal users like me, to do such things in understandable language.
I’ve managed it now after several hours and failures.

I went on a search and found the following:
In this thread, I have read that I could remove the"ntfs" modules.
Personally, I cannot recommend this. In my case it has rendered my motherboard inoperable.
Thereupon, black screen and nothing worked.

After some despair and experimentation(CMOS Battery, Jumper, Press all available buttons and switches on the motherboard);
I accidentally got a memory test image. This was achieved by pressing the “MemOK” button (didn’t even know there was one) on my motherboard.
It seems to start a small part of my BIOS that allowed me to interact with the system.
Then I pressed “Del” button on my keyboard and entered the BIOS, where I was happy enough to patch everything back. (Stock ROM)
After this shock I wanted to keep my hands off, but the interest was too high.

At the second attempt I removed the module “OnBrdDevDXE”. Why exactly that. I don’t know, in the name stood “Dev”, which I then assumed wouldn’t be so dangerous. (Naivete to the power of ten, german adage)
This time, however, the boot process worked. After a restart and a short check in the bios, the option for the NVMe was actually there.
Immediately I wanted to test the result and installed Windows 10 on the new NVMe SSD and tested the speed. (photos 001)

NVMe_speed-test_alt.png



Well, just as fast as my 6 year old SATA SSD. But after some research I found this: Asus P8P67 specifications Page - Expansion Slots



Ok, done.

NVMe_speed-test_neu.png




Ok that’s it, thanks for the forum and the help.

@th0mak :
I’m sorry that removing the Ntfs module did not work for you.

Note tha MMTool seems to produce slightly different structures than UEFITool. I’ve once bricked my BIOS using a firmware image produced by UEFITool, but replacing the module inserted by UEFITool with the same .ffs file using MMTool produced a working firmware image. Unfortunately I don’t fully understand what difference caused the issue. You might have encountered a similar issue.

Also note that you might be able to insert the new NvmExpressDxe_Small module (available in the NVMe guide) without having to remove any modules from your BIOS.

@th0mak :
First tell you that I feel totally identified with you, because it is this comment "After this shock I wanted to keep my hands off, but the interest was too high"
Second I resort to your recent experience since I bought the same SSD and I have the same motherboard as you (Asus P8P67 B3 - BIOS Firmware 3602). I am also a user with limited knowledge in this matter, for this reason I need your help to do the correct procedure to enable the NVMe module in the BIOS.

From already thank you very much
Ale

EDIT by Fernando: Unneeded fully quoted post replaced by directly addressing to the author (to save space)