Samsung 980 NVMe M.2 500 GB on ASUS P8Z77-V DELUXE 2012 won't boot

Attempts with the provided file fail. Flashing the chip goes well, but the BIOS hangs on startup. It is not possible to enter BIOS to change settings. To get out of this situation, I have to reflash the motherboard chip using the original Asus BIOS version 2104 (unmodified). I have performed several restarts, the result is always the same. POST is interrupted and it is impossible to enter BIOS to change settings.
Also, I can’t help but make the link with my previous tests, when the CSM parameter is set to Disabled, POST also stops. And the only solution to get out of this situation is to restore factory settings by ROM reset. By default, the CSM setting is Enabled.
QUESTION. Does the NVMe4 BIOS, provided file, have its CSM settings set to Disabled by default? Which could explain this blocking at startup.
Thank you for your help.

THANKS ! I will reflash the motherboard chip using NVMe modified BIOS.
Thank you for your help.

No, no values/strings changed, the mod file was done like i did dozens of times, NVMe mod only and confirmed to work by me om my past boards and other users…

So you definitely have an issue with your system, as you see now, your file mod and my file mod , reproduces the same behaviour, this must be presential debugged by someone with more expertise.

The situation you report its only seen when the bios is modified on internal strings/values, usually when using AMIBCP, that’s why i asked before if there was any other mods in your file.

Is there any “little” detail that maybe you “forgot” to tell us about?

What’s the q-CODE displayed when the bios/post hangs?

“i asked before if there was any other mods in your file”.
I don’t understand this question.

“Is there any “little” detail that maybe you “forgot” to tell us about? »
Maybe, but for the moment I don’t see. I’m going to start the whole procedure again from the beginning.

“What’s the q-CODE displayed when the bios/post hangs? »
Black screen ! No messages, waiting.


You dont even know your own hardware…

Have you tried to boot the mod in others pcie slots?
Test it on all PCIe slots (The Blue, White and Black one)

As I indicated above, I started the procedure from the beginning. Not that easy.
The first time I edited the Z77VD.CAP file using MMTool (Windows). I didn’t encounter any difficulty. And the double check that followed, using MMTool then UEFITool, showed that the NvmExpressDxe_5 code was indeed inserted into the file.

Rereading steps 1 to 4 of Fernando’s guide, I note the following recommendation regarding ASUS BIOSes with *.CAP suffix. This is only a recommendation, not a requirement, but skipping it the first time could explain the problems encountered.

Capture d’écran du 2023-10-12 23-11-46

So I decided to add this step to the process. But the procedure for un-encapsulating and encapsulating the file is not clear enough for me and the tests I have just carried out require a new request for help.

According to the extract above, under UEFITool, you must point to AMI Aptio Capsule then right click\Extract body…, the procedure works very well and the extracted file is by default in .rom. Which is perfect for its future modification. But the re-encapsulating procedure is not indicated and in the following line a link refers to the Lost_N_BIOS method of 07/18/2018 which also does not detail the re-encapsulating of the .rom file.
The method proposed by MeatWar on 05.09.2022, for its part, deals with extracting and replacing the modified file in the capsule, but the action must be done on BIOS Region and not on AMI Aptio capsule. I also tried this method and encountered two problems:

  • When extracting (BIOS region\Extract as is…) the extracted file is not necessarily in .rom. We can choose the extension.
  • On insertion (BIOS region\Replace as is…) the inserted file is added to the existing BIOS region file, but does not replace it. We therefore have two BIOS region files, which are much too large.

Thank you once again for your help.

Capture d’écran du 2023-10-12 23-11-46
This option is not used in all ALL .CAP files, it depends on motherboard model.
The guide was written but small details had changed along the years, mostly due to modifications by the OEMS to their bios and security upon new releases, some bioses got easier to mod some got harder, some of the methods and notes on the guide are mostly general rule…some specific, but the CORE of the guide and the use of the NVMe DXE driver is still the same across the releases of bios by the manufacturers.

What’s your answer to the questions on my previous post?

I have done this mod on my past boards Asus Z77 (M5F, P8Z77-V PRO), Fernando also had an Asus Z77, they all have USB BFB and the mod can be done directly on the ASUS .CAP file and flashed with USB BFB, i never had any issues… I’ve done the mod for you as it was for me…

AMI MMtool4.x method used.

EDIT: So, what’s your conclusion from these previous facts?

This is not a good sign, according the AMI table below…

Ah! The inscription Q_CODE is at the very bottom, hidden under the display, you still had to know about its existence! But above all, you have to get on all fours to catch a glimpse of it.

“You don’t even know your own hardware…”
I can confirm that you can use a computer without knowing it well.

"Have you tried to boot the mod in other PCIe slots?
Test it on all PCIe slots (The Blue, White and Black one)
I confirm that I have tried all four solutions: M2 SSD connected to blue, white, black and unconnected PCIe. The result is always the same, the POST stops and nothing more happens.
The Q_CODE displays FI or F1 for approximately 0.5 seconds then a very short cycle runs (also 0.5 seconds), all the numbers scroll at high speed on the display, the cycle stops again on FI/F1 and the cycle starts again until the computer shuts down.
Note that during this cycle of approximately twice 0.5 seconds, two LEDs flash at the rhythm of the cycle, DRAM_LED and CPU_LED. When FI/F1 is fixed, DRAM_LED is lit and when the cycle is scrolling CPU_DEL is lit.

This is not a good sign, according the AMI table below…

What should I conclude from this?

From this…

I don’t know what conclusion to draw from this latest information, but the night brings advice and I intend to close the chapter for today. I will read your latest analyzes tomorrow.
THANKS ! Good night.

Well im sorry but i cant lose more time on this, the conclusion is simple… it works for all past users and it’s not working for you, then it has nothing to do with the guide offered here and the issue is on your side, as it’s hard to debug further from a forum.

I must admit, what drives me nuts here… is even if the fault was on your side doing the mod file, still my file also doesn’t work on your motherboard… also, the curious fact that the bios can be written back with the original file and using the mod, the motherboard seems to enter in a recovery state…

All the best, good luck.

@AvisAlba @MeatWar
Maybe I have found the reason for the troubles to get the modded BIOS properly working:

The modded BIOS named Z77VD.CAP seems to be corrupted. An obviously important Pad file has been removed by the used BIOS Modding Tool while trying to add the NVMe module!

Look here:
a) excerpt of the original BIOS named P8Z77-V-DELUXE-ASUS-2104.CAP (with Pad file):

b) excerpt of the modded BIOS named Z77VD.CAP (the Pad file is missing!):

After having detected the missing Pad-file within the Z77VD.CAP I tried to insert the NvmeExpressDxe_5 module into the original BIOS by using the AMI MMTool

Here is the result (the Pad-file is still present!):

Note: The missing Pad file obviously has been missed by checking the modded BIOS, because this unwanted change happened outside of the DXE Volume.

1 Like

Thank you, Fernando, for this thorough analysis… still, i have no explanation how i always treated these files like this and worked on my boards… maybe something has changed within Windows environment causing the tool to behave like this, my culprit

And very unlucky also from his side as he claims to have done the mod several times…

@Fernando @AvisAlba
EDIT: Seems that UBU/Latest MCE v1.94.2 r276, removes the original PAD…tested updating all other modules, it only loses it, when updating the mcodes.
I did that to the previous shared mod file.

Link is updated, try it or follow Fernando’s notes.

The answer could be this…

@Fernando @MeatWar
First of all, many thanks to both of you for taking the time to try to resolve my issue.

The tests I have just carried out with the MeatWar NVMe version 2 BIOS provide new elements.

As a reminder, the MeatWar NVMe BIOS version 1 led to a POST blockage. Couldn’t get into BIOS to change settings. And the only solution to get out of this situation was to re-flash the motherboard chip using the original (unmodified) BIOS.
With the MeatWar NVMe version 2 BIOS, POST works normally, you can enter the BIOS to change settings and the Samsung SSD M2 drive is visible in the BIOS Boot menu. At this point it should be noted that I had successfully installed Windows 10 during a previous attempt. The SSD unit therefore appears in this form: Windows (Samsung SSD 980 NVMe).
But Windows 10, previously installed, does not start. Windows tries to start, but it fails. I assumed it was the boot zone that was not installed correctly. So I tried to reinstall Windows 10 from the FAT32 USB key previously prepared by Rufus. And then surprise, impossible to boot from the USB key. I then tried booting with several other Windows and Ubuntu bootable USBs, prepared by Rufus or by Ventoy. None of the keys start. So this NVMe modified BIOS has another problem. I re-flashed the chip with the original (unmodified) BIOS and I can use the computer again.

So I used Fernando’s analysis method and here is the result.

A. Capture 1. BIOS MeatWar NVMe V.1. The NvmExpressDxe_4 driver is present in the last line of the DXE driver (highlighted line - 1). Further down, the Pad file is missing (highlighted line + 3). These two points were highlighted by Fernando.

B. Capture 2. BIOS MeatWar NVMe V.2. The Pad file appears (highlighted line + 3). But the most surprising thing is that the NvmExpressDxe_4 file has disappeared. It is replaced by four drivers, installed in the last four lines of the volume, Nvme, NVMEINT13, NvmeSmm, SAMSUNG_M2_DXE.

I don’t understand this weirdness, but it’s not a big deal. On the other hand, much more serious, why does the MeatWar NVMe V.2 BIOS not allow you to boot from a USB key?
Thank you for your help.

Well if its wrong again… your solution is simple, do the mod yourself.
You now know what to check, so go ahead.

If you want, you can flash at own risk the attached BIOS, where I had just inserted the NvmExpressDxe_5 module (no other modification has been done by me!).
Please report here about the result of your test.
Good luck!
P8Z77-V-DL_Modbyfern.rar (4.2 MB)

@Fernando @MeatWar
Eurêka ! Eurêka ! Eurêka !
According to tradition, it was by shouting this word that Archimedes ran naked through the streets of Syracuse when he understood the principle of the eponymous push.
More modestly, I didn’t walk the streets naked, but I shouted Eurêka when I first saw “Boot Overdrive PATA SS:”.


  1. The Asus 2104 BIOS, modified for the first time by me, allowed the operating software (Ubuntu and Windows) to be installed on the NVMe SSD, but did not allow the computer to boot on said NVMe SSD.
  2. The numerous tests that I subsequently carried out under the advice of MeatWar were unsuccessful. Also, Friday October 13, I started the procedure from the beginning. And when rereading steps 1 to 4 of Fernando’s guide, I noticed that I had modified the Z77VD.CAP file without extracting the body of the file, although it is recommended for Asus files with *.CAP suffix. Body extraction (de-encapsulation) is easy to perform using UEFITool. On the other hand, the opposite operation, of reinsertion of the body (re-encapsulation), is much less simple and I have not found sufficiently detailed explanations in this forum to successfully complete this operation.
  3. However, MeatWar confirmed to me that extracting/re-inserting (de-encapsulating/re-encapsulating) the body of the *.CAP file is not mandatory and that changes made directly to the *.CAP file work perfectly. In addition, MeatWar offers me a modified BIOS 2104 file.
  4. MeatWar NVMe Version 1 BIOS is not working. It causes POST to hang without the ability to enter BIOS. The only solution to get out of this situation was to re-flash the motherboard chip using the original BIOS.
  5. The MeatWar NVMe Version 2 BIOS does allow you to enter the BIOS and start the computer on a system disk on which Ubuntu or Windows was previously installed, but it does not allow you to start on a bootable USB key in order to install the operating system (Windows or Ubuntu) on the NVMe SSD.

So I started modifying the Asus 2104 BIOS again, but this time using the two available tools, MMTool and UEFITool and not only with the first. In addition, Fernando also offers me a modified file.
Test results:

  1. Asus 2104 BIOS modified by MMTool. Flashing of the motherboard chip fails.
  2. Asus 2104 BIOS modified by UEFITool. Flashing of the motherboard chip is successful. POST proceeds normally. We can enter the BIOS and there, Eurêka, for the first time, in the Boot menu I see “Boot Overdrive PATA SS:” displayed on the screen. We have confirmation that extracting/re-inserting (de-encapsulating/re-encapsulating) the file body is not necessary. All other tests are also successful, booting from a bootable USB key, installing the operating system on the NVMe SSD and starting the computer on said NVMe SSD. Eurêka !
  3. BIOS Asus 2104 modified by Fernando. Flashing the motherboard chip is also successful. And all other attempts also succeed as before. I guess Fernando also modified the BIOS with UEFITool.

CONCLUSION. I strongly advise against using MMTool, which obviously is not 100% reliable, at least to modify the BIOS 2104 of the Asus P8Z77-V-DELUXE motherboard. This tool has been crashing my project for a year. I had already launched this project in September 2022, then abandoned due to lack of time at the time. I resumed it in October 2023 by registering on this forum. The advice received here allowed me first to identify the problem, then gradually to tighten the diameter of the circles until the final assault. Determination and perseverance are the key words.

Many thanks to MeatWar and Fernando and long live this forum.


You are absolutely wrong: I had used the AMI MMTool v4.50.0.23. By the way - there was no reason to guess, which tool I had used for the BIOS modification, because I had written it explicitely within >this< post.
As a consequence your CONCLUSION is wrong and misleading as well. Please correct it.
It was not the tool, but its user, who obviously made the mistake.

My conclusion:
The easiest and in most cases safest way to get an NVMe module properly inserted into an AMI Aptio IV BIOS is to use the AMI MMTool v4.50.0.23.
That is the reason why I had set this specific procedure into the first place within my Guide (>Link<).

6 posts were split to a new topic: ASUS P8Z77-V Deluxe with NVMe/PCIe Slot Problems