Samsung NP RV-410 (Scala-14L, Phoenix BIOS) how to disable checking GPU ?

Hello!
I have a Samsung NP RV-410 laptop, it seems to have a faulty video chip. I have no desire to repair it. But I really want to run and use without graphics to run programs on it through a network connection. Is it possible to remove the check for a graphics adapter in his Phoenix BIOS? Or put some kind of "plug" so that the laptop "thinks" that the adapter is installed?

NP RV-410.zip (2.18 MB)

It should boot of PCIE graphics or internal, if one is disabled/dead. Did you test connecting external displays? For that test, each port, connect the monitor/item before you power on, then wait a few minutes to see if it’s going to start displaying there or not.
PCIE is set to always enabled, but Internal IGD is set to auto. << This can be disabled possibly, but you need to test and confirm external display is working, to ensure the PCIE graphics is installed and working, otherwise if you disable this then no graphics either so would give same/new error if no PCIE device present.

It may also be possible to just set video errors to be ignored.

There is two BIOS in the file you provided, which does your system use?

Thank you for your prompt reply, and sorry if my english is bad.
This laptop model has only PCI-GPU, it does not have integrated video. Many people write that the problem with this model is the failure of the GPU, due to which the laptop does not start.
Yes, I tried to connect a monitor, press button combinations to switch to the monitor - but the image did not appear. I tried to warm up the video chip a little with a soldering hair dryer, after which it started emitting smoke (I’m not a repairman, I just wanted to fix my old laptop), then I removed the video chip, now the laptop also starts up with a black screen.



Yes, I would very much like to set this BIOS setting by default, but without a working video chip this is impossible.
Can I somehow switch this in the Bios ROM file? (Well, that is, set this setting as default)


Bios labeled 8020 is a modified version for GPU8020, it is used by repairmen when replacing the chip.
Unmarked Bios is standard for this model. I can dump the current Bios of the laptop, if someone can make the modification instead of me, of course it’s better to do the changes on the current one

On the attached diagram, DDR2 memory, but in my laptop DDR3, but on all sites they write that this is the most suitable diagram for my model:
[[File:[???-???.??]Samsung RV410 Scala-14L BA41-01325A.png|none|auto]]

[??????????-????.??]Samsung RV410 Scala-14L BA41-01325A.png

@Voha888 - You’re welcome! Your English is fine
I’m not sure if it was best idea to remove the PCI GPU, before trying this kind of fix. I can make you BIOS with PCI and IGD disabled + Ignore errors, or not stop on error etc.

I did grab schematic that shows image you posted above, but I could not tell from that, or board images online, if these came with both internal graphics and additional PCIE graphics by default or not.

So, you have hardware flash programmer, and can dump the BIOS with this? If yes, great, I was worried maybe edit with Phoenix BIOS tool could break BIOS, but if you have programmer then no worries.
If you do have programmer, like CH341A or other, please dump BIOS and send to me.



Thanks! It’ll be cool!
There are two files in the attachment - a version for GPU8020 from the Internet, and “25q16v.Bin” is my current backup, read using ch341.
I have attached two files, because today I managed to check the version for GPU8020, the laptop is trying to turn on on it - flashing LEDs, and it seems to me that it may be a newer version than in my laptop

Samsung NP RV-410_bios_backup.zip (2.18 MB)

I already have the two files from post #1, and am on limited internet, don’t want to download stuff twice. Please attach only your dump
Or, are you wanting me to edit both GPU8020 and your dump?

If yes, still, just upload your dump only, I already have the other one. But, please note, it is not named GPU8020, only RV410-S01_8020, is this not the same 8020 you’re referring to above?



Yes, if it doesn’t complicate you. Once you have a bad internet connection, make a modification on the files you have already downloaded. If it works on them, then I think there is no point in downloading my dump.

So that you do not download anything unnecessary, make a modification over the file “RV410-S01.BIN” and I will try to run it. And only if it doesn’t work with it, let’s try with my dump. Let’s go like this? To make it easier for you. thanks


Yes, I was talking about this file


The attachment contains only my dump. If it’s not a secret, what is your internet price?

25q16v.zip (1.09 MB)



Apparently it turned out to be a little more complicated than you expected? With the help of Phoenix Editor I found the Legacy OS boot option, maybe enabling it can help? But my version is very old and cannot build the bios image back properly

@Voha888 - Sorry, I was not feeling well last night, and missed your post the day before
Your comments above + the one in #5, make this even more confusing. You said RV410-S01_8020 (or GPU8020, if this is the same file), is meant for working on the GPU, but post #7, you mention to not edit this but the stock one instead??
Please confirm, is >> RV410-S01_8020 = GPU8020? If yes, why not edit this, seems like this file, if it’s what you mention, is meant to be used when graphics is not working, correct?

It’s no problem for me to edit any of these, only takes a few minutes.
I can’t remember my internet price, maybe $80 a month after taxes/fees added, why do you ask?

Legacy OS boot, has nothing to do with this kind of stuff you are asking about, that is more about booting UEFI BIOS or Legacy BIOS and GPT or MBR boot disks/HDD/SSD etc
It would switch what internal VGA vBIOS/GOP option is used, but that does not really apply here since you are not using onboard graphics.,
However, that could cause issues if your PCIE graphics only had legacy vBIOS image and not GOP in it’s vBIOS, but that would only matter if it was actually working

ALL versions of Phoenix BIOS editor are VERY old, but I think of the latest 2007 version, only one variant works and others usually fail (best one is build date Jan 29 2007 10:15:59)



Excuse me, I thought you had a problem modifying the file



The 8020 file is a modification of the original Bios from the repairers to work with a non-standard chip (a cheaper chip that is installed when repairing a laptop)
RV410-S01.BIN is the original Bios image and so I think the best option is to make modifications with it. Or tell me the HEX address, and I’ll make the modification myself in the hex editor - so that you don’t waste your internet traffic. Thanks!



I have a bootable drive for an ARM processor and this laptop is trying to read it! The read LED on the drive blinks for a long time when connected!
And Ubuntu doesn’t try to drive it. That’s why I thought that the problem is somehow related to the boot area

Please, make a modification to the RV410-S01.BIN file or tell me to do it myself. I understand that this needs to be done in the TEMPLATE00.bin file (which is inside bios), but I don’t know what addresses. You can send only the TEMPLATE00.bin file - and I will add it to Bios myself using the phoenix tool v2.73



Interestingly, in this program, in the bios emulator, I did not find the "halt on" item, so I am not even sure that it is possible to disable errors

No, no issues doing any mods yet, have not touched any BIOS But I don’t expect any issues
I can’t give you any hex address to edit, this is edited with Phoenix BIOS Editor and entire BIOS will be recompiled, so I assume 100’s or 1000’s of bytes will change, not something you can simply edit a byte or two


You just have to look in correct place with Phoenix Tool, it’s not in “BIOS Settings / Setup Table” area, it’s in “BIOS Configuration Parameters” window

OK, here is RV410-S01.BIN edited -

Changes -
1. Errors To Ignore >> Video Selected
2. Errors to Wait on >> Video De-Selected

I also see something new, you can maybe try next, if these changes above do not help. On that same page (POST), there is option “System is a network server”, this can be selected/enabled, sounds like maybe headless mode to me?

Ahhh! Sorry, this is new style Phoenix BIOS, I do not know how to edit this, Phoenix Tool can’t be used
Your best bet is to ask for help at BIOS-mods forum, or mydigitallife forums (They edit a lot of phoenix there)
Sorry, I assumed I could edit, and didn’t realize it was this kind until I went to make the changes above tonight

You may be able to edit TEMPLATE to make the two changes noted above, but I’m not sure how to do that on this kind of “New Style” phoenix BIOS
But, I think the actual edit would need applied to >> BIOSCOD06.ROM (or after finding correct byte to edit, if you can find syncmos tool, that would work too)
http://forum.notebookreview.com/threads/…36/#post5991508
http://forum.notebookreview.com/threads/…28/#post2678924

You’d have to use strings and template to get the correct offset, or some other file similar to strings which holds the settings on the page I mentioned (Since this is not setup)
I looked in strings, and the settings I’m discussing are not held there, so I could not get you the correct offsets via this method. You’ll have to search through all the files until you find which holds the strings for that area, then go from there.

Thank You

@Voha888 - Sorry I can’t do this edit If no one helps at BIOS-mods forum, be sure to ask at mydigitallife forums since I see they do Phoenix mods often too.

Okay, thank You for You advice