Samsung rv720 30 minutes shutdown

Hi after months of searching the internet about a problem I have with my samsung laptop I finally found this forum which I hope can help me.Every 30 mins on the dot my laptop just shuts down with out warning ,looking through this forum it seems to be related to intels anti theft protection.If anybody can help fix this I would be greatly appreciated and don’t mind offering a reward as it driving me mad Thanks

Download ME System Tools v7 from the ME thread. Run Flash Programming Tool via “fptw -me -d me.bin” and check if you see any error. Run MEInfo via “MEInfoWin -verbose” and show me the result.

Thanks for the reply Plutomaniac the first results was-Platform: Intel(R) HM65 Express Chipset Revision: B2
Reading HSFSTS register… Flash Descriptor: Valid

— Flash Devices Found —

Error 103: There are no supported SPI flash devices installed. Please check conn
ectivity and orientation of SPI flash device.

and second was Platform stepping value is 4

Error 9455: Fail to read FW Status Register value 0x0

I hope I ran the commands correctly

Hi, replace the file “fparts.txt” at Flash Programming Tool with the attached one and try again. Do you see the same error when running “MEInfo -fwsts”? (1.42 KB)

Hi plutomaniac same error again

Did you replace the fparts text file at FPT? It should not show the same error again.

I replaced the file in fpt folder and ran MEInfoWin64.exe -fwsts in the me info folder maybe Im doing something else wrong?

fparts has nothing to do with MEInfo. You need to replace it at the FPT sub-folder you use (for example Windows) and then run “fptw -me -d me.bin” again.

Platform: Intel(R) HM65 Express Chipset Revision: B2
Reading HSFSTS register… Flash Descriptor: Valid

— Flash Devices Found —
GD25Q32 ID:0xC84016 Size: 4096KB (32768Kb)

Error 26: The host CPU does not have read access to the target flash area. To en
able read access for this operation you must modify the descriptor settings to g
ive host access to this region.

This is the error I get now

To repair this issue you need to have read/write access to the ME firmware region of the SPI/BIOS chip. This will almost certainly require opening the laptop as explained in the Flash Descriptor guide.

I managed to dump the bin file using me -d me.bin command but cant get the analyzer to run .If I upload the bin file could you check it for me? thanks

What method did you use to unlock the FD? Yes you can attach the dumped image to take a look.

Thanks I used the audio chip shorting method.I installed pyton and the two files but couldn’t get the analyzer to run I have attached bin file.

Ah, great. At this point most users stops replying or refuse to read let alone follow the FD unlock guide. Your ME firmware is indeed correctly dumped. The next step is to follow the Engine CleanUp Guide in order to clean/repair/update the ME firmware. I have attached my own guide output image which you can flash via “fptw -me -f me_fix.bin” followed by “fptw -greset” which will force a system reboot. If you want to double check, follow the guide yourself using the image you attached and you should end up with a copy of mine.


me_fix.rar (518 KB)

Thanks again pluto for your help when I run the command line fptw -me -rewrite -f me_fix.bin nothing seems to happen only a list of commands appear

Ah right, “-rewrite” first appeared in FPT v8. Remove it and try again as such: “fptw -me -f me_fix.bin”. Don’t forget “fptw -greset” afterwards.

Thanks so much for your help plutomaniac that worked and has fixed my problem and computer is running for over an hour with out any shutdowns .I am extremely grateful for your help as this problem was driving me nuts and I have send you a pm

Hi. I have the same problem with the exactly 30 minute shutdown on a RV720. Swapped out CPU and RAM and upgraded to Windows 10. Then I found this forum. I can find my way around a PC (build my own) but limited on knowledge when it comes to BIOS and Me related stuff. Should I follow your advice to Lostandfound?
I tried downloading the ME System Tools v7 but immediately got a Trojan Horse virus threat.
Can you guide this novice please?

Assuming that the new CPU is compatible with the laptop’s PCH (check via, you’ll need to dump your ME firmware via “fptw64 -d spi.bin”, follow [Guide] Clean Dumped Intel Engine (CS)ME/(CS)TXE Regions with Data Initialization and flash the output back via “fptw64 -f spi_fix.bin” followed by “fptw64 -greset”. If you get a CPU access error, you need to unlock read/write access first via [Guide] Unlock Intel Flash Descriptor Read/Write Access Permissions for SPI Servicing. The tools are proper, use a better antivirus or disable it during the repair steps.