Samsung sm951 256gb ahci locked after system chash

hi, I have a problem with a ssd m.2 Samsung sm951 256gb ahci, following a sudden stop of the system I am asked for a password to unlock the disk in question. I do not use passwords and I have not the slightest idea of what it is, I have tried many times but without success. The disk is seen on Windows 10, it asks me to initialize the disk but does not complete the operation. There is a way to unlock it?

ssd.jpg

ssd2.jpg

ssd3.jpg

Time for RMA - usually this means disk is frozen or frozen/locked, it’s a security state. You can try to Secure Erase it, some will set a new password or unfreeze it/set pass before erasing, but the one I’m thinking of that does that will not work on M.2 drives, unsure how others do the process but I think it all has to be done similarly.
Try Samsung tools, and ask Samsung directly how to fix, they may send you special tool to unfreeze it if they can tell you for certain it’s not currently faulty. That happens with faulty drives too, so they may have you check a certain way to tell them how it acts so they can tell if it’s bad or just froze/security locked.

thanks for the reply, unfortunately I have already contacted samsung but do not give direct support for OEM products. The seller also does not give me support because it’s been over a year

You can try secure erase using Samsung magician, it may work for you
https://www.samsung.com/semiconductor/mi…sumer/magician/

Parted Magic may be able to fix it or secure erase and unfreeze it too

Due to the way this happened, not locked by accident, or mid-way through a secure erase session, there’s high probability the drive is faulty now and not really locked/frozen.

There is some tricks that will allow you around this, if it’s not broken, but very tough to do some of those with M.2 (Like unplug and replug after booting, or booting and then plugging in after boot), you can also try switching disk mode to IDE and see if it will let you secure erase after all fail to work in AHCI mode.
Others you’ll need to get into linux/ubunto etc to run some testing and to see actual disk state. Here’s more info on what I’ve been mentioning
https://www.disk-partition.com/ssd-manag…n-ssd-3889.html
http://www.tomshardware.com/answers/id-1…-hard-disk.html
http://forum.notebookreview.com/threads/…he-bios.550453/
http://www.admin-magazine.com/Archive/20…-disks-and-SSDs
https://www.neowin.net/forum/topic/12295…zen-bios-probl/


thanks, I’ll try

Good luck, hope you can figure out at least if it’s gone bad, or is just security locked/frozen

unfortunately the ssd is not frozen, is a password that obviously do not know and Samsung not providing support for OEM does not provide me with a master password to unlock

PicsArt_02-07-12.43.07.jpg

@antome - Will it let you Secure Erase (enhanced, or not)? See this, sounds like maybe since security level is only “High” you can somehow still access the data, change security level maybe.
https://forum.hddguru.com/viewtopic.php?f=10&t=31673&start=0

Master Password is also mentioned as being 20h there, all blanks, but that user had no luck doing that so it may be incorrect.

See this also, and follow/read the links within, you might be able to PSID revert and fix it.
https://www.tenforums.com/drivers-hardwa…50-evo-ssd.html

PSID Revert
https://github.com/Drive-Trust-Alliance/…iki/PSID-Revert
https://github.com/Drive-Trust-Alliance/sedutil

Success report on 960, and since yours is older than that it may be working for your SSD
https://github.com/Drive-Trust-Alliance/sedutil/issues/241

See also, post #4 here
https://forums.lenovo.com/t5/ThinkPad-P-…st/td-p/1670209
links to https://forums.lenovo.com/t5/ThinkPad-T4…/1484320#M78496

Samsung-PSID-Revert tool here
http://s000.tinyupload.com/index.php?fil…743997551931768


unfortunately, secure erase does not work, master password with 32 times 0 equal

Did you try all the PSID revert methods/tools?


I tried with samsung psid revert, as soon as I select the disk the application closes if not a problem of Windows 10. But I doubt it goes because I do not have a psid code to insert

Code should be on sticker of the drive, one of those links explains it. Yes, it could be Win10 issue, Win10 is terrible for many things, still… If you can try on other system that might be better


unfortunately there is no psid code on the stick, I also 960 evo and 970 evo and there is, but on the sm951 no

No Bueno! May be out of options then

you may have been hijacked by malware, if suddenly after a crash a password seems to be set where there was none. Not much you can do except try a warranty request.

If malware, they usually want paid, so I doubt it’s that or you’d have the “Send bitcoin payment here to unlock” type message. It’s too bad this is OEM, Samsung wont help him with RMA