SATA HDD don't want to be detected on Kaby Lake

Hey everyone,
I’ve recently been trying to install Windows 7 on my Asus FX553VD laptop (same mobo as GL553VD) but I’m currently stuck on the disk selection page.

The specs of the PC are the following:

  • Intel Core i5-7300HQ
  • 16GB RAM
  • GeForce GTX 1050 2G
  • 500GB Samsung 970 Evo Plus M.2 NVMe (Windows 11 is installed on it)
  • 1TB SATA HDD (Half is data and other half I want to install Windows 7)

I have a clean copy of Windows 7 SP1 Ultimate in french and when I start it with no modification in UEFI mode with CSM enabled, I got an A5 error but I fixed it by using a patched acpi.sys. I also installed USB 3.0 drivers and NVMe drivers with Asus EZ Installer. I can now boot Windows 7 installer, touchpad does not work but I can use a mouse, and when I get to the disk selection page, I can only see my M.2 NVMe SSD. I also tried loading the AHCI driver provided by Asus EZ Installer for Kaby Lake (100 series thing) as well as some other versions I found here, they load without any error but the hard drive is still not detected. I can also confirm it works perfectly well so it’s not a hardware issue.
I remember having installed W7 in the past like last year but I didn’t install all the drivers and all that so I ended up deleting the installation…
Now I also tried a few other ISOs with a Windows 10 installer instead of the Windows 7 one and even made my own image with it but Windows 7 fails to boot and crashes with 7B error and in safe mode I can see it crashes after loading disk.sys so I assume the problem also comes from a lack of driver for the disk.

So yeah I don’t really know what to do anymore, I have tried a lot of things, even using UefiSeven or Flashboot Pro but I got similar results (if not worse)

Anyway, I hope someone has a solution!

Thanks in advance

EDIT: In case it is required to help me, here is the SATA AHCI controller’s vendor ID and device ID: PCI\VEN_8086&DEV_A103

@AlfaYT Have you tried using Diskpart to clean the disk? (Thanks to MattChaffee for typing out the instructions clearly):

To use the Diskpart.exe utility to clean the hard disk, follow these steps:

  1. Insert the DVD into the DVD drive.
  2. On the disk selection screen, press SHIFT+F10. A Command Prompt window opens.
  3. Type diskpart, and then press ENTER to open the diskpart tool.
  4. Type list disk, and then press ENTER. A list of available hard disks is displayed.
  5. Type sel disk number, and then press ENTER. number is the number of the hard disk that you want to clean. The hard disk is now selected.
  6. Type det disk, and then press ENTER. A list of partitions on the hard disk is displayed. Use this information to verify that the correct disk is selected.
  7. Make sure that the disk does not contain required data, type clean all, and then press ENTER to clean the disk. All the partitions and all the data on the disk is permanently removed.
  8. Type exit, and then press ENTER to close the diskpart tool.
  9. Close the Command Prompt window.
  10. Click the Refresh button to update the disk selection screen. This step lists the disk. Install the driver in this step.
  11. Run Windows Setup to perform a clean installation of Windows.

You forgot to mention the most important info:
Which is the manufacturer and model of your mainboard?
By the way - some mainboards share specific data transfer lanes (if a certain PCIe slot is active, certain SATA ports do not work). Tip: Look into your mainboard manual.

Hey, thanks for your reply.
I actually ended up installing W7 on a small partition on my SSD and to my surprise, when I installed the driver, it worked. I think I’m going to setup everything there and clone my installation on my HDD when I will be done and come back to share the results.

UPDATE: Cloned the installation to the HDD, works like a charm!

1 Like

Hey, I forgot to mention but this is a laptop (Asus FX553VD as I said). Also, I think I have found a solution (see the post right above) so I’ll come back and say if it worked or not after cloning my installation to the HDD.
Thanks anyways!

1 Like

Hey @Fernando,
I’m now facing another issue about a PCIe controller being disabled, and I don’t know what is the cause.
Here is a screenshot of the issue:

This causes my NVIDIA GPU to not be detected. It happened after I installed the NVIDIA driver and rebooted.
Also, if you look at the bottom left corner, you can see that my battery isn’t detected for some reason.
Additionally, my touchpad does not work but it seems that the issue is common with a lot of Asus laptops with ELAN touchpads.

EDIT: Fixed NVIDIA driver issue and PCIe issue by changing Intel INF and setting TESTSIGNING to on using bcdedit (for NVIDIA driver).

1 Like