Secure erasing NVMe SSDs on motherboards that do not natively support M.2/NVMe

After successfully modding the BIOS on my ASRock Z77 motherboard and installing Windows 7 on my 960 EVO about 1-1/2 years ago, I recently upgraded to a 970 PRO. After installing a fresh OS on the 970 PRO I attempted to secure erase the 960 EVO using the latest version of Samsung Magician, but though Magician recognized the SSD and would benchmark it, it would not secure erase it (it said it was unsupported). After reinstalling the 970 PRO I checked Magician and it said the 970 PRO was also unsupported. I assume it’s because the SSD is mounted in an adapter card in a PCI-E slot instead of an actual m.2 slot on the motherboard (which my Z77 motherboard clearly does not have). I then tried PartedMagic version 8-1-2013 and it did not even see the SSD.

I may end up selling the 960 EVO (and the KryoM.2 PCIe adapter it’s mounted in), as I have no other compatible PC to put it in. But I would like to secure erase it first if I sell it. I could over-write the data on the whole SSD, but I’d rather not go to that extreme unless I have no other options. Anybody come across this problem and/or have a solution?

The tool named Parted Magic is able to secure erase any SSD, which is detected by the BIOS.

Hello @Fernando ,
As I mentioned in my post, I tried Parted Magic version 08-01-13 and it did not detect either the 960 EVO or the 970 PRO. Both SSDs are detected in the "Boot" section of the BIOS, but of course, do not show up in the "Storage Configuration" section, as my Z77 motherboard does not natively support M.2 drives.

I suspected that I would have an issue with the SSD being locked like SATA drives usually are in Parted Magic, but Parted Magic does not even see the NVMe SSDs.

Use killdisk within windows version.

@Lost_N_BIOS ,

I’ll try it, thank you.

If you need an upload let me know. I have version that I know works on Win7, unsure about win10, and don’t know if it can see NVME, but I assume it can see any/all disks shown in disk management / available to windows.

I downloaded Killdisk free from their website, but could not find a secure erase function in the Windows version (using Windows 7). The only option for erasing or wiping with the free version was “Write zeros - one pass”. No mention of secure erase. I created a bootable USB and Killdisk shows a secure erase option for both hard drives and SSDs, but does not detect anything but SATA devices (no PCI-E).

I’ve used Mini-Tool Partition Wizard for a few years, but the free edition does not have a secure erase option. I found “AOMEI Partition Assistant” and the free Windows version does have a secure erase option, but when I selected my 970 PRO it had the nerve to tell me “The disk is not a SSD. Please choose a SSD and retry”.

I would have searched Google before posting here, but I assumed that this was an issue that was already known on Fernando’s forums, as it clearly has to do with PCI-E adapter card mounted NVMe SSDs. I guess I’ll try the 960 EVO version of Magician to see if it will support the PCI-E adapter card mounted NVMe SSDs, but I suspect it will not support it either.

Does your Windows version of Killdisk support the secure erase function?

Sorry, I forgot that did not have SE! I see you mentioned trying Parted Magic 2013, but did not try latest version, the 2018 version specifically says it deals with NVME and PCIE

There is this I found, looks like it will work, but it’s Linux app so you’ll have to boot to some type of internet connected Linux like a live CD or Ubunto etc - (When in Linux hdparm may also have SE for the drive too >> hdparm --user-master u --security-erase p /dev/sda << Set correct disk location)
Info -
Main page -

See also this, by Samsung, their tool will do SE, but only if the drive is secondary (not sure if this applies to your PCIE but dropping here in case it matters)

And I found this, Naraeon Secure Erase, it’s a live linux boot CD I think

Or there’s this, for only $8,600…wp-0007-00a.htm

@Fernando @Lost_N_BIOS
December 1st I finally got back to attempting to secure erase my old 960 EVO. I followed the advice of you both, and spent $11 on the latest version of Parted Magic. It was as simple as that (I felt rather stupid afterwards :slight_smile: ). Thanks again for your help.

@Paulos7 - happy you got it erased, but sad you had to spend $11 At least you own latest version of Parted Magic now

@Fernando - we need thumbs up smiley! By the words of Tony Beets “Lets make that happening”

The $11 was nothing when compared to SuperWiper for $8600.00 . I like how the newer version(s) apparently allow you to “unfreeze” a drive that is frozen. Thanks again.

That price made me laugh again, crazy high! Frozen drive is no joke! Is that $8,600 one what you’re talking about can unfreeze? If yes, I may have to pickup a copy, in about 100 years when it’s $8.60 and frozen drives are no longer used because we keep data on diamonds instead.

What about this one?

It’s huge in the edit/full post menu, did you see? Yes, it’s good one, but needs to be smaller which I’m sure you’ll do in a bit anyway.

Made me laugh, I was editing a thread and not there, then re-edited and blam huge thumbs up popped out at me

Thanks @Fernando !

Yes, I see it, but I currently don’t know how to erase it.
Nevertheless the thumbs-up icon is now within the smilies bar available (maybe still a little bit too big).

You can delete it and upload smaller image, do you need it resized or you can do? Or, if you can’t figure that out without changing out whole smiley package, find the image source on sever side image storage and replace with smaller image using same name.

@Lost_N_BIOS :
Meanwhile I was able to solve the problem with the help of the Xobor Support-Forum. The extremely big sized smiley doesn’t come up anymore (it is obviously a wellknown Forum bug) and the “thumbs-up” smiley is now available within the iconbar.
Enjoy it!