Shrinking Raid 1 C: boot drive - will it work?

I have a new Dell Precision 5810 with Raid 1 factory installed as the boot drive. The OS is Windows 10 Pro.
The drive management tool shows
Disk 0 500 mB Healthy (EFI System Partition) OS C: 930.45 GB NTFS 450 MB Recovery Partition
The chip set is Intel C600+ /C220+ series chipset sSATA AHC Controller

I need to install Windows 7 to give me a dual boot capability to run legacy software that won’t install in Windows 7 compatability mode. I need to shrink the C drive by about 40 GB for Windows 7. I did this procedure successfully on a laptop with no problems.

My concern is whether shrinking the Raid 1 array on this new machine will cause a problem, especially booting. If I select the shrink disk option, it shows that I have a total size of 852.78 GB before shrinking, and the size of available shrink space is 451131MB.
The disk management sees the Raid 1 array as a simple C: drive with three partitions, so there appears to be no reason why the shrinking shouldn’t work.

I though of using Hyper V to allow a Windows 7 installation, but Hyper V won’t directly support the USB port, and I need to be able to attach a Sentinel Hasp for authorization. So dual boot is the only option.

@rayjcar :
You cannot shrink the existing RAID array without deleting and recreating it, but it should be possible to shrink the currently used Win10 partition and to install Win7 onto the freshly created partition within the untouched RAID array.
Maybe you will have to repair the Windows Bootloader thereafter by using a tool like EasyBCD.
Anyway I recommend to do a backup of your most important data or the complete drive C: before you start with your work.

Good luck!

I was successful in shrinking the C: partition. As per your advice, I made an entire system image as well as a system restore disc.
The shrinking takes only a few seconds, and then I named and formatted the new partition. The machine boots with no problem. All is well in that regard, thank you.

The issue I have now is that I can’t get Windows 7 SP1 to complete the installation . I realize this is “off topic” I’ve tried several approaches:
1) ran the installation DVD from file explorer in Windows 10, in Windows 7 compatibility mode. Activated option to download updates during the installation. Failed to download updates, and installation failed.
2) Ran the installation within Windows 10 with updating turned off. Started custom installation to the new D: partition. Failed when it said that it could not install driver.
3) Turned off secure boot and activated legacy boot option from CD ROM. Booted successfully, but then hung on the Windows Starting screen.

I tried running the compatibility test, and the result is a bunch of “don’t know” answers. It doesn’t know the Xeon processor, etc. etc.

I’m wondering if its haviing a problem with the wireless card I added, and perhaps an ethernet connection will work. Then again, it may not like the on-board ethernet adapter either.

@rayjcar :
Your question has been answered and you obviously have succeeded getting enough space within the RAID array for a Win7 installation.
Why don’t you install Win7 the normal way by booting off a Win7 DVD/USB Flash Drive? Maybe you have to load the required Intel RAID driver, if the target Disk Drive running in RAID mode should not be detected by the OS setup.

The Windows 7 installation has no problem letting me point it to the D drive, and it was definitely starting to install to that drive until it failed. Upon rebooting windows 10, it came up with the typical dual boot startup screen as if I had Windows 7 already installed. The highlighted choice was Windows Setup (not Windows 7) , and the second choice was Windows 10. The default 3 second delay to choose.

I have gone into the Windows 10 advanced setup to change the default to Windows 10. I still get the choice screen, but at least now it defaults to loading Windows 10. This is strange because I reformatted the D drive to get rid of any evidence of the Windows 7 attempted installation, but there must be some registry entry that causes Windows Setup to still show up.


How did you format it? Both partitions (the Win10 one and the one, which is designed for Win7) must use the same partition table (GPT or MBR), because both are members of the same Disk Drive (= RAID array).
The last option to prevent any booting into the Win10 partition is to delete the related boot partition while booting the DVD/USB Flash Drive with the Win7 image. You have to repair the Windows Bootmanager anyway once the Win7 installation has been completed.

I solved the problem by going into msconfig BOOT and deleting Windows Setup from the list, leaving only Windows 10. It now boots straight into Windows 10.

The raid array is all MBR, and botht the C and D partitions are NTFS.

When I did a dual boot installation on my laptop, Windows 7 treated the new partition as it’s own C drive, even though it’s labelled as the E drive in Windows 10. There was no need to repair the boot manager.

I’ll do a couple more experiments, but the Dell web site says that Windows 7 won’t work with 7th generation processors, so after all that effort, this may be the issue. My choice of processor in ordering the machine may have been the wrong one, because clearly Windows 7 was available with certain configurations.