Slow RAID1, proprietary BIOS

Hello, newbie here… I am looking for help with some terrible read performance that I’m getting from iRST in RAID1. The PC is a Lenovo M92p which is Q77 based, running Win 8. I replaced the factory drive with a pair of mechanical drives (WD Black 2.5", 4K sector). They measure 97 MB/s singly (sequential) via Crystal, but only 68 MB/s when put into an iRST mirror. 512K read test is even worse, and random access time jumps from 8ms to 16ms using Sandra. It does surpass the single drive in one test (4K reads with queue depth = 32), so I assume there is some spreading of reads happening. The OROM is showing v11.0.0.1124 and it is a UEFI bios “Lenovo BIOS Setup Utility” with a version dated 06/07/2013. The numbers above were from testing after updating the Windows driver to v12.5.1066. Should I expect better performance out of iRST? And if so, is there any way to achieve it using a branded BIOS stuck at that version?

Or do your experiences match those in this Intel forum thread from last year, even with the current drivers?

@ tonyp:
Welcome at Win-RAID Forum!

Since I don’t have much experience with RAID1 systems, I am probably not able to help you. Hopefully someone else will do it.
If you want the best performance, you have to create a RAID0 array.

Regards
Fernando



Hi
When you say "using a branded BIOS stuck at that version" does it mean Lenovo have some sort of protection against flashing a modded BIOS?
If not, this BIOS is easily modded, if you want to try newer RAID OROM.

EDIT: Also there was a new BIOS released yesterday for the M92p.

Hi - thanks for the suggestions. It definitely needs to be RAID1 in my case. This is a business PC which I can’t quickly get to for repairs. My understanding is that RAID1 can improve read performance, but only if it is implemented well. I could live with single drive performance but this is too much of a slowdown.

I just applied the new BIOS but the OROM hasn’t changed. I did notice that the update contains references to AMI, so at least that points me to the right guide on this site.

Hi tonyp, RAID1 with performs worse than a single drive on all of Intel’s Q67/H67/P67/Z68/Z77/Z75/H77/Q77 chipsets.

I have personally tested 36 drivers from the 11.x RST drivers and 11.x/12.x RSTe drivers with 13 OROM’s and the result is always the same.

The issue has been presented to Intel here, on their own forums back in October 2012 but there has been no reply from any Intel employee on the matter.

However - If you force the RSTe v3.x driver to install via device manager the RAID1 performance improves dramatically on reads, to almost RAID0 levels.

Unfortunately this was not a solution for me as the RAID1 array requires a rebuild every time the machine is powered cycled (and also there is no trim support for my SSD’s in RAID0).

If you need RAID1 to perform better you will either need a dedicated hardware RAID card or a motherboard with the X79 chipset.

Pretty sure I tried RAID1 some time ago on P67 or Z77 and got double read speeds.

@ chinobino:

Welcome at Win-RAID Forum and thanks for your contribution!

Regards
Fernando

Thanks - this is the info I was looking for (and had feared). I did submit a support case to Intel but I only received a boilerplate response.

FWIW here are results of AS-SSD running W8.1, RST11.2, 2x Vertex4 in RAID1.

Seems good to me. This was made with what I usually leave for OP so now to delete RAID1, recreate RAID0, trim and delete again since RAID1 trim does not work here. BTW the optimize function in W8 may report trimming successful when it is not as in the case with using RAID1 as above.

tonyp you mention 4k sectors, are you using 512e and is your partition 4k aligned?

CPL0 - good idea about the 4k alignment. I cloned the OS so it may well need this.

Another thought: were your P67/Z77 experiences also using SSDs? It seems like this problem might be specific to mechanical drives. If RST is doing a simple interleave, the seek time could kill any advantage to using two spindles.

Even that Intel forum poster was using SSDs on the X79, which could explain the difference rather than the X79 chipset itself.



I believe it is using 512e as the drive model (WD5000BPKT) lists Advanced Format in its specifications, but fsutil reports “Bytes Per Physical Sector” as 512. Also, I just ran the Western Digital alignment tool and it said it’s already aligned.

Thankyou for the warm welcome Fernando.

Very interesting results from CPL0 using RAID1 with SSD’s.

I must admit that I did not test my SSD’s in RAID1 (as my OS is currently installed on them), I only tested RAID1 on my 2 x WD 3TB Black Drives [WD1003FAEX].

I put the same mechanical drives into a Windows 8 mirrored array (dynamic volume) and only very occasionally saw anything even close to double the sequential read speed of a single drive, mostly the transfer speed was the same as a single drive.

I also tried using the WD drives in RAID1 with one of my Intel X25-M SSD’s as a cache (with Intel’s Smart Response Technology) but the read and write speeds were limited to that of a single 80GB X25-M (~255 MB/sec read & 80 MB/sec write) using “Enhanced” or “Maximised”.

The last option was to try using Windows 8 storage spaces - it was a bit better on the reads (approx 200 MB/s read and ~150 MB/s writes) but not as good as I wanted.

As a result I dumped the idea of using RAID1/mirroring and just made a striped volume in Windows 8 disk management, which allows me to run the array on either Intel or Asmedia SATA III ports and get high transfer speeds.

The performance will be much better, if you are using the Intel instead of the ASMedia SATA3 ports.

You are correct, it does limit the burst speed of the cache by almost 100MB/s;

Intel Ports (Striped Volume)


Intel Port Disk0 Read


Intel Port Disk1 Read


ASMedia Ports (Striped Volume)


ASMedia Port Disk0 Read


ASMedia Port Disk1 Read