SM951 With EVGA Z97 Classified

(Mods If this is the wrong board please move.)

So I need some help. I’ve got a EVGA Z97 Classified board and one the AHCI OEM Samsung SSD’s: the SM951. I have the SM951 plugged into a PCI to M.2 Sata adapter (Lycom 120 DT-120) and that adapater plugged into a PCIE 3.0 port. (The firmware sees the card and it’s using x4 PCI lanes.) I can’t get the UEFI firmware to recognize the SM951 as a bootable device. The stock firmware doesn’t support that SSD. It needs a special Option Rom/DXE. (I’m not a 100% sure I understand the difference between OptionROM and DXE). It doesn’t look like EVGA has any plans to add support for it on their end. So I’m trying to mod the bios myself and having no luck so far.

As far as I can tell the AsRock Z97 Extreme 6 has the DXE module I need. Opening the the rom file for the AsRock I can see a module named “SAMSUNG_M2_DXE” which I assume is meant for the SM951 and XP941 drives.

I’ve tried following the posted guides for using the MMTool and inserting/extracting Option Roms but it’s not working for me.

I have a usb stick with a live booting version of Arch Linux. Using that I can get to an EFI shell. Using that EFI shell I can tell you the SM951’s ID’S:

Vendor 144d Device: a801.

I’m using the 4.5 version MMTool. So when extracting the module do I extract it “As Is” or “uncompressed”? Same question for when it’s inserted? I tried adding it as an OptionRom using the ID’s listed above no joy. I’ve also tried deleting a module (NVME module since I don’t have one of those drives.) and then just inserting the DXE module in it’s place. No Joy there either though at least I could see the DXE module in the list of drivers in the EFI shell.

Link to EVGA firmware:

AsRock’s Firmware:…e6(2.10)

@ Tempest:
Welcome at Win-RAID Forum!

What you are trying to do is very difficult, if you will not get any support from the manufacturer of your mainboard. Since you are obviously the first user, who is trying to get a Samsung SM951 M.2 SSD booting on an EVGA mainboard, nobody has any experience with this kind of BIOS modification. Nevertheless we will try to give you as much support as we can.
I personally own a Samsung XP941 M.2 SSD, which is booting fine with my ASRock Z97 Extreme6 mainboard.

It definitively fully supports my Samsung XP941. It may support the Samsung SM951 as well, but I am not sure about that.

If you want to see the original hex code and to read the text fragments, you have to extract the module as "Uncompressed".
This is how the first bytes of the 7 KB sized "Samsung_M2_DXE" module look, which is within the latest BIOS 2.30 for the ASRock Z97 Extreme6 mainboard:

Samsung_M2_DXE hex code.png

Usually the modules are compressed within the BIOS. So if you want to insert an uncompressed module, you may have to choose the "Insert Compressed" option.

AFAIK there is no Option ROM available for such devices.

The latest BIOS for this mainboard is v2.30.

Good luck!
Dieter (alias Fernando)