[SOLVED]Acer 4755g GT540M got bricked

This guide [GUIDE] Flash BIOS with CH341A programmer . I’m sorry I just misread it it thought it was written by you instead you were just acknowledged by the author. Anyways this is a good tutorial.

By using ver 1.29, I am able to delete the contents of the chips and successful on blank veryfication. I only failed when I’m writing on it.

And there is a strange thing that is happening, I tried to program it using JE40213.ROM then I read the contents of the chip let call it Dump1.ROM. When i compare JE40213.ROM and Dump1.ROM they are not the same (totally expected this!). Now this is the strange part, when I read the contents of the chip again, let’s name it Dump2.ROM.
Dump1.ROM and Dump2.ROM is not the same!!..I tried it several times, and not even once they are the same. It seems like everytime I read it it gives me different values…lol

I thought maybe my programmer or chip is faulty, so I tried to erase the contents of the chip. Then I read the it multiple times. But now all dumps are always the same!

Thank you for the link for the flash rom GUI, I’ll try it later. :slight_smile:

@diode121 - Try this ASprogrammer (2.0.0a14) attached at last post here - https://www.badcaps.net/forum/showthread.php?t=82992
Also, try 1.38 and ASProgrammer ( from this download as well - https://www.mdclab.it/lab-usb-programmer-ch341a.html

You can’t confirm it’s blank without being able to dump it, you can only confirm that 1.29 thinks it’s blank

That is normal/expected, this means it’s not reading correctly (ie not compatible), and so you still cannot verify anything was written properly either.

@Lost_N_BIOS - Thank you very much for all your help and suggestion. I was able to repair my laptop.

The solution is on the first page of this thread.

@diode121 - You’re welcome, great to hear you fixed the system! Yes, sometimes chip removal is the only way, but it’s very rare.
Anyway, glad to hear your system is now back up and running, great work!

@Lost_N_BIOS hi i have the same laptop with him and with the same issue (stuck at acer logo). ihave already read the guides u made here and for some reason i clicked erase without dumping data files from the bios chip. how can i restore my macid, s/n, etc.,? thanks for the guides bro i also fixed mine but macid, etc is missing. i still have the stickers in my laptop soo i am hoping u could help me. thanks!

Hi @Lost_N_BIOS , can you help me with my problem in ME Region? May laptop Shutoff every 30 minutes and i knew that you is 1 of the heroes here :frowning: please helpe :frowning:

can you share the .bin/.rom file you successfully programmed on your BIOS CHIP. thank you!