[SOLVED]Acer 4755g GT540M got bricked

Hi guys can you please help me with my laptop.
I have an Acer 4755g which got stuck on Acer logo after i rolled back a previous update of windows.
I already tried everything. Removed the ram, hdd and others but still stuck.
Then I decided to buy the black CH341 programmer and reflash the bios.
I was successfull in detecting, reading and writing on the bios chip however when I plugged my laptop, it shows no power, no led indicator. I already checked if my charger has an output voltage and does have.

I tried to reflash the original content of the bios ic but it still shows no power.

I think I may have flashed the incorrect bios. i got it from here: https://www.acer.com/ac/en/US/content/su…roduct/3803?b=1

Since the bios only contains .rom file, i renamed it to .bin. Did i make i mistake by doing this?

Bios chip is winbond 25Q32BV.

Please help me, because of what is happening in my country and this pandemic, I have lost my job, I can’t afford to buy a new laptop now. Hope you help me fix it.

Thank you

Sorry for also posting this here

Bought a Bios Programmer (CH 134a - The black one).
Tried to program the BIOS IC by clipping the IC using the SOIC clip while the IC is still on the board.
By doing the said process, I got into errors specially the “Chip main memory with contents in disagreement”.

Tried all version of the programmer but still no luck.
So I decided to buy spare BIOS IC (winbond 25q32bvsig) which I experimented on. I directly soldered the IC on the breakout board (small green board) that comes with the CH134a programmer.
I managed to program it with no errors easily. To verify if it is really successful, I compared the contents of the chip with the bios of the program and it is 100 percent the same.

I desoldered the IC from the motherboard and soldered my newly programmed IC. My laptop now works perfectly. I’m typing this now on my laptop. :slight_smile:

For sanity check, I decide to program the old BIOS IC, by directly soldering the breakout board (just like what I did on the new IC), lo and behold it was programmed perfectly, no errors whatsover.

I think using the SOIC clip or programming the chip while on the board causes some issue on the writing process on the chip.

I tried to program the IC using the CH134a version 1.18, 1.29, 1.30, 1.34 and ASporgammer 1.41, all of them working perfectly on a directly soldered chip

And lastly and more importantly when trying to run the software, run it as “Administrator”.

Hope you will also be able to fix your device.

@diode121 - Please upload for me the BIOS chip original 25Q32BV contents you dumped. And then link me to the correct BIOS download page for your system.

No, renaming .bin to .rom is same/same, that’s not the problem. Usually BIOS you download is not entire BIOS, it’s only partial BIOS region, so this is the issue.
Also, sometimes, some system have two BIOS chips, with BIOS split between them, both must be dumped, appended together, then fixed, split again and then programmed back to each chip.
This may be one of those boards, please show me image of the motherboard, and see if you can find other chip with 64 in the ID

What software version did you use to dump the 25Q32BV chip? And, once you find the 64 chip, do not dump it yet, wait and tell me the ID so I can tell you what is best software version to dump and write to it with, not all software versions are compatible with all chips.

No need to be sorry, we’re here to help!

Thank you for the quick response here are the BIOS: https://www.mediafire.com/#c11xgr15dbimc
The original file is named origfromchip.bin. I extracted it using the CH314A Programmer version 1.18
As for the BIOS that I’m trying to program I got it from here https://www.acer.com/ac/en/US/content/su…roduct/3803?b=1

@Lost_N_BIOS I read one of your comments from other threads that for programming 25Q32BV I should use the CH314A Programmer version 1.34 version.
I am trying it now and I’m getting the error chip not found.

I also checked the output voltage of my progammer and it say 3.29 volts which is exactly on the operating voltage of the 25Q32BV.

@diode121 - Please use edit button instead of making many posts in a row. 1.18 may be OK for 25Q32BV, I am not sure. If you seen me comment to use 1.34 then there must have been reason, unless I said "Try 1.34"
Chip not found has nothing to do with chip ID or software version, that just means bad connection, reclip and try again, you will get that message any time it’s not connected perfectly.

Your mediafire link leads to nothing, but upload page. I checked stock BIOS, it is complete BIOS in the DOS Folder (The JE40124.ROM)
So, that can be directly programmed, with proper compatible software/ID. You will loose your serial, UUID, and possibly MAC ID if stored in BIOS if you write in the stock BIOS though, so best to dump first and let me check it/copy over these details etc.

You may have to program in latest BIOS, not older, especially if the windows update BIOS went in OK, because EC FW is updated with BIOS update usually and EC Changes may not work with all BIOS only the one they are meant to go with.

Sorry for the multiple post.
Here is the original bios from the chip. http://www.mediafire.com/file/83r37he8gi…omchip.bin/file

I also tried experminenting with ASprogammer. It was successfull in flashing it but my computer is still dead.

Im sorry but I cant quite understand your last sentence. Can you please guide me on how to do this?

It’s OK, just mentioned so you didn’t keep at it

My last sentence, I meant to program in the latest BIOS version (rom), not the older BIOS version you wanted to flash back to.
I said that because the BIOS update package, also updates another chip (EC/KBC FW), and those changes made with latest BIOS update to this chip may not be compatible with older BIOS, so to fix your system I suggest you write in latest BIOS Only, to rule this out as an issue.

Successful programming does not always mean data went in correctly, sometimes if software or ID selected is not compatible with the chip then verify success will be false verify.
You can confirm write is OK with whatever software/version you use manually, by after write/verify, close the program, then open again and read/verify, save and then compare that file in hex with the file you wrote, if they are 100% match then write went into the chip correctly.

* Edit - I checked your file, that is corrupted BIOS, which generally does not happen with bad BIOS update, not in this way, unless power was lost mid-update or you shut it off mid-update etc, but I guess anything may be possible.
Looks like bad dump, but since you’ve already written to the chip, we can’t dump with other versions to confirm

Ah, yes, I always get an error when I’m I try to veryfy it.
Edit: I mean when I try to verify after programming I get the error “Chip with the contents are in disagreement”.

Since the bios that i extracted is corrupted and details such as macid and uuid cannot be retrieved, will I still be able to make my laptop work?..

Verify read contents not matching what is on chip means your not using compatible software or ID. Even if chip has corrupted contents, dump of chip should always match what is on chip
So read >> verify = fail >> Means incompatible software or ID used, try another version of software or different software. If you can’t read and verify chip contents, then you can’t write to chip properly with that software either (and read/verify OK does not always mean write will be OK either, some can read OK but fail at write)
Try 1.29, 1.30, 1.34 and see if read/verify are OK with any, if yes, save the files from any that verify OK and compare with hex editor. Then also make dump with ASProgrammer 1.41 and compare to those
All versions mentioned included in this package in case you do not have - http://s000.tinyupload.com/index.php?fil…213094641136166

Yes, serial/UUID usually only matters for RMA (sometimes) MAC ID is for Ethernet LAN, if this system does not have Ethernet, then it doesn’t matter, but even if it does have Ethernet, I assume it also has WIFI too so loss of Ethernet MAC ID wouldn’t matter there either.
Data may still be in dump contents, send me your serial from bottom of case and I’ll see if I can find. Or you may find it on memory slot on a sticker, on the slot itself not on the memory, or under memory on sticker, or on other sticker on the board if not on back of case
We can put back, if we can find all the info. And yes, system will run fine without any of that, once you find what software will program this chip correctly

What do you mean by incompatible ID?..How can I know the right ID?

As for the serial. Do you mean serial number?
Here are the serial i found from the stickers.
Aspire 4755G-2674G75Mnrs

Some BIOS chip ID’s do not work in certain software versions, so you may need to use other than exact sometimes. For your current chip, please wait, I just seen another user with same chip and successful write with programmer, I am asking him what version he used to write.
Please zip images of all sticker for me, and yes, like that is what I meant, be sure to check where I mentioned on the board too.

Thank you for being patient with me…:slight_smile:
Here are all the stickers that I can find in my computer http://www.mediafire.com/file/thgudyx8q3…ickers.zip/file

Hope the user will reply soon. I’ll just wait for your next message…

@diode121 - You’re welcome! Thanks for the images!
Did you do as I mentioned yet >> Try 1.29, 1.30, 1.34 and see if read/verify are OK with any, if yes, save the files from any that verify OK and compare with hex editor.
Then also make dump with ASProgrammer 1.41 and compare to those (or send to me in max compressed zip and I can check if you want)

Or, instead of all that, and waiting on other user, do you want me to just make you a BIOS that should be bootable once properly programmed, then you can try write with various version until you find one that works?
It would be best to try and figure out how I mentioned above first, but it’s up to you how you want to move forward (I know it’s a lot of testing, tinkering, headaches either way, since we don’t know for sure what writes properly yet)
If you want to try and move forward, please tell me what BIOS version was in there that you tried to downgrade FROM, that caused this issue. And then also tell me what BIOS version you tried to downgrade TO, I will make you BIOS one of each, in case EC/KBC FW needs to be matched to a certain one.

I have not tried the other versions yet.
I’ll try it later when i have borrowed a laptop from my neighbor.

Regarding the bios version, this all happened because of a windows update that i tried to rollback. I was trying to rollback from windows build 2004.

I do not know what version was in the bios before it stop working. I have not tinkered or changed anything from the bios until my laptop stopped working.

@diode121 - You can use desktop, just put system next to the desktop tower

Windows version has nothing to do with BIOS version, nor does rolling back from one windows version to another. Your hard drive or windows install could have got messed up after/during that, but you should have been able to reboot and go into BIOS anytime.

I have no other desktop nor laptop here. This laptop is all that I have.

I dont know what happened but the last thing that i’ve done is trying to rollback windows update.

I also failed to mentioned that this is dual booted with centos.

Is it also possible that my bios chip is dead?.
Should i try to replace it?..

Ohh, sorry, I thought you were replying now from your desktop or something.

OS does not matter to being able to boot to BIOS, if you messed up the OS, either, or the HDD/SSD etc, it would have still booted to BIOS.
You should have removed the HDD/SSD and then got into BIOS, instead of erasing and trying to write the BIOS without even confirming you can’t enter it I know, too late now

BIOS chip is fine, no need to replace

Im using my phone to reply now.

This problem started stuck in Acer logo screen and loading bar stuck about 70 percent. I can no longer boot.
I can not also enter bios.

I tried to troubleshoot by removing parts such as hdd, ram, cmos battery. But still persists on stuck on acer logo.

Then when i tried to flash the bios to a new bios rom, my computer no longer turns on.
No output on screen, no acer stuck logo. Totally dead, it has also no status light.

I checked my charger and it gives the right voltage so i ruled out the possibility of broken charger


Here are the result of experimenting from different versions:

Version 1.29
- when I press detect it does not detect the chip. I manually input my chip number
- was able to read and verify successfully after erasing contents of chip
- was able to write successfully on chip but when verified it shows error " Verify failed chip main memory with contents in disagreement". Tried reclipping several times but still persists
- here is a link to the files http://www.mediafire.com/file/p8b2k6pa7s…er1.29.zip/file. The link contains the JE40213.ROM the bios that I program on the chip and the other 3 files are the ones I read from the chip. After every reading I removed the programmer and reclip.

Version 1.30
- cannot also detect my chip. I manually chose my chip number
- It gives error “Access violation 0097EA42. Read of address 0097EA42” when i press detect.
- when i try to read is says could not find chip

Version 1.34
- same sa 1.30

AsProgrammer 1.4.1
- it can read the chip
- when i try to program. It hangs on “Possible protection is enabled. Programming memory (verfying)”
- when i try to unprotect before writing, it hangs with a message SREG (0xFF,0xFF)

@diode121 - So, before you did anything to the BIOS chip, you removed hard drive and tried to boot to BIOS? If yes, then BIOS was probably currupted at that point,but shouldn’t have been caused by a windows OS version roll back.
I guess anything is possible now with Win10 these days, since they are pushing out BIOS updates to users now without notification and then on reboot they are bricking left and right.
I’ve had to help about 10+ Asus users with various models recover BIOS from this in the past year, some other brands too, but Asus one sticks out because of how many users found us all fixing and complaining in this one big thread here a while back.

In your very first post, you said “I think I may have flashed the incorrect bios” And I asked you to confirm the proper model, and link me to the page, and you linked same page/model that you said was incorrect
Are you 100% sure now, your model is 4755G and this is your BIOS download page https://www.acer.com/ac/en/US/content/su…roduct/3803?b=1
Just to confirm again before we move forward

When no chip is detected, do not enter anything, reclip, it’s not detected because it’s not connected, detection has nothing to do with software version or ID etc.
Anything you do after non-detection, without re-clipping the chip, is not valid (nothing is read or written, other than possibly invalid data either way)
Once chip is detected, and you have not moved the cable or the clip even the tiniest bit, then you never need to re-clip it again unless it accidentally moves.

DO NOT remove and reclip for no reason, ie “After every reading”, the clip will wear out very quickly and it then wont be able to grab onto the BIOS legs anymore.

1.29, 1.30, and 1.34 can all detect your chip no problem, chip detection is not about software version, it’s about physical connection is proper or not

For ASProgrammer, use this method to write >> Open program, select IC, hit “unprotect” Icon (not the drop out menu, just the icon), then erase, then blank check, then open BIOS file and write then verify.
At least you hit unprotect, that is good What do you mean “Hangs” is program frozen then, and you have to force it close?

Please connect this way again, the click unlock dropout menu, click edit sREG and then read, and show me image of what you see.

Do you have main battery installed? Do you have main PSU cable installed? Sometimes this matters, some systems need them removed, some need them connected.
Try again with both one at a time, then both together, and see if it all looks same with ASProgrammer when you hit unprotect (not the stuff I told you above, just normal hit unprotect icon, does it still then give you same SREG (0xFF,0xFF))

For all CH341A softwares when you try those again, go into the “Operate” menu at top, and make sure only “Main Memory” is selected

@Lost_N_BIOS - Yes, before I messed with BIOS, I troubleshooted it first by removing components like hdd and ram but it still stuck with Acer logo. I can’t even enter bios menu.

Yes I’m sure that this will be the link for my BIOS, because it is the only link for 4755g model. https://www.acer.com/ac/en/US/content/su…roduct/3803?b=1. I think the latest model for the BIOS in that link is the 2.13 bios version since it supports graphics card.

While experimenting with all the versions and studying the guide thread that you made. I thing version 1.29 is the version suited for my chip. This version detects my chip correctly (it shows the name, manufacturer,id). I was also able to erase and check blank with no error. I can also write on the chip but it fails during verification with error saying “Chip main memory with contents in disagreement”.

I am also having success on the AsProgrammer. I can write on the chip without error. However when I compare the ROM that I used for programming and the contents of the chip, they are not the same. I think the rom is not being written properly on the BIOS chip

On the operate menu, should I also unchecked “SST/ESMT chip uses AAI program mode” and “Use block/sector erase mode”?

And also I’m flashing the bios chip with CMOS battery, main battery and laptop charger removed

@diode121 - OK, thanks, I just wanted to confirm again about the BIOS, since you mentioned you flashed wrong one or programmed in wrong one etc.
The .ROM BIOS inside DOS folder should be bootable, once programmed in properly. Sorry, not sure what “Thread that you made” you’re talking about? I never made any guide or threads about this.
As mentioned, chip detection does not have anything to do with software version, except in cases where your BIOS ID is not in the list that program has, but it would always "Detect Chip"
So, you confirm 1.29 can read (maybe properly, maybe not, you’d have to be able to write/dump/compare to confirm), and can erase OK (again, maybe, you can’t confirm without being able to write first to know what is there, to then dump and check)

Being able to “Write and verify” without error, does not always mean there is not any errors, this is why I told you to manually close program, open again, then read, verify, save and then compare in hex.
So, as you mentioned, your then read/dump/compare later does not match, this means either bad read or write, still unsure which or both.

Yes, uncheck those and make sure “Main Memory” is the one selected.

As mentioned, test with main battery in and PSU cable connected as well, sometimes this is required. CMOS always leave in

It may be best for you to now try flashrom methods instead, since you’re having so many hassles here! Here is GUI version you can try in windows first - [Guide] Using CH341A-based programmer to flash SPI EEPROM (34)
And here is normal flashrom method, you’ll have to use Linux or Ubunutu live CD/USB - [GUIDE] The Beginners Guide to Using a CH341A SPI Programmer/Flasher (With Pictures!)