[Solved]ASUS BM1AD BIOS Unlock

PC : https://www.asus.com/Commercial-Desktop/BM1AD/overview/

I have 2x4GB G-Skill RipJawsX CL9 installed on my MOBO. When I enable X.M.P. profile on EZ mode after saving&restarting it turns back to normal CL11 timings.
There is no AI Tweaker tab in BIOS so I can’t manually set RAM timings.

I have tried modifying BIOS using AMIBCP4.53 for AI Tweaker and some sub menus (set access level default to user) then flashed EEPROM with AFUWINx64.EXE PATH_TO_ROM /GAN

When I check for BIOS version, I see the number of the modified BIOS so write is ok. But still no AI Tweaker tab.

Similar case → https://www.techinferno.com/index.php?/f…s-successfully/
Tried those steps but I cannot find boolean array which contains visibility flags.

@Suicidal :
Welcome at Win-RAID Forum!

I am sorry, but I cannot help you, because I am not an expert regarding this kind of BIOS modding.
Nevertheless I hope, that you will get support by someone else.

Dieter (alias Fernando)


That’s because (using UEFITool) your boolean array exists in: BIOS region > 3rd 8C8CE578-8A3D-4F1C-9935-896185C32DD3 > 899407D7-99FE-43D8-9A21-79EC328CAC21 > Compressed section > PE32 image section of your Setup module - offset 0x1C154 as “0100010101010101”. I looked into AMIBCP and it’s the 2nd expandable menu, so that boolean array would indicate the tab for the opcode not to show. Simply change that 00 to 01 and replace as is and save the ROM in UEFITool and then make sure the privilege levels for access in AMIBCP are still set as they were (USER) before flashing.


Thanks a lot!. XMP works now.


@Dreamonic :

Welcome at Win-RAID Forum and thanks for your contribution, which has been very helpful.

Dieter (alias Fernando)

Guys i have also asus desktop Pc , cm 6870 , i couldnt find the setup string can you pls help ? I want to unlock ai Tweaker . https://www.asus.com/us/support/Download…CbsOpUyO2nz/41/ here is my bios .

@ultragamertr44 :
Welcome at Win-RAID Forum!

Since I am not an expert regarding unlocking specific BIOS features, I cannot help you.
Maybe someone else will give you some tips.

Dieter (alias Fernando)

Hi, I also have an ASUS BM1AD running, and I tried the modded BIOS found in another forum thread you started here. Although the Ai Tweaker appeared after successfully flashing the BIOS, it actually doesn’t work. I could adjust parameters in BIOS, but after I enter Windows, using something like CPU-Z to check how memory actually works, it didn’t change anything no matter what I set in the BIOS. The biggest problem is that although the BIOS appears to report that it is using XMP, the frequency still stays with SPD (XMP 1600, SPD 1333) disregarding whatever DRAM frequency I choose in the Ai Tweaker.

Could you share your finalized (really) working BIOS image here or somewhere?

Thank you in advance!

Sorry, I don’t have that system anymore. If you repeat the steps explained by @Dreamonic and still doesn’t work it could be a compatibility issue. If you have two RAM modules make sure they are identical. You can also try enabling X.M.P. with only one module installed. Good luck!