[SOLVED] Asus laptop GL502VM trouble with recognize Plextor 256GB M8PeGN M.2 PCIe in BIOS/UEFi

Hi, i buy this disk last week and try to install on it Windows 10, but when i put it in laptop and start laptop, going to bios in secion boot I see only my old hdd with system, I serching in evry forum I be and looking on similar problems to trying solve this but in my
situation not work any solve. This is list of what I trying to do:

1. When I disable fast boot and security boot and i next step enable CSM ( in some cases this should help) and reboot my laptop stuck on screen with logo and i cant do anything, cant open bios laptop do not respond. I must remove ssd from laptop and reload setings.
2. In remove old hdd and start boot bios only with ssd m.2 and dosent mater with or without enable/disable function (security, fast boot) in function boot is empty bios dosent see anything.
3. I put windows OS (usb stick) and try instal system on ssd m.2 and in windows instaler see my disk ,so ok I choise it so windows warning me the ssd is in GPT format (I solove this problem) and when again instal windows in gpt is succesfull instal I reboot and remove usb to try start boot from SSD. laptop start automaticaly Bios and in boot like alweys is nothing non disk.

when i startup normaly sys from old hhd and go to manager windows normaly see Plextor 256GB M8PeGN M.2, in computer section i see normaly disk can open and menage files copy delete etc. This is strange my laptop have only 1 year is brand new model so it is possible bios dosent have driver to this disk? I dont understand why this even happend? asus support send my a list with compatibility disk m.2 and only say they dont test more disk so they dont know is compatibly or not.

Ps. aplication /diskpart see SSD when i try change GPT to MBR they show information about ,it cant be do because this station is a dvd/or cd or removable station ?? this is strange.

Question is how to resolve this problem, what I must do to succesfuly BOOT Windows from m.2 ssd?





@adax666 :
Welcome to the Win-RAID Forum!

It is rather normal for Intel 100-Series chipset systems, that the NVMe SSD resp. its model name is not shown by the BIOS as bootable device. Nevertheless the BIOS of your system obviously has detected and is able to manage your NVMe SSD. Otherwise the Win10 Setup wouldn’t have seen the related NVMe SSD.
Conclusion: You will be able to get Win10 properly installed onto your NVMe SSD and to boot off it. The BIOS will show this bootable NVMe SSD after the successful OS installation as “Windows Boot Manager”.

This is what I recommend to do:

  1. Disable “Fast Boot”, “Secure Boot” and “CSM” within the BIOS and remove all disk drives except the NVMe SSD.
  2. If not already done, let the tool Rufus create a bootable FAT32-formatted USB Flash Drive containing the Image of your demanded Windows 10 Edition, which is prepared for an UEFI mode installation (using the GUIMode Partition Table).
  3. Boot off the USB Flash Drive in UEFI mode.
  4. When the Setup shows the NVMe SSD and its partitions and asks you where you want to get the OS installed, do the following:
    • Delete all visible partitions of the SSD.
    • Click onto “New” and let the Setup create a new partition with a size of ca. 230000 MB (if you don’t want to leave free space for overprovisioning, you can choose the complete available space for the new partition).
    • After having done that, the OS Setup will create automaticly 2 additional very small sized partitions.
    • Now choose the biggest of the shown SSD partitions as target drive for the OS installation.
    • The rest will be done by its own.
  5. Once the OS is up and running fine, you can shutdown your laptop, open the back cover and re-insert the previously removed Disk Drive(s).
  6. After having successfully booted into your freshly installed Win10, which is now on your NVMe SSD, I recommend to run the Disk Management and to delete or format the previously used small sized boot partitions of your HDD (to prevent, that the system may boot by mistake off the old HDD in the future). Optional you can additionally delete or format the previously used system drive, which is still on your HDD. Now you have space enough on your HDD for the creation of a new partition, which is designed for the storage of data.

God luck!
Dieter (alias Fernando)

Thank You for answering on my problem. ok I basicaly do everything what You say earlier, but now I do it again so:

1. put cms, fast boot and seciurity on disable
2. create boot drive on USB disk in Rufus ( I read before about GPT and rufus) but i give try, again set GPT for UEFI format in FAT32 and mount iso Windows10
3. restart laptop and start Boot from USB, next in instalator delete every partition I create earlier, only one exsist my SSD i do new and its strange You say it create 2 partition,
but in my cause it create 4 small partition, ok i chose biggest one like always and start install, when its done computer automaticaly restart ( i put off USB pendrive) and computer automaticaly open BIOS i look in to BOOT
section and is empty nothing. I think mayby is somthing withe EFI wrong ? where is problem ?






zdjecie rufus.jpg

I wrote about 2 additional partitions (that is what I usually got) and you got 3 additional partitions. The first one is a Recovery partition and does not belong to your freshly installed OS.

That is really strange.
What means “when its done”? Has the OS installation been really completed inclusive all your personal settings and choices (it should have rebooted several times)?
If you should have meant, that your laptop rebooted the first time after having extracted and copied all OS files onto your future system drive, I recommend to restart the OS installation from scratch and to let the USB pendrive inserted. Once the OS installation really has been completed, you should look into the Disk Management of the fresh installed OS and check, whether your new drive C: is listed as “Healthy” and as “Boot Partition”.

I means to the first automatical restart after instaling components, like you say after extracted and copies all OS files to future system drive, and if i leave pendrive USB its boot again to the start proces of instalation, so i removed booting pendrive and my laptop open BIOS because dosent detect any boot localization.

EDIT by Fernando: Quoted post shortened (to save space) and code corrected (for better readability)

Thanks for your report, which indicates, that you are not able to boot off the NVMe SSD.
Possible reasons:
a) The required NVMe support is missing within the BIOS of your laptop or
b) certain default BIOS settings prevent to use any other than the natively present HDD as bootable system drive.
Regarding the option a) you or me should have a look into the mainboard BIOS. If you cannot do it yourself or if you are unsure, please post the latest BIOS for your laptop as *.ZIP or *.RAR archive.
To exclude option b) you should check within the BIOS all BOOT or SECURITY related options. If you don’t find any relevant setting options, which may have prevented to boot off the NVMe SSD, I recommend to contact the ASUS Technical Support.

Good luck!

Hi, Thank You for answer, I serch in BOOT and SECURITY for somthing related but i think is everything normaly.

@adax666 :
Thanks for your report about the BIOS settings and for having given me access to your currently used BIOS file.
I have checked its content and found an NVMe EFI module, which normally should be loaded while booting off the NVMe SSD.

Since this obviously doesn’t work with your specific NVMe SSD and I cannot help you to solve your problem, I recommend to contact the ASUS technical support.
They should be able to answer the following questions:
1. Does the latest BIOS, which has been released by ASUS for your notebook, support the usage of your specific Plextor NVMe SSD?
2. If yes, which BIOS settings are necessary to be able to boot off an NVMe SSD? If not, is it possible to update the BIOS to get enhanced NVMe support (inc. Plextor M8PeGN)?

Good luck!

Ok thanks, I erlier (about week ago) sending question to ASUS support about compatiblity my plextor and they in answer send me list of disk (quite short list) about tested and working on GL502VM other (like Plextor) they write not tested and dont know it will be fully work,

Ok mayby I do somthing wrong erlier, when I first time trying to put on Notebok NVme and Install OS, I instal OS and created bootable USB disk from officialy site of microsoft (media creation tool) but in hdd i have recovery and orginaly personalized recover partition with ASUS soft, so when I first time instal on NVme (whitout Rufus tool) OS from USB i decidet to format and delete all partition from hdd so its posibly i delete some important partition or hiden partition with efi ? or somthing?
( I say about hide partition because i read about someone damaged efi partition and have problem) or Its normaly dosent support disk and thats It ? Like You write I post to ASUS Support mayby they say somthing more.

and in support site ASUS in section driver in other OS drivers is only 200 and 202 wersion of BIOS ver.300 BIOS is too from oficial site but in windows driver section is strange? for me why there, (mayby I doing wrong to download it and flash) mayby i must now downgrade to 202 or 200 ?

@adax666 :
1. You problem is not driver related, because the Win10 Setup was able to detect your NVMe SSD and to install the OS data onto it without any problem.
2. The usually hidden extra partitions on the HDD, which natively contained the OS, do not matter at all, because you had unplugged the HDD and were able to start the OS installation onto your new NVMe SSD.
3. Maybe the BIOS of your ASUS laptop model contains some restrictions regarding the replacement of the system drive. Only ASUS knows it.

Hello I SOLVED my problem :slight_smile:

today I remeber what I do when first time put SSD MVne, when first time I power on laptop and like usually open BIOS for serching new disk drive and I didint see it so, ok I serch for it in Windows and open katalog “My computer”, I think mayby there I see unformated partition but nothing here so ok,
next step i open somthing like “manager storage place” and in here not araged space will be so I create space and disk here and this I shuldind do.
I enroll this proces delete all storage palce and do Everything again ( I mean all instalation process posted by Fernando) and it work.

Thank You for Your help Fernando.

@adax666 :
Congratulations for having found the reason for your problem and for being able to solve it. Thanks for your final report.

You probably mean the Win10 in-box utility named Disk Management “Manage Storage Spaces” (“Control Panel” > “System and Security” > “Storage Spaces”).
By the way: Since your problem has been solved and the solution has been described, I have added the prefix “[SOLVED]” to the thread title.

Enjoy your laptop using an NVMe SSD as system drive!

I mean “manage storage locations” ( if not correct translation please correct me) I attach the screenshot of location this function ( my system is in Polish language) :slight_smile: