[SOLVED] BIOS Problems after having flashed modded ASUS M5A97 R2.0 BIOS

Hi guys, I’m kind of new here, I own an ASUS M5A97 R2.0 motherboard and following Fernando’s guide I used AFUWIN64 to flash a modified bios since I didn’t get a usb 2.0 to do it with the USB FLASHBACK method.
The flashing was done correctly, or so I guess, because now I can’t save any changes in the bios because the screen freezes and I have to reboot manually. I can’t load optimized or any other settings as I can’t save any values.
I have tried moving the jumper to reset the BIOS settings, but when I turned it on it gave no image, so I turned it off and pressed the MEMOK button inside the motherboard and it turned on and gave image, but still no settings can be saved.
What did I do wrong? I don’t want to ruin my board, I just updated the microcodes and lan option rom with UBU.
I hope you can help me, greetings!

Edit by Fernando: Thread moved into the correct Sub-Forum and thread title updated

Wot was the old bios on system before the flash? Do u have access to the bios itself or not? When does it freeze, before the post or after?
Does a normal bootable USB still boots on the system? F8 or F12 works at post?
Starting by digging a USB for BFB if u want to recover the motherboard… or a programmer.

EDIT: CMOS battery ok, SPI ok, 3,3v ok…mod wrong/damaged?

Hi, I have access to the bios, to all menus including advanced mode. I can boot in windows, but every time I turn off the pc and turn it on, it starts in bios and I have to configure again the boot device. I am re-updating version 2603 but modified, I already had the last version when I flashed modded.
Regarding the freezes, they happen only when I save settings from bios, it doesn’t matter if I put default optimized load, power save mode, or don’t touch anything and just save the changes, it freezes there… I’m confused, I read in some forums to reflash several times but I’m not sure.

The battery works because it worked until just before flashing the modified bios, the ubu tool I guess is safe, and I doubt of any broken module, the voltages look good, although let me tell you that with the original bios last version it also crashes the bios when entering the AI TWEKER menu only if the defaults were loaded when entering, because if the asus optimized values were active, then yes I could enter AI TWEAKER to change things, I guess it is a problem with the ram module of the motherboard that is defective.
Remember that with the modded flashing I did this got worse and now it freezes in the same way as in AI TWEAKER but when saving the configuration.

Let me get a usb 2.0 pendrive and then I will tell you what happened, thanks and sorry for the inconvenience, best regards.

Well if recovered with original bios files (USB BFB preference), still crashes, its an HW issue then, in the motherboard, good luck.

The USB flashback seems to be sticky,so I think you could try SPI programmer.

@Nekrodamus :
This is what I would do:
1. Clear CMOS.
2. If this hasn’t solved the problem, flash/recover the latest original BIOS (as MeatWar already has recommended).
3. If you ever want to flash a modded BIOS, use the USB Flashback option your mainbiard offers. It will work, if you do it correctly and use an appriate USB Flash Drive model.

Hello, thank you for your recommendation. And yes, I am seriously thinking of buying the CH341a.

Hi, thank you for your reply, I will purchase a 2.0 flash drive to do it the right way and not experiment as I have done with AFUWIN.

It made me remember that when I flashed the modded bios, then I did a Clear CMOS.When I turned on again the computer did not give image, so I assumed that the problem was memory, so I touched the MEMOK button on the motherboard and it booted with the default settings when you clear CMOS, and I can not save my settings such as choosing the boot disk because it always freezes when saving, so every time I turn on the pc starts directly to the bios.
I clarify that all this problem appeared after I did a CMOS clear.
In a few days I’ll tell you what happened when I get the right pendrive, I won’t keep doing stupid things because I’m sure I’ll mess something up - :confused:
Best regards guys.

Hi guys, I haven’t gotten the USB flash drive yet, but I was doing some research and found the NVRAM. This device is the one that is in charge of saving the bios settings right? What can happen if I flash the NVRAM section next to MAIN in AFUWIN, it will erase the settings and boot by default as if I move the jumper to reset, or there are chances of bricking and the system will not boot even resetting CMOS, or it is just the same as doing a clear CMOS and there is no risk? I don’t know what is the difference between these.
I was thinking that some configuration got bugged and a full reflash is necessary for me, but I don’t know if the flashback tool does that or if the programmer will help me with this.
I also have the doubt if I do a full flash and my bios update file is incomplete and no good later, then I should do a dump and compare its size? I hope the help of an expert on this subject, if necessary I can attach original and modded BIOS files like the one I have now, greetings!

Hi guys, I bring you a good news, I was able to unbug my bios!
After reading tons of forums about NVRAM and AGESA I decided to program the “nvram” sector with the AFUWIN program, using the /n command.
All done, and when I turned the pc off and tried to turn it on it didn’t respond, so I said to myself, well, I screwed up. But I tried moving the clearCMOS jumper for a few minutes and when I put it back to its place and pressed the power button voila, the startup of the pc appeared with the text that says press f1 to enter the bios, when I entered, luckily my hard disk appeared and when I put save the changes at last it didn’t freeze.
I hope it helps someone else, I think the /n command in afuwin is very important because it erases the configuration data that resist other methods. Greetings and thanks to all.