[SOLVED] Can\'t restore HP Folio 13 BIOS (Insyde) dump backup successfully

Hi there,

I’m facing a problem while trying to restore a BIOS (Insyde) dump/backup I did before flashing a modded BIOS to my HP Folio 13 1010-es laptop (trying to get rid of the wlan/bluetooth whitelist).

I used InsydeFlash v4.19 to flash the modded BIOS but first I modified the platform.ini file to do a backup of the stock BIOS, just in case (017F8_F0A_Pre_Flash_BackUp.bin).
The modded BIOS didn’t work. I ended up with a corrupted BIOS (capslock blinking twice every few seconds) and with the help of a CH341A programmer and AsProgrammer 1.4.1 I erased the BIOS and re-programmed it with the BIN file backup that was done during the previous flashing process.
Unfortunately after doing this the laptop didn’t start properly. The screen was coming up and I got a blinking cursor in the top left corner of the screen but that was it. I wasn’t able to access the BIOS or boot menu, and it was just stuck.
If I try to press ctrl+alt+del it looked like rebooting but the screen was turned off and again nothing happens even after waiting for a while.

In this situation what I did was to download the latest BIOS package from HP, extract it and with the help of the hewprsa.exe tool I extracted the BIN file (017F8_F0A_Extracted_From_sp59761.bin) from the FD file in the BIOS update package and again with the programmer I erased and re-programmed the BIOS with it.
On first boot after flashing I got a message on screen saying “Flashing boot block” for a few seconds, then another reboot and that was it. Everything was working again, except for the DMI data that seems to be gone.

For the sake of trying to understand what was wrong with the backup, if it was corrupted or what, after having the laptop working again I took another dump of the BIOS using the programmer and saved it to a new BIN file (017F8_F0A_Post_Recovery_Flash_Backup.bin).
Then I erased and re-programmed the BIOS with this new dump and expecting for it to work this time.
To my surprise this was not the case, I ended up in the same situation I described above (blinking cursor on the top left corner and stucked there).

If anyone can help me to understand why restoring a dump is not working as expected, I will be really appreciate it.
Since I’m new to the forum I can’t post the links to the different BIN files, so feel free to PM me and I will be glad to share them.


Also wanted to ask, is there any guide to extract DMI data from a BIOS dump?
I’ve been searching the Internet but without success.


EDIT: I found something in the forum (use UEFITool and look into the padding areas) so I will try that

Finally I found why the first backup (the one I took while flashing the first modded BIOS using InsydeFlash) wasn’t working and after restoring it with the programmer all I got was a blinking cursor in the top left corner of the screen.

The problem was that the BIOS backup ME region was completely empty.
What I did to fix it was to use UEFITool 0.28 to extract the ME region from the BIOS file that was working (the one extracted from HP BIOS update package) and use it to replace the empty BIOS ME region in the backup.
Saved the new BIOS file and flashed it to the chip with the programmer and now everything seems to be back as it was before starting to play with it.

Marking the thread as solved.