[SOLVED] Coffee-lake Cpus on Sky/Kaby-Lake chipsets

Hello for everyone!
Thank you for you work/
I have start 8100 on GIGABITE H110M-DS2.
But have problems with PCI-E+voltage, same same like LittleHill on his MSI.

Please tell me: alot of info about Core i3 8100/8350K, but no info about Core i5 8400/8600, somebody tried this tricks with Core i5 or you tried only with Core i3? What about ASRock with Core i5?
I have Core i5 8400 but he didn’t start (switchON per 2-3 sec and after switchOFF without any signal)

On Baidu there are only pictures of Asrock MB running with functional PCIE x16 slot.

For i5 and i7 you need to integrate other microcode. 906EA needs to be integrated, i3 has different CPUID.

Give me link to this pictures please.
Believe me, I know everything about CPUID and have tried with mc 06EA (latest revision).
I think all problems in ME, because with ME v11.8 I can’t start Core i3 8100 too. Same same problem like with Core i5 - start per 2-3 sec and stop. But if rollback ME in this version of BIOS to v11.6 Core i3 8100 works fine.
So, as I think it’s need to fix ME for coffee lake support on <3XX chipsets.

hi @mammoht
The baidu-sources posted by @Sebastian-Sigma shows 12 threads in os,
Even through the pictures are shitty low-res i believe it implies use of i7-8xxx on mentioned board. (also asrock:: ASRock B250M Pro4)

I will try to run i5 at least when i will be able to get the pcie working on something else then asrock.

I believe it can be done purely by bios mode because we have multiple unrelated asrock board tested and they work as a charm, what are the others manufacturers bioses missing ?
As this is a question of PCIe from CPU, layout and periferies on PCH should not affect this.

Best regards so far, will post if any porgress is made.

Need version of ME that used with b250M Pro from baidu-sources…

P.S. I think it was fake with 8700 on baidu-sources… cause picture is very bad quality (nokia 3310?)

I was able to force ME region from working ASRock to same PCH MSI/ASUS boards, no change, did not solve the PCI-e issue so far.
@mammoht : if you have a working example of board from other manufacturer then ASRock and with working CPU-PCI-e lanes please share the bios file or at least a method to replicate results.

I do not know English, this short story is from Google Translate!
According to your method to add CPU microcode, VBIOS, GOP; can make most of the H110 \ b150 \ B250 \ h170 \ H270 \ z170 \ z270 motherboard lit into the system. ASRock most models set motherboard, voltage, full load frequency, PCIEX16 can be normal! Asus, MSI, Gigabyte are the first PCIEX16 can not work, and some models of voltage anomalies, if there are voltage adjustment options you can adjust does not affect the use. Also tested a number of small factory motherboard: such as Rainbow, Onda, Ming speed, MAXSUN, Somerset and other brands H110 motherboard, there is a problem, CPU frequency can not work full frequency; such as i3 8100 clocked at 3.6GHz, but these small factories Motherboard can only work at 2.7GHz, I tried to replace the ME version, turn off energy and power constraints, doubu

Success in the MSI Z270 motherboard lit 8700K!



Success in the MSI Z270 motherboard lit 8700K! This is really very happy it!

Can you tell what GUIDS in BIOS you have change to start this MB with 8700K?
Can you share your bios?

No, I have only GIGABITE H110M-DS2 with PCI-E and Voltage problems(((

Ok, so 8700K has been shown to work on a MSI Z270 Krait Gaming.

The main PCI-e slot works - so what is different about this board? It uses a PLX chip for multiplexing the PCI-e lanes, as this motherboard is SLI capable.

Why did you think that PCI-e slot is working?
Maybe he connect GForce210 to small PCIEX1 by raiser?
Need more info…

He said:

OK. Maybe our pciex16 not works cause we have voltage problem and its did not start?
So, we have same same problems with Gigabyte GA-H110M-DS2, Asus H110M-K, MSI-B150M_bazooka-plus, BIOSTAR B150....

Did you test with your Gigabyte GA-Z170-HD3 DDR3?

Just ordered an AsRock H110M-HDS just for experiments with an i3 8100. It is the cheapest Skylake available and has the BIOS chip socketed if things go wrong
Among the various BIOS available, is it better to insert the modules into an old version or a more recent one?

2、These models can be used normally I3 8100 \ i3 8350k. And you can light 8700K, to work properly. If you use 8700K will cause short-circuit the two pins burned! This is because Intel changed the power supply definition!

Hi, @shixinyuan
1) can you share bios-binaries for the ones you mentioned ?
2) I have doubts abou if it was caused by the 8700k because those pins you shared with me to be broken have the same function and layout on both sockets CFL and KBL as well. There is no reason for aby damage to happen if the board is routed by intels guide-lines.
Can you measure resistance-to-gnd on those pins ? should be in range of miliohms.

Thank you

Hi @elisw , use the latest version, just make sure, you are not using ME of higher version than 11.6.
I have not observed any difference except the compatibility for ram etc. that is why the latest is recommended.
Share results please.

@LittleHill Thanks for the reply.
the board will arrive within a week, so it will take a litte time…
I have a further question for those doing the tests: how does the motherboard deals with DRAM speed?
on non-Z chipsets is it limited to the board original speed or does it automatically adapt to the new CPU DRAM max speed?