[SOLVED] Coffee-lake Cpus on Sky/Kaby-Lake chipsets

EDIT 1-MARCH-2018: Thread is considered solved, thanks to all who participated in this.
Solution here:
Fixing PCI-Express for Coffee Lake CPUs on Sky/Kaby Lake non-Asrock motherboards (2)

Following work is done in the same thread:
Fixing PCI-Express for Coffee Lake CPUs on Sky/Kaby Lake non-Asrock motherboards

Original post:
Hi to anyone reading this. Coffee-lake=“CFL”, Sky-lake=“SKL”, Kabby-> "KBL"
I successfully added microcode of CFL cpu to an B150/Z170/Z270 bioses and I am able to get CFL cpus running without any HW mod on the board.
(Do not mind the BS intel put out about pinout incompatibility, close look reveals there is no big issue in that - you can just pop the CFL cpu in board without a problem or risk of damage.)

I get the full cpu functionality, tested that with many benchmarks and stress tests. Example: https://browser.geekbench.com/v4/cpu/4500790
Tested with i3-8100 on H110,B150,Q170,Z170,B250,Z270 boards.

I can not get the PCI-e x16 lanes comming from cpu running on CFL.
The internal intel-gpu on die does not boot up as well. (I presume the gpu failing is just a result of the pci-e bus not being properly configured.)

Does someone have an idea what block/piece of FW does configure the pci-e in cpu (or the expected pci bridge) ? All system-tests so far were with gpu on one of the pci-e lines comming from PCH. That works very well, no issue there, all peripherals as well. (usb3.0, sata etc.)

As the CFL architecture is really similar to the SKL and KBL i still have hope this is possible.
Please do reply - i appreciate any tips how to get to the bottom of this.

Note: I do not mind to get my hand dirty with HW mod or any sw/fw/bios modding. This endeavour became my hobby for past month and i am looking for help and tips to get this functional or just to find out why exactly it does not work.

Thank you for any tips or ideas.

EDIT by Fernando: Typo within the thread title corrected (Kaby Lake instead of Kabby Lake)

MSI-B150M_bazooka-plus_i3-8100.zip (5.17 MB)



I’ve read somewhere than intel ME put some restriction to software compatibility.
i think you need to investigate that.

Regards, Ray.

Keep in mind that too :



Hi thanks for the reply, i am adding an explanation to my thoughts about this:
1) ME blocking
i have been looking into that possibility and truly the 11.7 and higher ME does try to block run-time. It shuts down loading of bios. That is not happening with either 11.7 “disabled” by null-ing out parts of fw or using 11.6 (or lower).
Expectation: The init of HW is done by the bios dxe or some other setup and it is a matter of “writing to the right address”. (What even is the address for cpu’s pci/pci-e bridge on KBL ?)

Note: even after official “update of ME” by intel’s tools which cases system to fail booting with CFL i can re-flash the old bios with 11.6 which enables me to boot etc. Therefore i am pretty sure the blocking part is NOT in any “internal” code of ME. (Meaning the on die uController’s flash or something…)
2)pinout, yes, i mentioned that in the fist-place of original post - it does not matter, explanation:
- The “pinout” differs only where the SKL/KBL 1151 had reserved pins - those are left floating (not connected) on the MB’s pcb. With one exception, that is covered by [2b]. (This is true at least on all MB that i tested, since MB manufacturers did follow Intels SKL/KBL guide-line for layout.)
- All of the new pins are power-pins. This makes about 8% improvement in CFL power impedance to KBL. It is a difference but not a one that matters. Cpu has all power-pins connected by power-plane. I tested for 20A currents pin-to-pin, all VCC are equal.
- Power delivery on i3-8100 can not be affected by this since it does not even use full 90W claimed capability of KBL… etc. On Z170/Z270 boards people have been overclocking as hell draining more than spec power of CFL socket. Not to mention i am able to stress-test the cpu while measuring the core-voltage. There is no issue with the power delivery. It is, in my opinion just intels marketing BS… (And my measurements pretty much confirm that.)

2b] The VSSGTx_SENSE pin/rail: This one is tricky. It is obviously made to make people think the sockets are not compatible. Big reveal: THEY ARE! :slight_smile:
- On older SKL/KBL intels spec it is meant to be the sense of gpu’s secondary power source “on-die”. Parallel to VSSGT_SENSE. IT IS NOT USED. (On all boards that i tested it is either left floating or connected to ground - according to intels spec of KBL/SKL when not used.)
Why it was not used ?
- It is not mandatory, the gpu can comfortably run from one power-source.
- Why would MB manufacturers went to the extend of having two power-sources on VRM, when they can do just fine with one. It would be just extra cost.
- on CFL pinout this pin is connected to GND, no issue there. either is is on SKL/KBL socked on GND too or, as others previously reserved left floating…

- I attached screen-shot of important section in intel’s spec.
Thanks, i hope this clears out some confusion about this topic.

Best regards


Update iGPU VBIOS to V1054 and and GOP Driver to 9.0.1069, see if that gets the iGPU up and running.

Thank you for your answers.
I got iGPU works but have some problems with CPU core voltage and PCIE channel.
I tried i3 8100 on MSI and BIOSTAR B150 motherboards and got 1.4v idle voltage.When I add heavy load to CPU and it got 0.6v or lower voltage ( I guess it’s a mistake ).
And the main PCIE from CPU cannot work , so I must insert my graphic card to second PCIE slot.
But when I switch to ASRock motherboards , I got everything works just fine.

Hi, i aquired some more hw in order to test and further develop this compatibility.

Could you share with me your results? Mainly the list of stuff you had to change/update, possibly original and updated bios binary? ASRock or even the BIOSTAR you mentioned
(Write me a message or a reply how did you get the ASrock mb running.)

As you stated, the voltage measurements can be wrong - as well i can test this with advanced measuring HW. (specifically the MSI B150 bazooka boards which i am willing to mod on hw level to test.)

Thank you very much for helping this compatibility hack/patch

It’s so easy to get ASRock MB working with quad-core 8th CPU like i3 8100 or i3 8350k :

UEFITool 3 modules:
Microcode 17088572-377F-44EF-8F4E-B09FFF46A070 (extract from Z370 MB)
GOP 380B6B4F-1454-41F2-A6D3-61D1333E8CB4 ( version 1073 )
VBIOS C5A4306E-E247-4ECD-A9D8-5B1985D3DCDA ( version 1054 ) .

ME region is not necessary to modify. Just not too new.

But other brands MB cannot get main PCIE ( direct connect to CPU ) works and CPU voltage is abnormal.
I replaced ASRock’s DSDT (C118F50D-391D-45F4-B3D3-11BC931AA56D) into BIOSTAR MB but nothing happen.

maybe to better understand the problem it could be useful to test the opposite:
has anybody tried to insert a Kaby Lake CPU on a Z370 motherboard?

Hi @elisw , thanks for the note
I can test such condition, have not done it so far because many people with z370 board do not want to risk the warranty lost in process of researching this hack.
And the majority does not need this (apart from the rev.engineering factor), cause if they are willing to pay for the z370, why to "mod" bios for the older cpu.

What would you suggest to test in such conditions ?
As far as "to find out what is going on" i am working on the iGPU VBIOS update on my boards as it was mentioned in previous posts - it actually might help.

Hi, @dsanke thanks for the very useful info.
Could you share the exact ASRock board-type you used?

1) I got the iGPU running. cpu-pcie-x16 still does not boot for now. Same state on MSI B150 and ASUS z170

2) I am looking into the voltage regulator problems as well and i am using MSI B150 Bazooka plus so if i need to check the differencies in dxe drivers it might help me understand.

All 100-series ASRock MB can get everything works well.

Hi @dsanke , are you able to get PCIE to work?

@hoeman Now I can only get ASRock MB’s main PCIE work.

@dsanke could you provide directions on how to do so and which ASRock Z170 board? So PCIE works? I can run a Z170 with a 1060 and Coffee Lake CPU?

I been able to replicate @dsanke example,
1) Got the ASRock B150M-HDV 100% working by mentioned steps. updating GOP, VBIOS and microcode. Still working on the others.

2) For anyone who might want to help with this and does not have access to example of i3-8100 or can-not spare a board i uploaded the working bios file as well as 2 other bios files here: http://www.mediafire.com/?noo62dvgdvue1
The other 2 which shows iGPU working but not the PCIE lanes. (MSI B150M bazooka-plus and ASUS Z170)
Note: If you want me to upload the binaries elswhere, just send message.

Any help or tip is appreciated. I am looking for difference why the asrock works and other do not.

3) Voltage issue mentioned in previous posts is a “bad reading” actual voltage on board is the default of a certain cpu ~1.1V even the bios shows 1.4V
Setting the voltage in bios from auto to specific value sorts it out and the VRM follows works a problem.

Hi @hoeman , yes you can.
I will be putting out a [guide] shortly.
Simply use UBU (i used the v1.69.6) to update attached files. (VBIOS, GOP and microcode)

Just run UBU.bat - it provides fine interface.
starters guide can be found here: [Tool Guide+News] “UEFI BIOS Updater” (UBU)

Intel Skl-Kbl-Cfl GOP 9.0.1073.zip (36.9 KB)

VBIOS_v1054__Section_Freeform_subtype_GUID_A0327FE0_1FDA_4E5B_905D_B510C45A61D0_body.zip (39.8 KB)

ucode.zip (187 KB)

Do you think this will be harder to work for Zx70 Boards?
PCIe x16 will probably be configured differently due to 8x+8x option?
Would be interesting if it is possible to mod the hexa-core ones to work on the Z170 and Z270 boards.

  1. I am planning to test this but it will probably take me a month to collect the HW for testing.
    Will post results.

    2) Zx70 boards should work just fine as well, because the configuration is done as a configuration of pcie-bridges on board and if the main x16 works, they should too. @dsanke even shared a working example of ASRock Z170 Gaming setup.

look https://tieba.baidu.com/p/5506064145 Z370BIOS–>B250M Pro4 and To transform the CPU .
Sorry, I can’t speak English

Hi, thanks for link, good to know that there are other people chasing this topic.
@Sebastian-Sigma If you would be able to provide mod BIOS file binary from the ASRock B250 that migh help us too.