[SOLVED] Compare change between two BIOS versions

I have a pretty unusual problem with my computer and I think a BIOS mod should be a great solution for that.

I am actually using a Jumper EZBook X1 laptop, and the Wireless card can’t be seen on Linux. Using lspci -nn on Linux, the line “01:00.0 Network controller [0280]: Intel Corporation Wireless 3165 [8086:3165] (rev 81)” is missing. However I can see it without any problem on Windows 10 (using pciutils for windows).

Another laptop had the same problem, the Teclast F5. However, a BIOS update solved it. I am trying to figure out what changed between the two versions to make it work, and apply the modifications to the BIOS of the EZBook X1.

Is there any way to search for differences ? After days of trying with UEFITools I still have not figured out what could have been the modifications to make it work on Linux.

Teclast F5 wifi not working.zip (4.43 MB)

Teclast F5 wifi working.zip (4.46 MB)

EzBook X1 wifi not working.zip (4.42 MB)

@Thymidin - On the Teclast BIOS, one is a dump correct, and other is stock BIOS package? The working one looks like a dump, with two complete NVRAM volumes, the other non-working does not look like a dump (missing an entire NVRAM volume, and 3/4 of the other missing leaving only stock data instead)
If these are dumps, from one and not the other, can you flash back the not working BIOS and then dump it too, so a better comparison can be made.

These machines are not same as the other, so no comparison can be made like that, at least not easily. The BIOS EzBook one, looks like a dump too, complete BIOS with two populated NVRAM areas.

When working, are both types supposed to use the same driver? Is LAN Chipset the same?
Since it’s working fine on windows, on the “Non-working” system, that says to me BIOS and device is fine, this is a driver issue, however if you experienced same on other system too maybe this is not so true as it seems.

@Lost_N_BIOS - Sorry for the time it took (more than a year, I know…). I tried everything to make it work by myself as I wouldn’t want to waste your time.

So here is an abstract of what I tried :

- Tried to use amisetupwriter to change some var in setup – Failed
- Tried to unlock the advanced menu to try with CSM Legacy boot – Failed
- Tried to modify the DSDT but couldn’t figure any problem about wireless with that – Failed

- Then, I flashed the Teclast BIOS directly on my Laptop and… Everything works fine, wifi is recognized on Linux without any problem, except the internal speaker which doesn’t work on any OS now (the audio jack works fine).

I guess this is enough to confirm that this isn’t a driver issue.

So, i wanted to know if there is a way to extract the “audio part” from the the EzBook X1 UEFI to replace it in the Teclast F5 UEFI.

Thanks in advance !

EDIT : I was able to make the internal speaker work by using hdajackretask on linux. However, I tried to use regedit on windows but nothing works for now. The only topic I found about this kind of problem is this one : How to remap audio jack in BIOS ? (2) but I don’t fully understand what I should do here… Maybe someone can help ?

EDIT2 : Dump with the Teclast UEFI attached

Teclast.zip (4.45 MB)

Problem solved, I just made an HDACfg.dat and placed it in /Windows/System32/drivers to "bypass" the bios pin config without modifying the BIOS.

Attached here for those who may need it for this laptop.

HDACfg.zip (289 Bytes)

Hi @Thymidin , I have a similar problem as yours, where my pin config in BIOS is incorrect. I do however, have the correct pin verbs. How do you generate the HDAcfg.dat from these pin verbs?
Or did you extract yours from a BIOS blob?

Sorry for reviving an old thread.