[Solved] DELL E5570 / 25Q128FVSQ Backup taken but how to remove Service Tag and flash other E5570

Hello friends,

this is very useful forum. I have a DELL E5570 Notebook for about 4 years. I bought it from a custom auction. But the old owner has activated the Computrace i think, i could not use it till now.

I found Win-Raid Forum and red many topics about flashing, modding etc.

I opened my motherboard and found out, that my chip is Winbond 25Q128FVSQ. I bought another empty working chassis E5570 notebook. I bought lastly the CH341A USB Programmer and the SOIC8 Clip.

I connected with the CH341A Programmer v1.81 to the working motherboard (without restrictions) and backuped the bios as BIN and ROM file. Verified too.

Now my gain is, that i want to flash this rom to my computrace activated motherboards chip. But before i am thinking; what will be the Service Tag of the working rom?

I found a Software called FD44Editor. But it only works i think with asus or it id not function.

Would you please orient me, how to change the change the Service Tag of the backup rom and wanted to be sure, if i can flash the backup rom directly with the same programmer to the computrace activated notebook chip?

Thanks in advance and thanks for such a useful resource on the web.


as i shared, i made a bios backup from working (not computrace locked) DELL E5570 notebook. Later i made another backup from the non-working (computrace activated) notebook. After that i erased the bios with CH341A Programmer v1.4 and made "Blank". After that i flashed the bios backup from the working (not computrace locked) notebook and verified. By the way i did not any changes on bios dumps. U used UEFITool to look inside and extract but i did not know how to work on it, thats why i did nothing and directly flashed the bios from one notebook to the other.

Now the notebook works :slight_smile: The bios shows the right Service Tag. I did not change the Service Tag in Bios Dump but the notebook did not take the Service Tag from other notebook. I did not understand why?!?

But the good thing, the Computrace field was not grayed out. So i could disable Computrace and now the field is grayed out but disabled. I installed new windows and made a bios update from DELL. Everything works, it seems so.

I only have a problem, i dont know why: if i turn the notebook on, it takes about actually exactly one minute to the DELL Logo. Before that there is a blank screen but the keyboard has light up and the power button up. I tested to restore factory defauls, bios update, but every time, if i restart or new start the notebook, the bios is waiting one minute and than the DELL Logo appears.

Has someone has idea about these:

- i flashed a bios dump from another notebook with same model and config. Why the Service Tag has not been taken from the source notebook? How does the Service Tag saved in system?
- And why should it take one minute to load bios DELL Splash Screen with blank screen?

Thanks in advance.

By the way my system configurations:

1. Notebook (working one and the computrace deactivated)
DELL E5570 with i7-6820HQ CPU without USB-C Port

2. Notebook (non-working one, actually working but because Computrace was activated, i could not use)
DELL E5570 with i7-6820HQ CPU without USB-C Port

Now the Second notebook works and the Computrace is disabled (i disabled it) after flashing the bios backup from the first notebook.

By the way for the people, they have E5570 Notebook: The SOIC8 Clip is working very well with the chipset on this mainboard (25Q128FVSQ). So i did not need to remove the chip from mainboard and solder again. And i did not need a extra power source. The power adapter was not asserted. I did not have a problem by flashing, reading, erasing, blanking and verifying. I used the CH341A Programmer v1.18, v1.29 and v1.40. All of them worked in both way.

The v1.18 only detected chipset model WINBOND 25Q128BV but worked.
The v1.29 detected chipset model as WINBOND 25Q128FV and worked.
The v1.40 software had the chipset detection not like above versions but he detected a model and worked too.

I wanted to share everything, that i done and would be happy, if someone can help me about the above two questions.

Thanks in advance.

Hello friends,

today my actual news about this problem.

As i mentioned above, the flashed bios dump (from working bios without computrace lock) had a problem, that the post screen (blank) before DELL Logo took about one minute. I realised that the system was unstable also. I today flashed the old and computrace locked bios dump back to see, if it has the delay problem still. But it was not the fact. So i red the threads a little bit more and decided to use the original dump but with modding.

So i used the UEFITools 0.21.5 to compare the bios dumps. I only copied the BIOS region from the working (not computrace locked one) bios dump and export it. I than replaced the BIOS Region with the exported one on the not working bios dump (working but computrace locked). After that i saved the modded bios and flashed to the system. Till now, the computrace is not disabled. The delay on post screen is not anymore occurs. I installed windows and installed drivers etc. Till now everything works fine.

So only to replace the BIOS Region on UEFITools solved the Computrace lock problem.

Again what i needed to do all this:
- (1. Notebook) DELL E5570 Notebook with Computrace Lock (activated)
- (2. Notebook) DELL E5570 Notebook without Coputrace Lock (deactivated, i disabled it later)
- CH341A Programmer Software v1.40
- UEFITools v0.21.5 to modify the BIOS dump

- i took from both notebooks bios dumps with CH341A Programmer Software
- i replaced the BIOS Region of the 1. Notebook with the 2. Notebook’s BIOS Region with the UEFITools and saved it
- i erased, blanked the BIOS of 1. Notebook with CH341A Programmer software and flashed the modified BIOS Dump to the 1. Notebook. Verified and was ok.

After that the system worked well without Computrace Lock.

Thanks for this useful forum and if someone have question on this notebook model, feel free to ask here.