[SOLVED] Gigabyte GA-Z97X-UD3H cannot boot in AHCI mode if HDD initialized in GPT

To clarify, I was asking if, when, you updated the RAID Roms, did you update both legacy and EFI in the BIOS at same time? In BIOS when you update the RAID Roms, there is two modules to be updated, so I was asking if you did both when you tried that previously?
UBU will update both, if you tell it to do both, and it’s up to you to insert both modules into the correct folders before running UBU. Sounds like you did both, so I guess this is out as possible fix.
I assumed it wouldn’t matter anyway, since RAID means RAID and this is ONLY used when you use RAID, but worth a shot since one of them is named SATADriver module-wise in the BIOS.

Gigabyte will get back to you in support system, sometimes it take a bit, but probably much longer now due to coronavirus slowing everything down
But, they will get back to you, and if you sent them specific case info (HDD model used, exact scenario to create the issue etc) they will test that exact scenario and either tell you how to not make it happen, or send you a fixed BIOS.

I checked my board pile, and sold all the Z97 and H97 from Gigabyte I had, so I can’t test myself
I was really hoping and thinking I still had a H97 to try this with, I know it wouldn’t have been the same, but maybe if I could have found the issue on my end I could find solution, but no dice

Wait a sec!! I did a double check just now in my old board for sale list, and I found I do have a Z97X-UD7 in pile somewhere! So, let me dig that up and see if I can figure this out
I will test with WDC WD40EZRX, but I’ll have to move all my files off it first, so give me a few days to sort all that out and do some testing

Yes, I updated RaidOrom.bin RaidDriver.efi both at the same time.

ALright! Thanks!

I’ve opened the BIOS file in MMTool, and there are “ahci”, “ahciSmm” and “ahciMmioSmm” modules. What could happen if I replace them with modules from other board (from GA-B250M-D3H perhaps)? Though I don’t see “ahciMmioSmm” module in GA-B250M-D3H BIOS file…


Well, tried that. :smiley: Just couldn’t detect any SATA device after that. :smiley: Reversed to original BIOS after that.

Please edit your posts if you need to add more info, questions etc, and no one has replied yet. Thanks

So, you don’t think WD40EZRX will give us valid test scenario? If not, we may have to wait on this, at least for me to test, I will need to purchase a 4TB 4K native drive. I am looking to buy another 4TB drive anyway, so this gives me good chance to do soon as I can!
Can you please look at Amazon for me, and show me what WD models you find 4TB that are for sure 4K so I look at pricing on the correct ones.

And keep in mind, once you get replies going with Gigabyte directly, they will resolve this for you too, so there is no massive rush to get this done Asap.
Use your drive otherwise for now (ie in RAID mode, with OS and single disk non-member), until we get this sorted out. This is ideal solution anyway, I would have just used this from the get-go and never messed with all this testing.
I used to run non-member RAID mode always with a single OS SSD and HDD before that, on purpose

OK, I’m doing exactly like you say, and now you confused me with lfb6 and mixed our messages into 1. :slight_smile: Can you please split them back and adjust your reply, who exactly are you replying to? :slight_smile:

Sorry, must have seen all those replies as you, didn’t notice . I was replying to you, and or him (about the disk I have I guess)

@Tacis - does the size of the partition matter? I think maybe we discussed, but I looked back to be sure and I can’t see it If not, maybe I can use a NVME or SSD?

@lfb6 - would that work? ^^ Or, do you think for a valid test I need an actual 4K native HDD? If yes, can you show me which models are cheaper ones on amazon, if you don’t mind - thanks!

I know they will test and resolve if we can’t, just have to wait it out

Sizes don’t matter. Even presence of any volumes is irrelevant. I tried:

1. GPT + 4 TB NTFS
2. GPT + 2 x 2 TB NTFS
3. GPT + 6 x 500 GB + 1 x rest NTFS
4. MBR + 2 x 2 TB NTFS
5. MBR + 8 x 500 GB NTFS
6. GPT without volumes (all space unallocated).
7. MBR without volumes (all space unallocated).

Still waiting for their response…

Thanks, hopefully maybe I can test with SSD or NVME where I can set my own sector size, hope lfb6 will know if that would be valid substitute or not.
In meantime, while you wait on support via ticket system, you should get a thread going at both of their forums too and see if any official reps will step in and test on their end as well

https://forum.gigabyte.us/ - zero response
https://forum.giga-byte.co.uk/index.php - still waiting for account approval (since Thursday)
https://forum.gigabyte.ru/ - “just get rid of that HDD”

Well, at least they will reply to you for sure in the ticket system, and hopefully you get good tech that will setup test right away, if not ask them to directly and they will (usually they show proof of test too, images etc)

Doesn’t Motherboards typically allow you to disable a SATA Port in the Firmware? Yours do. Can the Port be re-enabled AFTER Windows boots so that it detects the HD?
Basically, connect the HD with no Partition Table (No MBR nor GPT, totally blank) so that it doesn’t freezes on POST, disable its SATA Port in the Firmware, create a Partition Table and try again. If it doesn’t crash, maybe you can get it to work Windows-side at a later stage.

Port can be disabled at BIOS side, but then cannot be re-enabled at windows, since disabled in BIOS windows would not see the drive at all (ie no power)
He could hot plug it and do similar to what you mean though, but unsure if that would be OK always, or just on reboot freeze again.

Actually, theorically it is entirely possible to re-enable it from within Windows. You may want to read 13.1.35 section of the Intel 9 Series Chipset Family PCH Data Sheet: https://www.intel.com/content/dam/www/pu…h-datasheet.pdf

The question is how you are supposed to do that…

It may be possible, I didn’t read datasheet due to your comment (ie the answer isn’t there).
I believe power is shut off to the drive when you disable in BIOS, I’ve tested power count values before when checking this about a disabled SSD I wanted to leave in place once, and it never powers on.

I checked what you mentioned, I believe that is for normal enabled at BIOS state, then OS can control sleep, or enable/disable at software level via certain apps/controls etc.
If disabled at BIOS level, it’s never enabled for the OS to see, so I don’t think that applies in such case, I could be wrong, but that’s how I think it would be implemented.

My understanding about the matter, is that the SATA Port is logically disabled but it can still be re-enabled if you toggle a magic Bit (As stated in 13.1.35 Tables). According to the Data Sheet explanation, all the SATA Ports are disabled by default and the Firmware duty is to enable them. Both the SATA Controller and the HD are still powered on if you disable/not enable a single Port in the Firmware, only the data link is off. Seems worth enough to me to see what happens if you were to enable the Port.

The thing is, you need something REALLY low level to write some random Bit to a PCI Device Configuration Space. I know that in Linux you have the setpci command and I have seen it used to debug some broken Hardware behavior or apply a workaround of sorts, but I don’t know how you are supposed to do that in Windows. If anything, the whole thing relies on the Firmware not getting frozen if you disable the Port with the HD, then figuring out if you can flip the magic Bit of the PCI Configuration Space, and see if Windows automatically picks up after that or not.

Yes, I thought that too how it’s worded, but then assumed BIOS enabled enables it, then as I mentioned applies… but those are just my guesses, and I can only further comment on my actual experience with disabling per port in BIOS.
When I disable port in BIOS, power on count does not increase, so to me that says disabled=disabled

Yeah, but no: "Seems, that some problems with new HDD. We recommend you to contact the service center of your seller for diagnostics.". No tests, no questions, no nothing. :slight_smile:

Officially, the shittiest present for my birthday ever. The Reply.


Wow, that first message would be too much really, they do not speak English so huge message would not get good attention. The last message there is great, short, direct and to the point.
I would make a new ticket with that only, adding "I request GBT please setup similar board/HDD test in lab"

Did you tested POSTing with the specific SATA Port disabled as I suggested before? I’m curious if that works to bypass the Firmware freezing, whenever you can find a way to enable the Port AFTER POST or not.

You mentioned that it works in AHCI Mode if you plugged the HD in after POST. That means that you have been using hotplugging?

Also, you made a question in the ticket about whenever the Firmware reads from the HD or not, or why it matters. Since UEFI, it DOES matter. An UEFI Firmware may be able to read the ESP (EFI System Partition) of all available drive units so that it can make a boot list, or something along these lines. Some Firmwares even provide a builtin file browser of sorts if you want to make custom boot settings (Loading a different EFI executable file). Your Motherboard Firmware should have issues parsing the MBR/GPT of that disk for some reason.

That will boot, port will be electrically disabled