[SOLVED][HELP] [AERO 15 OLED XA] After manually flashing stock BIOS, cannot open control center anymore


My laptop is AERO 15 OLED XA, just tried to flash the new FB07 BIOS by control center, but it just restart the laptop without upgrade the BIOS,
so I try to manually use AFUWINx64 to upgrade it, the command I used

AFUWINx64.exe P75VAFB07.rom /P /N /B /R /Q /capsule

and it upgrade successfully and boot up to windows 10, I used HWINFO64 and confirm the BIOS is FB07, but soon I found I can no longer open the gigabyte control center again,
I’ve tried to reinstall the control center (tried version &, neither works), also tried to manually flash back to FB05 (AFUWINx64.exe P75VAFB05.rom /P /N /B /R /Q /capsule), doesn’t help

Also I found Fn+Esc (full speed fan function) do not work now, anyone know how to solve this problem?

Many thanks!

Flash BIOS properly, not manually, the stock package also updates EC FW

Also, please wait, see here, follow along, then we’ll fix it
[Help] Flashed stock Bios on Aero 15, now it won’t post


Do you mean flashing BIOS using AFUWINx64 is not correct? Since the official stock package did not work (only reboot laptop and upgrade nothing)

Actually when I using AFUWINx64 to upgrade, I saw it also upgrade EC in the BIOS, so I assume it already upgrade EC firmware in FB07 or FB05(when I flash it back), do I need to also manually upgrade EC again?
(Just entre BIOS menu and confirm again, BIOS version is FB07 and EC version is FB006 which matched)

Also I do read the thread, it means I need to teardown my laptop and use CH431A to get some information? Don’t really want to do that, I’m afraid I’ll mess up, at least currently it can still boot up and work normally (except for control center and fan control…)


I tried enter BIOS menu and do restore to default settings, and problem resolved after reboot, control center and Fn+ESC works again

No idea why this fix the problem, actually I never change the BIOS settings before, it should already be default settings…

@youngtse - Yes, in a way, I mean that. I mean you are not flashing BIOS as manufacturer intended, unless you run their EXE (EC FW is not updated if you use AFU outside their EXE like you mentioned).
Since you mentioned seeing EC FW update, it may be OK, but I’ve checked this exe and the EC FW is not updated using AFU during the normal update process. I mainly mentioned this EC stuff, since it sounded like you didn’t update it, so mix-matched BIOS/EC FW possibly causing the issue
If you can still boot now, and all is OK (Ethernet working, not WIFI), then you do not need to take it apart. That’s only if you are not able to boot the system, then you’d need to dump BIOS chips and send to me to make you new BIOS to write to the chips.

Good to hear you’ve resolved your issues! Yes, always load optimized and reboot back to BIOS after you update BIOS, then once back in BIOS make all the other changes you want.