[Solved] Lenovo G50-70 bricked bios recovery


The computer shut down during bios update (probably over-heating). Then nothing but power led. No fan or display.

Found a dump and flashed with CH341. Computer turns on without SN, UUID etc.

Attached clean dump and original (bricked) extracted with CH341.

How can I copy all the computer specific data to the clean bios?

BIOSLENOVOG40-70 g50-70.rar (2.99 MB)

BIOSLENOVOg50-70-original.rar (3.11 MB)

Maybe it would be easier editing the clean image and add the serials.

UUID: 694039EF16D511E4A81828D244C7C08C

How can I extract the MSDM key (Windows 8/8.1)?




I tried extracting NVRAM with UEFITOOL_NE and then copy/paste with HxD, but there’s no POST.

UEFITOOL reports a few problems, but most of them are also present in the clean bios (which POST’s)

@na_sa - please wait, I will fix this for you from your original (bricked) BIOS and the other one which I assume is the working bootable one, correct?
NVRAM may be messed up, or it’s possible you did the insert wrong, hard to say. I will send you a mod with and without NVRAM transfer, then you can test if you want

@na_sa - Please test in this order, see if boot OK, and if serial, UUID etc back in place (I could only find your MAC ID in bricked dump, main BIOS region was corrupted, not sure if it was in there anyway)
1. Bricked-VolFixOnly << This is your bricked BIOS with ONLY the corrupted main BIOS volume replaced with working one. Test this first, if all good here, no need to test the others
2. BIOSLENOVOG40-70 g50-70-PadOnly << This has a padding file with some board specific info swapped in, but may be corrupted
I could not tell because I do not have another actual dump from running board of this model (not stock BIOS flashed in, actual proper dump) If this fails to boot, do not test next, it’s build upon this one

3. BIOSLENOVOG40-70 g50-70-PadNVOnly << This is the working BIOS you sent + Pad mentioned above + NVRAM swapped in from brick
4. BIOSLENOVOG40-70 g50-70-NVOnly << This has your original NVRAM only, put back into the working BIOS you provided.



It worked!

The first file did the trick.

Didn’t try the others, but I compared “BIOSLENOVOG40-70 g50-70-NVOnly” with what I tried - they are identical.

I think it probably has something to do with the CMOS battery. It’s soldered on the MB and I didn’t think of disconnecting it .
Only after I disconnected it - the computer POSTed and all the old info is there.

Thank you very much!

@na_sa - Hey, great to hear!! So, based on that, I would go ahead and also test #2, that way if that works too, you’d have all your full NVRAM and board specific info back in there too.
Surely your NVRAM edit and mine #2 could not be same, unless you also swapped the padding file I did at #1? CMOS shouldn’t matter, but yes, maybe needed reset. I would go ahead and try #2, if it bricks now, then you know for sure original NVRAM is corrupted.

You’re welcome!@


Your #4 is the one identical with my attempt.

The SN and MSDM are present. Are you sure I should try #2?

@na_sa - Ahh! You know what, sorry, I didn’t realize until now, reading my notes above again, that BIOS #1 you tried, would be best one. It was your original bricked dump, only fixed the main BIOS volume that was corrupted, all system details/NVRAM etc in other areas
So you’re good to go on BIOS #1, no other testing needed done, sorry for any confusion (especially mine ) No, no need to test BIOS #2, sorry about that, BIOS #1 is best one there!


If it’s not too much bother, can you explain how you made the different mods?