Solved, Lenovo s30 dead after windows 10 installation

Help is needed from experts.
Hi, my pc Lenovo s30 (machine type: 435, model: D32,… motherboard: Socrates rev 2.0) bios have been corrupted during windows 10 pro updating, I was using windows 8 and I manually installed a fresh windows 10pro-64bit, after installation finished i checked for updates in the setting -windows and updates, it was going good for 40-50 minutes untill when windows were updating its components and then a message windows pop up saying shuting down, after shuting down it starts and fan spins and after few seconds its get off and restart again for few seconds and its stuck on this loop forever, i tried, to reset bios by cmos battery removal, and cleared cmos using jumper as per the manual, tried also a bios recovery but no luckand i also checked powersupply with cplip it runing fine… At last, i have ch341 programmer laying around so i tried to read the old bios(dumps) , its a 16ping flash rom named as: MX25L12835FM1-106, So igoogled and find some one on this forum has read the chip so i follwed the steps and able to read the dumps, but i am not programers nor computer guy and dont know how to repair my bios if possible or replace with new bin file which i dont know to extract from bios,
so help is needed if someone can have a look at my bios dump and can fix it, or extract me a bin file that i can write to the chip,
note: This motherboard has no error code display screen like some have, and there is no beep, just a starts-off-restart with no display on screen complete blank no input
Thanks
.
here is the link for old dumps, and images of the system model
https://drive.google.com/drive/folders/1MKI3T6fZEmBkla1VqZNFoOb0q1cUNmze?usp=share_link

Checked your file, can’t see any traces of an update process or corruption of the static parts. Might be corrupt NVRAM of ME, but at least the latter is rare.

Just to test you might use a stock bios region, you are on A2KT45A, rather old but still available. Download update, unpack with innoex, open file in UEFIToolNE for seeing the structure, remove the first 0x1000 (AMI capsule), result is bios region (size 0x800000).
Use a hex editor or UEFITool to replace the bios region of your dump.

Post the result before flashing here!

1 Like

Thanks for suggesting a solution, but i don’t understand the processes involved in extracting and editing of bios and making the final .bin file which could be written on a chip, all I saw were youtube videos and some topics here but was unable to do so, I am seeking help and would be thankful if someone expert can do it for me if it’s possible.
thanks

Hi, I tried what you suggested, as i don’t understand these edits as i said earlier, but i tried with the help of youtube videos, so here is what i did.

1: I downloaded the A2KT45A An .exe bios file and extracted it with 7zip, and then find the .cap file inside it which was the largest file as compared to other, it was of 8mb in size.

2: I opened .cap file in UefiTool and expanded one step and save it as .bin but find it as .rom file in folder.

3: I opened the newly extracted .rom file and my old bios(dump) file in hex editor.

4: The 2nd half of my old bios(dumps) looks same as it of newly extrated .rom file, then i copied my old bios(dump) 2nd half and make a new copy and copared it with newly extrated .rom file, the start and end portions of both were same but i find some values that were null(means FFF) in newly extrated bios, and also i compared in hex editor and it showed some values in some areas differs but the difference was very little as compared to whole file mostly or 90% same i would say.

5: So as i told you i don’t understand wats going on and how to do it but i replaced the 2nd half of my bios old(dumps) with the newly extracted .rom file, the part i replaced starts from {00800000 - 00FFFFF0}
So i saved as “modified bios.bin” the link to which is here
https://drive.google.com/drive/folders/1ZXZN223XBekl6KuuRupNfvoFu-X7BMit?usp=share_link

Plz have a look and let me know if what i did is wrong or right.
Thanks

1 Like

Congratulations, looks good!

Might need several reboots to repopulate the NVRAM and you won’t have your machine specific data, but if it’s firmware/bios region related it should boot!

Thanks, but i was unable to read chip again as it was getting errors of chip not detected, i tried others programers too but no luck, i tried every thing but after searching my problem on internet i came across the same problem other people have on lenovo forum, so there were some people who had same problem after they migrated from any other windows or linux operating system to windows 10, all had same issues and bank displays probably motherboard issue…
here is the link for the problem…
https://forums.lenovo.com/t5/ThinkStation-Workstations/S30-0568-No-Post-No-Video-Output-After-Mandatory-Restart-During/m-p/4414159

Might be, but seems no one did find a solution to this problem and tried to work on the firmware. So it might be interesting if Windows wrote something into NVRAM which causes all this or if this is something else that is firmware related. Unfortunately I didn’t find any other complete S30 435* firmware up to now.

Unfortunately firmware updates via Windows update are possible and they’re ‘not always’ completely safe. On the other hand the Windows update catalogue keeps it secrets which updates it might consider appropiate for a certain machine type.

My Asus q470 board should get a completely different firmware, a Lenovo M920q (updated to latest version) should get a bios region from 2018.

The good news here is that for a machine this old there aren’t too many controllers on board…

I’d recommend you try again to program the bios! If you are able to find another dump of such a machine please post it!

Sorry for being late, i was busy, as i told you I wasn’t able to read the bios chip by myself so i took my pc to a local computer repair shop, as you said it seems bios issue he also told me that it’s a bios issue and he will install me a new bio probably copy from some other s30’s they have laying around. I asked him if he can provide me the .bin file of the new bios that he will program but he was not willing to give it to me this is a big problem of 3rd world countries where such repairing shop wont share information and even not tell you whats the issue that they can charge what ever they want…!
.
he puts the bios of same machine type: 4351, and bios version was also old(2014) so i downloaded latest bios(2020) available on lenovos website and installed it through dos bootable usb and now its updated.
.
the only issue i had now is, the lan port of pc is not working, it was working before, but now its shows faulty hardware or driver issue in the device manager, i installed drivers manually and updated windows 10, also i installed windows 8 on another hard disk to test it but no luck, it seems dead as no signal leds on lan port are also not working

That’s the problem when you flash “something”- might be empty GbE without Mac address, for example.

Since you paid for this I’d recommend to confront the shop with this problem.

Actually, you won’t belive if i tell you that those people are not literate, even i know more than them now, they only know how to desolder the chip and copy the data from one chip and write it to another, that’s it, not even know that this is binary data and how to maipulate, because they don’t know, this business in this part of the world works like that, they had a bunch of system laying around which they sale and use same for copying data and stuff, i told him that lan port is not working and he straight said that it not their issue…! so there is no point of wasting time with him on this point as i know at the end i won’t get anything for arguing with them, so I am using wifi dongle now…!

This is something i came across and wanted to share that how far is Microsoft going in with windows 10 so far…
https://answers.microsoft.com/en-us/windows/forum/all/does-windows-10-write-code-into-a-motherboard-bios/5cb48c90-0cc2-4c69-bf28-68f7c74f9618