[Solved] Machinist board not detecting HDD

Hello, sorry if this is not the appropriate forum, I don’t know where to post this issue for help

I have a motherboard Machinist MR9S and I have a problem when connecting a internal SATA HDD of 10TB, it’s not recognized not in the bios nor in windows 11. I’ve tried the disk in another computer and it’s recognized. I have tried other HDD of less capacity with the same connections and cables and they are detected. Anyone can tell me if there can be an issue with the motherboard? is there any update or configuration with the storage drivers that I should use to have this HDD working? Thanks

Has your mainboard an Intel X99 chipset? If yes, to which SATA port (which color?) did you connect the SATA cable of your 10 TB sized HDD?
With which SATA mode (IDE/AHCI/RAID) is the in-use SATA port running? If you are not sure, please post a screenshot of the Windows Device Manager after having expanded the “IDE ATA/ATAPI Controllers” and “Storage Controllers” section (maybe you have to replace the not detected HDD by a working one before starting the test).

It should have C226 or B85 chipset


Thanks for your replies.

Finally I solved the issue but I don’t quite understand how

After countless tests and googling, I tried to exchange the SATA power cable from the PSU. I used the one in the photo and magically then the drive was recognized

With the original cable attached to other drive that drive was recognized, but with the 10Tb drive it was not… but changing the cable and then the 10Tb disk was recognized… I really don’t understand why… but it’s working and that’s the important thing

So issue solved… anyway thank you very much for your concerns and help offered