[SOLVED] Marvell 91xx AHCI/RAID Driver detect SSD as SCSI HDD


today i have installed a new SSD (Crucial MX500) to my Sabertooth X79 Board.
I have choosen the Marvell 9128 Controller because of the NCQ Trim Support.

The Problem is, after installing the Marvell SATA 6G Drivers Station-Drivers ( Windows 10 detect´s the SSD as SCSI HDD.
Is there a Solution ?

With the Standard Microsoft AHCI Driver it detect´s the Crucial as SSD.

@Starfox :
You probably can solve your problem by following the advices given within the start post of >this< thread.


meanwhile i have changed the SSD from Marvell to the onboard Intel Controller C600/X79.

The Performance is better than the Marvell Controller. I have with Crystal Diskmark on the Intel Controller 580MB/S Read and 520MB/S Write, on the Marvell only 410MB/S Read and very bad 160MB/S Write.

I Use in Windows 10 the Driver from here (, and the Bios Rom´s EFI and OROM IRST RAID SATA OROM IRSTE

In AHCI Mode i checked Trim in Windows 10 with "fsutil behavior query DisableDeleteNotify" in command line. The Value is 0 that normally means that Trim is enabled.

@Starfox :
Did the execution of my linked advices solve your problem? Has your SSD been detected as SSD (and not as HDD anymore) even while being connected to the Marvell SATA port?
If yes, you may add the prefix "[SOLVED]" to the thread title by editing the start post.

Yes this Solved the Problem