[SOLVED] MSI GL65 9SEK no product name and serial number

Hi everyone.

So I just flashed my laptop bios chip with ch341a and stock BIOS firmware. And now there are no product name and serial number on BIOS setting. I cant get the msi dragon center working because it doesn’t detect the product name. what can I do? can anyone help me please?

Thanks for reading!

got this issue too, same laptop too

Thats right, read and learn before doing programming with stock files.
Information can be recovered/partial from full or corrupted dumps.
Specific tools or hex editing can be used to apply information.

can you give resources to read how to recover the bios fully? the product name, serial number, etc is gone. still can’t find any good resources to read and tools to do it. :slight_smile:

Try harder, plenty of info on the forum on similar situations and the use of programmers.

Hello, sorry for interrupting.

Can you give us specific links or explanations? I already tried hard to search but I found none with proper solution. There’s some forums with the same problem but it just end there without any solution, and one forum states that I need to edit the DMI with some sort of tools but it doesn’t say what tool was it. There’s no link for the tools and info for it. Can someone actually help me fix this?


@thiccchicken Do you have a backup/ dump of the original chip content? If yes- post it.

Yes, I’ll send you the dump file.

Don’t send information in messages. This is still a forum.

Dead end- your ‘backup’ contains a 10 MB bios region, but there’s just 30kB code (identical to 102) left, rest is ‘FF’. No structure and of course no machine specific information.


ALWAYS check your “backup” before overwriting the firmware! At least use UEFIToolNE, but best use a hex editor and compare the dump to a stock bios since all the static volumes (here in blue because of bootguard) should be 100% identical. For this bios EC firmware would have been in 1st padding in bios region, board specific information in second padding in bios region. As you can see this region is (of course) empty in stock bios since it wouldn’t be overwritten in a normal update procedure…

I’m sorry, it’s my fault not to upload here instead.

Yes, it is a backup file from the corrupted BIOS using ch341a and flashrom to back it up. in fact the backup file was probably already “corrupted” before I flashed it, I did the “bootlogo mod” with some sort of amichangelogo tool, which I don’t know that it’s good or not for my BIOS (yes I know I was dumb and careless). Recently, I successfully flashed the BIOS with ch341a and stock MSI BIOS file, but now there’s no product name on the BIOS, it says “Please change product name”. how can I fix this? can you help me?

Thank you!


Can he use the AMIDEEFIx64 - AMIBIOS DMI Editor for Shell… the machine is working, so he has access to host, is got a programmer anyway…


And yes INESC boiz we know that u need help but not too much miracles around… lately.

If you have the required information like serial and exact product name, you might try DMI tools. Some vendors do have the tools for often commercially used boards, for example Asus has a ‘Commercial BIOS kit’ (PRIME B250M-C/CSM - support - Drivers and Tools - other OS) that enable to edit at least some of these values. Maybe you are able to find something corresponding for MSI, maybe directly from AMI, or these tools do work already…



Thank you, it seems like MSI doesn’t provide any tools to edit the DMI, sadly. and I only know the exact product name of my laptop.
"We are really sorry, DMI information need to be restored by DMI Tool, but we did not provide the Tool to user, if you can find or download the DMI Tool from the Internet, you can fill these information in bios. If you cannot find the tool, please contact your reseller (The place you bought this MB from), then ask for some help. Sorry for any inconvenience caused."

Well, if there’s no method or tools for editing DMI of this laptop then I guess I’ll just use the laptop right away without it :confused:

Hello, I’m sorry for bumping this thread again.

I just want to tell you all that I’ve solved the problem. So, I recently discovered some tool from random youtube videos. It’s called TYPE11 Tool, I just changed the script .bat from another laptop to mine ( GL65 9SEK ) as instructed. I ran the script with elevated permission, and then boom, It’s working. Now my BIOS Product Name is normal again, I don’t know how this tool exactly work but if it works, it works right?

Here’s the link

It would be great if someone would explain this kind of tool, and how she finds the AMI tool when there’s no forum or thread is talking about “my problem”? ( actually there is, but most are old or the tool has been removed from mod ) or maybe my googling skill isn’t good enough… Anyway, thank you everyone for helping I really appreciate it.

Best regards,
Myself and @17radf.