[SOLVED] P9X79 WS/IPMI BIOS Overclocking unlocked...

@MMFC378 - Slow down before you brick your board! biosreg.bin output from FPT can only be used in that exact context with FPT, this is only part of the BIOS, you cannot use this with EZ Flash or flashback etc.
Luckily for you Ai Suite either failed to flash that and only looked like it did (common with AFU based tools), or it recognized it was only BIOS region (unlikely, my bet is on first comment)

I now refer you to what I said in step #19, please read that and do that and only as I mentioned, nothing else, no name changing, no trying this or that etc.
Do not use or attempt to use FPT for anything other than what I’ve mentioned here in this thread thus far, you can brick your board with a single click using this incorrectly, so don’t stray from things I’ve said here.

My fault. I thought that command line was to show errors if i had any.

I ran it and it looked like it was loading but the window disappeared too quick to see anything. I saw it reach 100% but i saw a few red lines pop up below it

I got it


@MMFC378 - No, that was a test I wanted you to do, flash back your dumped FPT region using FPT, and if any errors to show me the error. FPT must be ran from admin command prompt, you have to open it before typing in the command, using same method I gave you before when you created the backup.

The above image is not helpful, I cannot see the command you entered and that’s not an admin control prompt. Please open the command prompt using method as described in post #4, then enter command as given in post #19 and then show me image where I can see command entered and error all on same image

I hope i got it this time…


I would like to say that I have this board and also have the locked AiTuner. I am very hopeful the two of you can figure out a way to remove the password and open up the settings. If there is anyway I can help please let me know.

It tough finding X79 boards for a decent price these days and theres not a good enough reason (in my eyes) to upgrade. So i found this board for a ridiculously good price but didnt realize the work it would take to even get it running. We’ll see if Lost is our savior and hoping i dont mess up anymore of his instructions

I bought the board as a spare to my regular p9x79ws . It sat in a box for 1.5 years before I tested it. I got lucky moving the gpu jumper first so I didn’t have trouble getting it going initially. I have been using aisuite in windows to overclock on it but it is so limited. I can’t get XMP and that going simultaneously and I know I can get a much better overclock on the chip I currently have in it from my experience with my standard board. I will be very excited if we can get these unlocked.

Thanks @MMFC378 looks like FPT is locked out of writing back to BIOS region. I would try the same again from DOS instead and see if you get same error, this error is about invalid descriptor and we’re not writing or using a file with descriptor in it so you should not be getting this error.
If DOS Fails the same >>

Lets try this method, see this guide and download the attached files in the guide, we’re only paying attention to the last spoiler here (Flashing stock BIOS first, then mod BIOS)

Here is stock 1208 BIOS, for later use.

For now, download the files package included in the guide above, so you can get that exact AFU version, then using AFU make a AFU Backup and send me that file to make a single test change.
Once I send back to you, follow the guide exactly, flash stock and then without reboot flash mod

@Nuckyy - Hopefully you guys wont have to purchase flash programmers, but if you want to order now maybe they will arrive quicker They only cost $2.50 on ebay, get one of each item below, but long time to be delivered.
This way, if we can’t get a mod BIOS flashed in, then eventually you will have programmers then we can sort this out for sure.

AFU extracted rom

Extracted.rar (4.67 MB)

@Lost_N_BIOS These look to be the same as what you posted. More expensive but I could have them by next monday instead of a month from now. If you think they’ll work let me know and I will order them.


Awesome find. Id easily pay that to have in 2 days lol. But lets see what our hero can do

Yes @Nuckyy - you can often find closer or shipped faster on ebay or other shops for more $$
You guys BIOS is in a socket correct? If yes, then that is all you need.

Thanks for AFU extracted ROM @MMFC378 - Did you try FPT from DOS yet?

Here, please test flashing this mod BIOS with AFU, as mentioned above. This has only a single setting change (now two changes), you can verify after flash if it actually flashed by checking “Boot >> Boot Logo Display” Option >> Change default from Auto to Disabled
If you cannot see that setting now, don’t waste time flashing this yet, pick some other simple setting you don’t care what it is, and I’ll change that instead.
I also made a single change at very end that may affect Ai Tweaker visible or not (Did this right before posting this after already wrote this reply all out), so if you do get it flashed, after checking Boot option mentioned above, see what Ai Tweaker tells you now.

@Nuckyy - do not flash the BIOS above, please wait until we find the fix and I will do on stock BIOS (Or you send me your AFU dump etc) Otherwise you will loose your serial #, UUID etc, this has all MMFC378’s details in it, so again please do not use and wait I will do to stock once we find fix.

The site you posted with AFU instructions says something about asus boards needing to flash the original, then the modified in order to work. Should i do that?

@MMFC378 - Yes, as I mentioned previously where I linked that guide, the method is to flash stock (do not reboot) then flash mod, I also linked the mod BIOS there for you.

Ok, so i flashed to stock, then modded. It still asks for the password and my Boot Logo setting didnt change, but i did notice it no longer says "AiTweaker Not Available" like before

190228144714.rar (574 KB)

Thanks for info @MMFC378 - this proves BIOS mod was flashed in, since no “Ai Tweaker Not Available” anymore.
Logo setting change not changing could be expected, I only changed in NVRAM/SetupData, not in actual setup module. Some BIOS use one or the other, wasn’t sure which on this, so apparently this one uses setup instead for that setting.

This now means we can flash mod BIOS, and I can create test BIOS for you with empty/stock NVRAM, to see if the Ai Tweaker lock is stored there or not. If it is, we’ll figure out how to remove eventually! Or I can put in regular P9X79 WS NVRAM instead.
Or I can get you guys switched over to regular P9X79 board BIOS if you don’t use the IMPI features. This probably not best way to do it, so we’ll reserve that as dead last option.
I’ll get on this tonight for you, sorry can’t do now as I’m leaving soon.

I flashed it again and the Logo setting went back to Auto.

No problem at all. You’ve already done a ton for us IPMI owners and we appreciate it. Thanks for all your help

Logo went back to auto? I thought you said it didn’t change to disabled? Anyway, no worries on that no matter what, we already confirmed mod BIOS flashed in due to the Ai Tweaker message removed, either one confirmed changed is all we needed to prove this method works to flash mod BIOS.
You’re welcome, and I’ll get on this tonight for you!

* Edit - @MMFC378 - Quick test, simple change here to user access level, before getting into other stuff (always flash mod BIOS same way, stock, no reboot, then mod, reboot load optimal etc) Probably no change, but something we should check before moving forward
Speaking of Access Level, can you see on main BIOS page what your access level is set to now?

What CPU’s are you guys using? That textual notification I disabled, looks like it’s possibly tied to certain CPU’s

Also, I see this on the Ai Tweaker password, do you see this on screen before, if yes what happens when you push esc >> “Password Required Or Press [ESC] to skip” Does ESC just back you out of Ai Tweaker page?

Ill test that one now

Yes, thats the password message i get before entering BIOS. ESC just takes me right to standard bios screen.

Im using a 1680v2 CPU

Access level is Admin

Something a little strange happened. After it flashed, i was closing apps to restart manually, but it just shutoff and rebooted on its own.

I have both a 3930k and a 1680v2 I can test with. The 3930k is currently in the ipmi board and my 1680v2 is in my regular p9x79ws board. I would gladly lose the ipmi features as I have no use for them.