[SOLVED] P9X79 WS/IPMI BIOS Overclocking unlocked...

So the Ai Tweaker is locked on this BIOS so i figured the seller might have locked it. Turns out ASUS locked out overclocking functionality but was told it can be modified. So i turn to you fine folk who have help me out in the past to hopefully take a look and see what can be done. Im guessing its basically the same as the WS but i could be way off. Ive attached a RichC’s NVME modded bios which worked for me so far.

Even any info on this board would be greatly appreciated. I cant find anything on it and took a small miracle to even get this thing up and running. (its tough finding X79 boards at a good price and this was one)

i hope i did this right and if not, ill fix this post any way needed

Edit: Didnt upload

P9X79WSI.rar (4.43 MB)

@MMFC378 - Please take BIOS screenshots (F12) to USB and zip please of all the pages and settings you can see in Ai Tweaker, and in Advanced >> CPU Config and it’s submenu CPU power management

*** @ EVERYONE - SOLVED *** See post #117 for IMPI 1208 Ai Tweaker Unlock BIOS!!!

Screenshots attached. These are after it asked for a password (which no one seems to have). Cant get any settings in Ai Tweaker to show

Edit: Didnt upload

Screenshots.zip (2.37 MB)

@MMFC378 - You never mentioned password! Try risky or Risky. I assumed you meant limited BIOS, locked out of settings as in hidden settings, not a password. Is Ai Tweaker only place you can’t enter without password?
I looked around about this issue, and seems you’re the only one mentioning it or asking about it in the entire internet. I wonder how that’s possible!
Did you flash in RickC’s BIOS? And still password? If yes, you may need to get a flash programmer (Ch341) and IC chip extractor, remove the BIOS chip and program in a full BIOS manually to remove the password

We can try to fix via FPT though, tell me your ME FW version, check BIOS main page or with HWINFO64, in the large window, expand motherboard then find ME section and get the version.
Once you know ME FW version, download ME System Tools package from section “C” in this thread - Intel Management Engine: Drivers, Firmware & System Tools

Inside you will find Flash programming tool folder, and inside that a windows or win/win32 folder. Select that Win folder, hold shift and press right click, choose open command prompt here (not power shell)
Then run the following command and zip the created file and upload for me >> FPTw.exe -bios -d biosreg.bin

Yea, the password is strictly for the Ai Tweaker. Ill try that password first and see if it works.

My ME info is - Intel ME Version: 8.1, Build 1471, Hot Fix 51

Ill follow those instructions and get back to you shortly. Thanks for the help :slight_smile:

Got it

biosreg.rar (3.5 MB)

Thanks @MMFC378 - I will dig into your BIOS dump tonight and see if I can find out where password is being kept, see if I can remove etc. You didn’t reply, are you already using the BIOS from RichC and still password after that, or you not using that BIOS anymore?

Oh, sorry. Yes, thats RichCs modded BIOS and still has the password. I just added Samsung ahci support to it

Thanks. Do you care about loosing Serial #, UUID etc? I have a test in mind that will remove these, only to see if it unlocks AiTweaker (Clearing out NVRAM data, replacing with stock clean/empty), but we can put back the original once done with testing if you need it.
This would only be to test if the password lock is within the NVRAM data or not, and is not permanent. Do you want to try that real quick?


Wait, why are you using 1208 BIOS, when current is 4901? Can you please flash in 4901 from this thread, not RichC’s BIOS in post one, but the one I posted at post #13 or #19 (both have NVME mod done). Then send me new FPT dump
[OFFER] ASUS P9X79 WS NVMe Mod (2)

The WS BIOS wont work with the IPMI version of the board. Tried already

RichC’s BIOS is regular WS BIOS, I thought you already flashed it? I guess you don’t have programmer correct? What do you mean tried already, tried flashing, or tried using and after flash it failed to boot properly? I assume flashing wont work, it’s different BIOS ID, but using is a different matter
We can put in 4901 BIOS region via FPT, but that wont help me get the dump I wanted and it might break ME for a while also while we test, but we can proceed with my test that way anyway.
Are you booting off NVME? Need to know, so I can add to the NVRAM removed 4901 stock test if you are

I downloaded the latest ws bios from asus, renamed it and it wouldnt take. Im booting off a samsung ahci

Yea, i just tried again with both flashback and ai suite. Wont take it

Yes, I assumed you can’t flash using normal methods to regular WS BIOS, no need to keep trying, it has different BIOS ID so you can’t do it that way.

So, your Samsung AHCI, is that NVME SSD or regular SSD? If you are not sure, give me the model number, or I guess it doesn’t matter, I can go ahead and add NVME module to any/all BIOS I send you.

Please add, or send a zip of all stickers on the board, be sure to look at side of 24pin and top/bottom sides of PCI/PCIE slots.
I will get you over onto regular WS BIOS and include your board details too.

Before that, I will find stock version of the board/BIOS you are using now, and remove the NVRAM for test as mentioned.
However, I assume that will be waste of our time, since I know the regular WS isn’t locked and I know I can put you onto that boards BIOS.

We may need to do a interim BIOS flash first, if ME in the latest WS BIOS is not same as you’re using now, but that’s not a gbig deal.
Once all is done, you will be able to flash normally using EZ Flash and stock WS Regular BIOS.

Non-NVME version SM951 i believe. Ill start taking pics of the board now.

Stickers. One might be blocked off by my gpu and i cant remove it right now since its watercooled.

Pics.rar (2.96 MB)

@MMFC378 - Thanks for the images, will check them over shortly. Please test flashing back your FPT backup you made earlier so we can see if error or not, if there is please show me image of the error
FPTw.exe -bios -f biosreg.bin

So i renamed the the biosreg to P9X79WSI.CAP. Couldnt get it to work with flashback but i did flash it in windows with AI Suite. No errors. Booted as normal