[Solved Problem] ASUS Prime Z390-A with wrong BIOS

Hello guys. First sorry for bad english. So i have this motherboard. I flashed wrong bios with afudos. I bought a CH341A programmer and accidentally flashed the wrong chip “25X05CLNIG- 64KB” chip and not the real bios chip. I thought this is the bios, but not, the bios chip is next to the battery it’s a GIGADEVICE chip (25B127DSIG, 128Mb). I can’t turn on the mobo anymore when i pressing the power button nothing happened. No fan spinning, debug leds not working. Nothing. Possible to save the motherboard or i can use only paper weight? If i get the same motherboard and save the rom from this chip and write back to my mobo will it work?

Edit by Fernando: Thread title customized

  • Short cmos jumper, take off cmos battery, unshort jumper, power on psu (so mobo receive power)
  • try to flash it with CH341A app v1.18 or 1.29, use the gigadevice GD25Q128 option and detect (since it’s 128Mbit, then program it and verify make sure everything the same (buffer same),
  • do not unplug soic clip if you use it, short cmos jumper again, unpower psu and press and hold power button for 5 seconds, plug cmos battery, unshort cmos, boot up like normal

Blockquote If i get the same motherboard and save the rom from this chip and write back to my mobo will it work?

I think this is a good way

I tried this, but no difference. Mobo won’t power on. The winbond chip is erased so need rom for it.

Just flash the rom?

Download the mobo bios, extract it using uefitool from.cap, and flash it.

Yes flashed the gigadevice chip with bios. And what the other chip? The programmer shows value are “FF”. nothing on a chip.

Well, that’s expected after trying to flash, most programs erase the chip first, meaning writing FF to it.

Chip is EC SPI Flash.Taking its content from another identical same revision board and flash it back might work.

There are some used boards on ebay, I think it’ll be quite hard or impossible to find the dumped content of this chip somewhere, and I doubt you’ll find people reading it out just to do you a favour- might at least take some time.

Don’t erase an unknown chip without having checked at least if the size fits and without taking at least a valid backup/dump first.

This is was my mistake. I was convinced this is the bios chip.
" Chip is EC SPI Flash.Taking its content from another identical same revision board and flash it back might work. " Wow nice information, thank you.

Guys, i got same motherboard. I saved the rom from the chip and flashed back to my mobo, and it WORKS!!! WoWW. I can’t believe. Works perfectly. Thanks for the help guys. :wink: Have a nice day.

Now… as a good forum user and if you want, since its an unusual dump of the specific chip, the community will appreciate if you can share here for future users with common issue…but rare same situation and congrats on solving the issue, good luck.

1 Like

Yes, if somebody gets into a similar situation here is the dump for fix:
Chip places: Here
25X05CLNIG chip dump: Link
Motherboard revision : 1.02


Thank you, for sharing here with us, all the best.

1 Like

i might have failed a bios update. Im getting no q-leds on the z390. do you know if that would that be typical of a bad bios write?

What makes you think it’s a bad bios write? Normally there’s a correlation between a bad bios update and a brick? And a brick might have a lot of other reasons…

(Since you didn’t yet flash a wrong chip I’d recommend to start a separate own topic)

im just looking for an experienced answer.
I purchased/gambled on a known bad CPU.
It would post to BIOS after a cmos reset, or 1/4 of the time. I thought id update the BIOS using the internet utility through BIOS. I think i gave it an hour and then forced a shutdown, not observing any response. After the update the MB gave a red QLed for CPU, and i sort of figured it updated and the bios now detected that the cpu was bad. Then i got a new CPU and it doesnt show anything, no post no q-led as if there is no processor connected.

The cpu LED is lit before anything starts (at least at a Z490 board which has a Q-Code display, even if the bios isn’t doing anything- showing “00”- it might be ‘on’).

So there’s a possibility of bad hardware or a bad cpu, the bad cpu might’ve damaged the board which again damaged the good cpu?

You didn’t write specifications (cpu-types, board type, bios versions), so this is just speculative. Some cpus only work with later bios versions…

Possible paths:

  • Check components each with know good hardware (but might damage the hardware)

  • Dump the bios with a programmer (valid backup at least two 100% identical dumps made in separate processes), check if there are signs of corruption in the bios, if in doubt reprogram ( after havin checked that board specific inromation is backed up)

Ya it makes sense that the qled would be before anything.
I have an Asus Prime Z390-a. I cant think of anything that would have damaged it recently, but put simply i realize i dont want to believe the MB is failing although it might be.
The first “bad” cpu was an i7-9700kf and I no longer have it. The later cpu that i still have is an i3-9100F. Either should be compatible but i guess there can be different revisions that might impose incompatibility if that is a thing.

Assuming the MB is good.
Would there be no Q-LED, if a CPU wasnt installed at all?

Hello, could you upload this chip file again

Hi, I have the same problem.
I had a conversation with the asus support, but they told me they have no file for this chip.
Can you reupload the file pls?

25X05CLNIG.zip (29.3 KB)

(I hope this was the correct file?)