[Solved] Problem with Asmedia + Marvell 9215 S-ATA Controller - Running in IDE-Mode


I have a Z77 Mainboard with the usual 6 Intel S-ATA Ports which work fine in S-ATA Mode.

As I am using 10 drives I also use onboard AS-Media (106) and Highpoint Rocket 620 (Marvell 9215) S-ATA Controller, which both seem to run in ATA (IDE) mode, see picture attached:


These controllers also seem to provide the ATA channels 0+1 (2x) in device manager.

Any chance to change this?


@ mike49:
Welcome at Win-RAID Forum!

The 4 drives, which are connected to the ASMedia and Highpoint Rocket SATA ports seem to be the only ones, which are running in IDE mode using the ATA Channels 0 and 1.

What do you want to change? If you want to run the 2 ASMedia SATA ports in AHCI mode, you have to change the related settings within the BIOS.

Dieter (alias Fernando)

.Yes, exactly. The 6 drives connected to Intel ports are all doing fine.

Both controllers (ASMedia + Highpoint) are set to S-ATA, but windows recognizes them as ATA/IDE controllers. No chance to change this (usually I know what I am doing…)


(Just changed driver for ASM-Controller to msahci, but still no change…)
Thanks + regards,

EDIT by Fernando: Unneeded quoted text and empty lines deleted (to save space)

That is absolute normal. All IDE, SATA and AHCI Controllers are "IDE ATA/ATAPI Controllers".

What did you expect? According the Device Manager your storage configuration seems to be fine.
By the way: Where is/are your optical drive(s) connected?

Well, i did not expect those 4 ATA-Channels running in Ultra-DMA mode which are provided by the 2 additional controllers.
Or to put it other way round: The second SSD (Crucial M4, s. first screenshot) is connected to (onboard shared) e-SATA (ASMedia) but only gives me ~ 150 MB/s instead of ~ 500 MB/s if it were running in SATA3 mode. Boot-ROM of ASMedia posts SATA3 mode for connected devices btw.

Optical drive is a Sony BD-Writer connected via USB (do not use it that often so that is fine).
This is an own build sitting in a Fractal Design Define Mini and acts as desktop-PC + NAS for my LAN. More flexible than dedicated NAS-devices for my usage. Board used is this one:


One of the few mATX-Boards with 8 SATA-Connectors.

What happens, when you replace the generic MS AHCI driver by the AHCI drivers, which are provided by the manufacturers of the related SATA Controllers (ASMedia and Marvell)?
Another request: Please post the DeviceIDs of the ASMedia and Marvell SATA Controllers (right click > "Properties" > "Details" > "Property" > "HardwareIDs").

I already had ASMedia drivers installed (s. screenshot in first post), same problem.

For the Highpoint Rocket 620 (Marvell 9215) I already tried manual installation of 64-bit Win7 drivers (generic Marvell which are linked in this section of the forum; there are no dedicated drivers by Highpoint for this card) but windows refused these drivers.

Will come back this evening with the requested Device-IDs (I’m at work right now…)

ASMedia 106 (with driver installed):


Highpoint Rocket 620 (Marvell 9125 with msahci, did not find any other working driver for this):


@ mike49:
Thanks for the DeviceIDs of both SATA AHCI Controllers.
I don’t have any idea, why the Device Manager still shows 4 ATA Channels, although all IDE ATA/ATAPI Controllers are AHCI ones.
Please check, if any drives are connected with them, and if yes, which ones.

I found a suitable, but old driver for this Marvell AHCI Controller. Which architecture (32/64bit) do you need?

Yes, that is exactly my problem.

Meanwhile I think that my Windows gave wrong ClassGuid to the controllers, see here:


Both controllers have classguid for ‘HDC 4D36E96A-E325-11CE-BFC1-08002BE10318 Hard drive controllers’ whereas drivers are for this guid:
SCSIAdapter 4D36E97B-E325-11CE-BFC1-08002BE10318 SCSI and RAID controllers

I am quite sure that this is the reason, drivers do not install. I already tried changing classguid in windows registry, but no luck so far (just started…)

It’s 3 internal drives + (optional) 1 external drive (via e-SATA) and they all run in U-DMA Mode connected to those 4 ATA channels (see screenshot in first post)

It’s a 64-bit Windows 7

Attached is the 64bit Marvell AHCI driver v1.0.0.27 WHQL:

Marvell AHCI driver v1.0.0.27 WHQL.rar (144 KB)

Thank you!

Now I have only 2 unwanted ATA-Channels provided by ASMedia Controller, all other 8 drives run in S-ATA mode:


Which ASMedia AHCI driver are you using?

I used the one provided by ASRock which seems to have caused the problem.

Just switched to newest (also linked here) and everything is fine now:


All 10 drives running in S-ATA Mode, finally

Thanks again for your great support!

Ok, it’s fine, that your problems could be solved at least.

Enjoy your optimized system!