<Solved> Radeon HD7970 3GB Voltages (Revision 2 Cards)

Hello folks, i got hold of a good cheap radeon hd 7970 3gb that seems to play any game i throw at it at 1080p paired with my ryzen 2700X, its the gigabyte revision2 card, and i hear its not possible to unlock the voltages on these, surely there must be a volt modding guide somewhere for these gpus, at the moment its at 1080MHz core and 1550Mhz Vram, it wont go any higher unless the voltage is raised, it’s pretty easy to increase the voltages on the V1 cards as they are factory unlocked, but the v2 is a tough nut to crack.

Apart from this i am very pleased with the performance of the card but i know locked away is much more grunt, especially on water

At the moment maxed out the temp hits 59c on stock windforce air cooling which i find pretty impressive! even then the fans are only set to 50% on the card and are very quiet.

If there’s anyone out there that knows of any way to add more voltage to my windforce HD7970 i would be very thankful if you could post your findings here, i have 30 years experience in soldering so that side of it wont be a problem.

Thank you.

Did you try flash V1 BIOS on it? Maybe only way is hardmod?


I havent tried that m8 no, cant find the bios for v1 m8

Right, i found the vbios for the first revision gpu, and guess what, before the stock clock was 1000mhz 1375vram, now its stock at 1100mhz and 1500vram, the card seems to be working well in a couple of tests ive done but guess what ive got the strangest issue, google chrome just loads a black page and nothing else! everything else on the pc is working great but it seems google chrome has somehow blacklisted it wtf!!

a quick look in gpuz tells me the max voltage has gone up too, and if the card is boosting up to 1100mhz it must be true, because before 1080 was the max speed i could hit, before it was 1.170v now its 1.256v

This is the one i flashed F62 dated 2013, https://www.gigabyte.com/Graphics-Card/G…support-dl-bios


Kets the master at this sort of thing, he will let us know whats going on.

Update the GOP version and that may help with the Chrome issue (or enable/disable GPU acceleration in Chrome, whatever that’s called in Chrome)
It’s cool you were able to get v1 vBIOS on there, can you now adjust voltages manually too?

Just skew the VRM signal if the card is voltage locked (no idea why it would be though) force it to give more voltage under load that way.

games working 100% 10fps increase
chromes working 100% after a reinstall of chrome
unigine heavens working 100%


I now have only one issue, after playing a game or benchmark entering the radeon settings causes the pc to lock up with lines across the screen, this tells me the vram or a voltage somewhere isnt set right.

GPUZ tells me the card for 3d is now 1.265v from the original 1.170v

The 3d voltage must be working ok as before 1100mhz was impossible

The issue lies in the ram speed, its stock was 1375mhz now with this bios flashed its stock is 1500mhz.

If i could manage to drop that ram down to 1475mhz somehow everything would work great, i have no idea how to edit a GOP UEFI bios.

I even tried flashing the R9 280x bios and that works too with the same 1500mhz ram issue though.




Yea its weird gigabyte chose to lock the voltages on the V2 version of the hd7970, but we all know how bad gigabyte can be lol


Im doing a lot of experimenting with the r9 280x bios, this is fun lol

@POE_UK - upload the vBIOS you are using now (both, the V1 and the 280X), maybe I can change the ram speed?

You can edit a lot of properties for the HD7k series with VBE. I definitely would not use the incorrect vBIOS on any GPU it will cause a lot of strange issues. What memory is the HD7970 fitted with? If you’re using a vBIOS thats intended for Elpida but the card is fitted with Hynix thats going to cause huge problems. Old cards like the 7970 are nothing like newer cards you HAVE to use a vBIOS intended for the memory fitted to the card, and numerous other factors, hence, stick to the original vBIOS upload a copy of the original and I’ll take a look at it. It would also be useful to have a picture of the cards PCB so I can check what voltage controller it’s using.

EDIT: I took some educated guesses and modified this firmware, its about the latest the 7000 series ever got (15.34), supports both Hynix and Elpida memory, I guessed your card has 1x6pin and 1x8pin PCI-E connects and adjusted the firmwares TDP to 250w which means with the power limit slider maxed out the card will draw up to 300w (75w slot + 75w 6pin + 150w 8pin = 300w), I also changed the temperature hysteresis and curve to something thats much more balanced and will keep the card cooler for longer once the GPU reaches 70c the fan will ramp to 75% which theoretically shouldn’t be too loud, that depends on the cooler though. Memory clock I rounded up to 1400MHz, and GPU VDDC I increased to 1.225v - should be enough for 1100MHz+. Only thing left to guessing with this firmware is the voltage controller I had to siply guess its a chill controller, but might not be the case for your card.

Custom7970.zip (99.4 KB)

@Ket thank you so much,

The card has hynix memory, its a v2 card (windforce) you are right, i can edit the bios with the vbe editor but i use it in uefi mode so i can only merge the factory uefi image otherwise the ram will run at 1500mhz and crash

To cut a long story short its the uefi gop settings i need to sort out, the only gop i can find to merge are ones with 1.17v and this is useless it caps the vcore to 1080mhz, either 1.25 or 1.27v would be ideal, ive got it working ace in BIOS mode 1100mhz core and 1400mhz ram, but again in uefi mode it goes to 1100/1500 its the 1500mhz ram setting in uefi mode thats causing problems it needs to be lowered to 1400 or 1450 but i have no idea how to do this.

This is my card


id like to raise the voltage to 1.25 from 1.17 and clocks to 1100mhz/1400mhz in uefi mode if possible, thank you mate.

i have tested these clocks and voltages in BIOS mode its rock solid.

This is the bios im using: bios works well = uefi the rams too high.


HD7xxx Series UEFI Patch Tool BETA is what im trying to use to add a working gop



All sorted!

You wont believe why radeon settings were crashing in uefi mode, it was my damn memory timings!

It now runs smooth as silk at 1100/1500

who would of thought ram timings alone could have cause this issue lol!

@POE_UK - I thought maybe you catch on after seeing my silent edits, without me having to say something, but I see maybe not Please edit your posts if you want to add more info and no one has replied yet, thank you.

Glad to see you sorted all this out without need for me to try editing stuff for you!

Did you try the vBIOS ket made you?

Thanks also @ket

Ok @Lost_N_BIOS what have i done wrong? lol

@ket thanks mate, your bios works but in uefi mode its still only 1.17v if you could inject 1.2v into it for me that would be fantastic.

GOP work can be tricky and time consuming, I’ve never bothered with editing the GOP. Heres a link that might help you though clicky.