[solved] specific AHCI/SATA-Driver urgent needed (Motherboard Asus B85-PLus)

The Intel RST driver v11.2.0.1006 is the last one, which supports Windows XP. All later released Intel AHCI/RAID drivers don’t have a file named txtsetup.oem, which is required for the XP installation.

hm… it is a little weird,

the PC don’t run like expected - it needs for example much too long to shutdown. There is almost nothing installed except the Needful Things for nLite (Nero etc), it shouldn’t take so long to shutdown but with this I could live.
But sometimes he have also Startup problems. I start, it runs through the BIOS-Dialogue and than - end of the story, he is doing nothing anymore, no Bluescreen, no startup, when I start again it works (sometimes I need to start 2 or 3 times)
Acronis seems to run - but also in a way that I have the feeling, it is not everything correct.
I still use installations with the DEV_8C02 version, maybe it would help trying the DEV_9C02?

No, that wouldn’t help at all.
By the way: You can check the correct DeviceID by running the Device Manager, explanding the “IDE ATA/ATAPI Controllers” section, doing a right click onto the Intel SATA AHCI Controller and choosing the options “Properties” > “Details” > “Property” > “HardwareIDs”.
It would be better to run the Device Manager and to look for yellow flags.
Which third party software is running in the background (Antivirus etc.)?

hi Fernando,

3 yellow Flags:
- Audiodevice (this is ok, I didn’t installed the Soundcard on the Motherboard because I use my own Audiocard)
- Unknown device - very funny, how shall I install it if it is unknown :slight_smile:
- USB Controller (this I don’t understand because I installed this Reneseas USB-Thing for the USB 3.0 devices and there are a lot of installed USB’s)

when I check Properties of IDE ATA/ATAPI than your Driver is mentionend (what else), Details:
PCI\VEN_8086&DEV8C02&SUBSYS85341043&REV_05\3&11583659&0FA (I hope I didn’t made any tippos now)

3rd Party Software: only known which I use since a while:
- Nero Burning Rom 10.5.10300
- UltraIso 9.3.6
- WinRAR 4.00 (german)
- nLite
- and surely also the basic Drivers:
* Motherboard Chipset, MEI (Managment Engine Interface), Realtek LAN (not needed yet because the PC is not on the Internet but for basic installations)
* GraphicCard ATI-XFX 5700 Series
* Soundcard Asus Xonar D2
- normally I run also Acronis Home but right in this version it isn’t installed yet (and I had already once this start-up-problem 20 minutes ago)

for I’m in the Testphase and just run windows at the moment for testing and building nLite-CDs there is no need for more

Edit: by the way: every new Winows Version is made with a fresh, clean Windows

Right click onto it, choose “Properties” > “Details” > “Property” > “HardwareIDs” and try to find out the VendorID and the DeviceID.

AFAIK USB 3.0 Controllers are generally not supprted by Windows XP.

This verifies, that you have integrated the support of the correct Intel SATA AHCI Controller. The SUBSYS doesn’t matter.

The latest WinRAR version is 5.30.

whatever an AFAIK is :slight_smile:

I don’t know what a vendor is or so but the Details in the [unknown device] are:
ACPI\PNP0A0A\2&DABA3FF&0 (which looks a little short to me),
also the 4th Rider [Resources] is missing there

It seems to be an ASUS ACPI driver.
Tip: Do a Google search for “ACPI\PNP0A0A\2&DABA3FF”.

I did the search and it become now much more mysterious - some user report, they have trouble with and without have installed this thing and that ASUS did there a very un-documentated thing with this interface. However, Asus Website doesn’t support this for XP and so I have to leave it as it is. But after some users-comments I have read, I’m thinking now, that this maybe cause the start-up-troubles

ok for good now.

I do here a little summary, so not everybody need to read the whole Thread:

my problem was fixed with Fernandos kind and patient help. The needed AHCI/SATA-Driver for my Motherboard was found from Fernando himself here Modded Intel AHCI and RAID Drivers (digitally signed) (choose: Universal 32bit Intel RST AHCI+RAID driver v11.2.0.1006 mod+signed by Fernando).
The neccessary driver in this set for me to choose in nLite was the DEV_8C02 and nothing else

I have to say very much “Thank you” to Fernando, which is a real kind Guy with a lot of Knowledge: Thank you Fernando
I keep this Thread a while on my watchlist, maybe something more happen here. If not, the Thread can be marked as “solved”

Thanks for your final report.
Enjoy your Windows XP running in AHCI mode.